1. jeremyr4's Avatar
    *** UPDATE: BATTERY DRAINING SOLVED - See Post # 12 below for how I solved this problem. I hope it is helpful!!! ***

    I have been using the official Verizon 10.3.1 (that came with my phone) and just recently updated it 10.3.2. Aside from some minor (but annoying) bugs, my battery is draining MUCH faster than before. I was really happy with the battery life prior to the update but now it's literally draining 1.5-2x faster without any changes to my overall use or apps that I use. So before it would last 20 hours and now it's essentially lasting 10-12 hours.

    Is anyone out there experiencing the same problem with their Verizon Classic? I'm trying to figure out whether something is corrupt (in which I am guessing I would need to wipe it?) or whether 10.3.2 just happens to drain much more quickly. Is there a way to downgrade back to 10.3.1?

    Thanks very much,
    Jeremy
    Last edited by jeremyr4; 06-25-15 at 12:25 AM.
    06-23-15 01:49 PM
  2. Mmickel Abraham's Avatar
    My Classic is having the same Battery results. About I day of heavy use.

    Posted via CB10
    06-23-15 01:52 PM
  3. jeremyr4's Avatar
    My Classic is having the same Battery results. About I day of heavy use.

    Posted via CB10
    Thanks for your response - I appreciate it. To confirm, do you mean that your 10.3.2 is having the same battery life as 10.3.1 or do you mean that your battery life on 10.3.2 is the same as mine? Sorry but I wasn't sure what you meant by "the same" - thanks.
    06-23-15 02:01 PM
  4. kvndoom's Avatar
    You cannot downgrade back to 10.3.1. The most you can do is try some of the leaks and see if they improve performance, but 10.3.2.680 is the lowest version you can now install on your phone.

    Posted from BlackBerry Classic, Verizon, no camera, 10.3.2.840
    06-23-15 02:55 PM
  5. rhoric's Avatar
    How long ago did you update to 10.3.2 as remember with any OS update you have to give your phone 24-48 hours for things to settle back down. I have 31% left on my battery and I took it off the charger 21 hours ago and have been doing moderate use on it.
    06-23-15 04:41 PM
  6. yessuz's Avatar
    you canot go back to anything beow 10.3.2.500

    Now, read this:
    http://forums.crackberry.com/blackbe...l#post11733995
    06-23-15 04:51 PM
  7. davisgq's Avatar
    I have been using the official Verizon 10.3.1 (that came with my phone) and just recently updated it 10.3.2. Aside from some minor (but annoying) bugs, my battery is draining MUCH faster than before. I was really happy with the battery life prior to the update but now it's literally draining 1.5-2x faster without any changes to my overall use or apps that I use. So before it would last 20 hours and now it's essentially lasting 10-12 hours.

    Is anyone out there experiencing the same problem with their Verizon Classic? I'm trying to figure out whether something is corrupt (in which I am guessing I would need to wipe it?) or whether 10.3.2 just happens to drain much more quickly. Is there a way to downgrade back to 10.3.1?

    Thanks very much,
    Jeremy
    Mine has been stellar since the update. Not that it was bad before. May be an app? And as others have mentioned, usually need to wait a day or two for the OS to settle down.

    Posted via CrackBerry App
    06-23-15 05:00 PM
  8. BKA22's Avatar
    I have a verizon z10 and my battery has been draining about the same as the OP since going to 10.3.2. Ive done 2 blitz and one autoloader keeping up with the 10.3.2 leaks and it hasnt changed. In fact, im backing up my phone as we speak and I am going to autoload 10.3.2.2204. I have it loaded now but I did it via blitz a couple weeks ago. Im hoping to get better results this time.
    06-23-15 05:51 PM
  9. jeremyr4's Avatar
    Thanks for everyone's responses - I appreciate it. I should have mentioned that I update my phone about a week ago and, at first, I figured the drain was due to the new OS settling down but I'm clearly past that point now. I'm wondering if perhaps something is corrupt, as it doesn't seem like anyone is having this type of issue except for me... (go figure!)

    The only thing I can think of is my WiFi has shown an error a couple of times so I now deleted the saved profile and tried it again. If it doesn't clear up within a day or two then I will probably try to reload the OS via BB Link.

    If anyone else has any suggestions I would be happy to try them. Thanks for everyone's help!
    06-23-15 06:36 PM
  10. slagman5's Avatar
    Notice any difference in your reception? Like is it worse than before? Sometimes that can be the biggest battery drain. If it's worse, see if maybe you can load a different radio file on it.

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    06-23-15 07:23 PM
  11. jeremyr4's Avatar
    Notice any difference in your reception? Like is it worse than before? Sometimes that can be the biggest battery drain. If it's worse, see if maybe you can load a different radio file on it.

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    Thanks for the suggestion. Reception seems comparable but, frankly, I was always getting 1 or 2 bars so it's tough to say whether it has changed, as it's similar.

    In reading the link posted further above, I wiped my save WiFi network, as it had displayed a couple errors over the past couple of days which I believed has never happened before. I'll see if that helps.

    Thanks,
    Jeremy
    06-23-15 07:49 PM
  12. jeremyr4's Avatar
    I have a verizon z10 and my battery has been draining about the same as the OP since going to 10.3.2. Ive done 2 blitz and one autoloader keeping up with the 10.3.2 leaks and it hasnt changed. In fact, im backing up my phone as we speak and I am going to autoload 10.3.2.2204. I have it loaded now but I did it via blitz a couple weeks ago. Im hoping to get better results this time.
    I'm the OP and I did something earlier today that might have fixed my problem that you might want to check. My WiFi network, which hadn't changed at all when I upgraded, was showing a "network error" intermittently that was causing my WiFi to be disconnected on my phone (meaning that I wasn't connected to my network when I looked at my WiFi status on my phone. I'm guessing perhaps my network profile got corrupt during the upgrade because I deleted the network as a saved network, reconnected to it, and at least for the past few hours my battery drain seems to have stopped or at least is declining at a much more similar pace to my previous 10.3.1.

    So, similar to the link that was posted earlier in this thread, I would recommend you check all of your wireless connections (including WiFi and others) to see if any errors are showing. If they are then delete the profile and reconnect to see if it solves your problem.

    I'll try to post a status update tomorrow night after I have had a good day to verify my battery drain. So far I'm cautiously optimistic

    I hope this was helpful.
    Nanker Phelge likes this.
    06-23-15 09:26 PM
  13. jeremyr4's Avatar
    I'm the OP and I can now confirm that my battery draining problem is solved. See my previous post just above with an explanation of how I solved this problem. I hope it is helpful!!!
    06-25-15 12:26 AM

Similar Threads

  1. Replies: 7
    Last Post: 07-11-15, 12:17 PM
  2. Anybody get the Uber app to work?
    By illwill718 in forum BlackBerry 10 Apps
    Replies: 5
    Last Post: 06-29-15, 09:07 AM
  3. Replies: 2
    Last Post: 06-24-15, 08:58 PM
  4. Replies: 5
    Last Post: 06-23-15, 02:42 PM
  5. Replies: 2
    Last Post: 06-23-15, 02:11 PM
LINK TO POST COPIED TO CLIPBOARD