1. dan_slack's Avatar
    Hi all,

    I've just noticed that search in hub shows results extremely slowly. Sometimes it take even one, two minutes long.
    Done a Hub restart, by swiping five times down from top right corner, it appeared to go well for one word (search term), or two, but then it takes forever to show some results.
    Any clues?
    Thanks.
    Dan

    PS. Just restarted the device... same!
    02-24-15 03:02 PM
  2. classicrock31's Avatar
    I have experienced the same lag or sometimes I get no response at all. Other times I get a response about the search came back with no results when doing a remote search. The remote search is for email that is older than the email sitting in my device. Searching for texts works when it does in fact work. When I do want to look for a particular word or phrase in my texts I go in to the text messages and search from there. It does seems to work faster when filtering...

    Posted via BB Classic
    02-25-15 08:34 AM
  3. Just Me's Avatar
    Terrible on my Z10. Not so bad on the Passport.

    Posted via CB10
    02-28-15 10:13 AM
  4. nagyr's Avatar
    Any soluion on that?
    03-02-15 06:21 PM
  5. joan006's Avatar
    I just tried my search function and it worked fine. I only looked up contacts phone numbers tho. Like I typed, "Dad", and his phone number, email and text info popped right up!
    03-02-15 07:22 PM
  6. joan006's Avatar
    Don't know where that wink face came from. I typed dad
    andy n likes this.
    03-02-15 07:23 PM
  7. jj311's Avatar
    This is a huge issue for me also. Minutes to search when you are in a rush is ridiculous. Usually i give up...i wanted a smart phone. Even upgraded to passport because i heard it is faster so thought that would do it. Not the case. It is bad in hub and contacts, but hub is worst. They need to fix this it is even embarrassing. You are searching for something with a friend looking on and laughing at how slow it is "that's why no one uses blackberry anymore". Hard to defend it.

    Posted via CB10
    03-25-15 11:34 PM
  8. kberube911's Avatar
    Z30 would be super fast with this. Now the classic seems to lag. One of the few drawbacks in my switch. Overall I am happy

    Posted via CB10
    03-26-15 05:48 AM
  9. Kamika007z's Avatar
    I have this issue as well.

    It used to be instantaneous in 10.2.x, but under 10.3.x it has been horrible. It sometimes takes as long as 4-5 minutes for my results to show (VZW Z30 running OS 10.3.2.2252).

    Can someone please report this to BB via bugtracker if they have access?

    Thank you!
    06-22-15 10:30 AM
  10. Nicholas Mauro's Avatar
    My hub search works well. I have texts, bbm, whatsapp, 2 Gmail accounts, and inst10.

    Do you guys have loads of unread emails? I remember Facebook performing slowly when deleting or replying to hub notifications. I removed facebook from thhe hub and my search works well.



    Posted via CB10
    06-22-15 10:38 AM
  11. motec bb's Avatar
    Ya mine is also very slow, on 10.3.2 but I find that anything I am searching for can usually be found also in the BlackBerry assistant search.

    Q10 on 10.3.2.2204
    06-22-15 11:15 AM
  12. Kamika007z's Avatar
    My hub search works well. I have texts, bbm, whatsapp, 2 Gmail accounts, and inst10.
    Do you guys have loads of unread emails? I remember Facebook performing slowly when deleting or replying to hub notifications. I removed facebook from thhe hub and my search works well.
    Posted via CB10
    I don't use FB. I have 1 Exchange and 2 Outlook/Hotmail accounts. On Exchange (showing 30 days worth) I do have subfolders selected since I use rules to automatically move specific emails to their respective folders - which was the same config in 10.2.x but never had this issue.
    Last edited by Kamika007z; 06-22-15 at 12:36 PM.
    06-22-15 12:06 PM
  13. yasmar's Avatar
    Also slow on my Passport (10.3.2)...even if I filter to 'text messages' and search a name, it takes 10-15 sec..and I hardly text anybody so there are very few SMS contacts to search through.

    BlackBerry Assistant works fast though
    07-30-15 11:24 AM
  14. VeryBumpy's Avatar
    Yup, Hub search is snail like. Heck, I consider most things my Classic does snail like compared to the Curve I had.
    08-01-15 06:03 AM
  15. Kamika007z's Avatar
    Any updates on this thread?

    The issue is still present.

    ...hopefully 10.3.3/4 will correct this, but I highly doubt it.
    04-08-16 08:45 AM
  16. undefinederror's Avatar
    I don't have any trouble. Search results pop up within a second for me.

    I have texts, BBM, one outlook account(with a 30 day sync time frame, 63 items in the hub right now), and one POP email account(with a 30 day sync time frame as well, and 334 emails in the hub right now).

    I find that searches are even faster if you open the left pane of the hub, and select a specific account before performing the search. have you tried this?

    Posted via CB10
    04-08-16 11:51 AM

Similar Threads

  1. LGBT in the United States
    By bredamota in forum Discover BBM Groups
    Replies: 33
    Last Post: 07-26-18, 12:30 PM
  2. Battery life very bad after updating to new OS 10.3.1.1565
    By zene zene in forum Ask a Question
    Replies: 5
    Last Post: 03-12-15, 12:33 PM
  3. Do Microsoft outlook.com Aliases work in 10.3?
    By lindaandjon in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 03-11-15, 05:56 PM
  4. REPLY NOW feature limited to BBM only in 10.3.1
    By bbbkkk in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 02-24-15, 03:26 PM
  5. Replies: 3
    Last Post: 02-24-15, 02:55 PM
LINK TO POST COPIED TO CLIPBOARD