1. ericssan's Avatar
    Hi all,

    I have just bought a classic but it just couldn't detect my micro SD cards ( sandisk 16 GB & 32 GB). I put it carefully & even rebooted it several times to no avail.

    Please help

    Posted via CB10
    04-14-15 06:02 PM
  2. anon(9208252)'s Avatar
    Did you format it by chance,
    04-14-15 06:59 PM
  3. ericssan's Avatar
    No I did not. Both cards r okie. Now both cards aren't recognised that card is in BlackBerry.

    Posted via CB10
    04-14-15 08:57 PM
  4. bbinoz's Avatar
    When I put in my SD card from my previous phone (Bold 9900) I had to format it in order for it to work.

    Settings > Storage and Access > Format Media Card

    * This will wipe everything that is currently on your media card, put it into a computer and perform a back-up first unless it is a brand new card or doesn't contain data you want to ever see again.

    BlackBerry Classic = Corporate User Perfection!
    04-14-15 11:39 PM
  5. ericssan's Avatar
    The issue is I have put this same micro SD into passport before and it works fine

    Posted via CB10
    04-15-15 04:54 AM
  6. ericssan's Avatar
    I bought a card reader. One card is faulty. Totally can't read. Must be corrupted. The other could be reformatted on computer. I pop back into classic, it works!

    Thanks all. My classic is ok & well.

    Posted via CB10
    04-15-15 07:11 AM
  7. HarryLime's Avatar
    Just purchased a Classic yesterday and I'm having this issue. I came from a Z30 and was using a 16g SD card. It's not being recognized by the Classic. I popped it back into the Z30 and it's read just fine as it is in my wife's Note 4. It's also recognized by my PC. Whats even more odd is that I get a brief message when I put the card in confirming it's been inserted but it's not picking up any data. It'd not recognized by the BBVE or the File Manager. I transferred the data over to my PC and reformatted the card and the phone is still not reading it. Does anyone have any other ideas?

    Posted via CB10
    07-12-15 11:09 PM
  8. HarryLime's Avatar
    Bumping this up, I've read a few forum posts on this issue with various devices and they all seem to trail off so I'm not sure if folks found resolution for this issue.

    Posted via CB10
    07-13-15 09:17 AM

Similar Threads

  1. Replies: 6
    Last Post: 07-30-15, 05:44 PM
  2. Android YouVersion bible app not working
    By Applevine in forum BlackBerry 10 OS
    Replies: 13
    Last Post: 05-10-15, 12:13 PM
  3. Why does my Z10 not charge when powered off?
    By Muffella in forum BlackBerry Z10
    Replies: 21
    Last Post: 04-19-15, 03:35 PM
  4. Why can I hear a caller but they can't hear me (Q10)?
    By CrackBerry Question in forum BlackBerry Q10
    Replies: 6
    Last Post: 04-14-15, 10:35 PM