1. elipsen's Avatar
    From time to time, my Classic doesn't show the caller ID for incoming calls. Approx. one of ten calls shows the incoming phone number only. My contact list is synced from iCal. Any ideas?

    Posted via CB10
    02-16-15 02:03 PM
  2. elipsen's Avatar

    Posted via CB10
    02-16-15 02:03 PM
  3. werkregen's Avatar
    I have the same problem. I fiddled with the smart dialer and changed the format of my numbers so they are all the same, to no avail. Sometimes a person would call and show me the caller ID and 10 minutes later when the same person calls I can see only the number.
    02-16-15 05:03 PM
  4. MobileMadness002's Avatar
    Does the callers phone number display on the screen? If so, that is Caller ID. The name will depend on what is listed in the contact details. That being said, also the number has to match what the providing carriers sends to the device as the caller phone number. +19999999999 does not match 1 (999) 999-9999. Sucks supremely, but it is what it is. Some carriers do not send the +1 or whatever the country code is.
    02-16-15 05:19 PM
  5. elipsen's Avatar
    The phone shows the number, so I guess the actual caller ID is ok. I have the country code in all my contacts, but I'm not sure if my carrier sends it to the phone.

    The names show nine of ten times and then the same caller is presented by number only, so this cannot be anything than a bug? If so, this is a joke; even my basic Nokia didn't mess with this basic function 20 years ago...

    Posted via CB10
    02-17-15 01:04 AM
  6. werkregen's Avatar
    I'm trying this at the moment (I'm using google to sync):
    - exported all contacts to excel. edit out all ( ) + . and extra spaces. (to look exactly how the carrier shows it)
    - deleted all contacts from google
    - deleted all contacts from BlackBerry
    - reboot
    - copy back to Gmail and let it sync with BB
    - reboot
    - delete from call log all entries that contained any extra characters (luckily only 1 month old)
    - reboot

    Will try if above method doesn't work:
    - copy all numbers to local (can't do it if contacts are merged so you have to do it when they are first copied to the phone with automatic merging disabled)
    - add + in front of all phone numbers so it's in international format (even though the carrier doesn't show it this way)

    Will do if above methods don't work:
    - switch back to android

    Tried and didn't work:
    - unmerged and disabled automatic merging
    - changed national number count
    - changed a few numbers with or without + for testing purposes

    I can get past bugs, inconsistencies and poor battery performance with android apps, but not being able to know who is calling me is a deal breaker. I had no such problems on nokia, iphone or android - all synced in the same way with google.
    02-17-15 06:46 AM
  7. Zeratul57's Avatar
    I moved mail to office 365 and you can for 4 bucks a month. Couldnt be happier. Perfect active sync performance.
    02-17-15 07:38 AM

Similar Threads

  1. How do I change the ID on my Q5?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 02-16-15, 08:12 PM
  2. Why do incoming message icons no longer appear on my home screen?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-16-15, 08:08 AM
  3. Talk2Watch Pro updated with caller ID support and access to the Pebble appstore
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 02-16-15, 03:40 AM
  4. Replies: 2
    Last Post: 02-14-15, 01:55 PM
  5. Replies: 2
    Last Post: 02-14-15, 05:51 AM