1. DOCTOREVIL8's Avatar
    Just purchased a brand new BlackBerry Classic off Kijiji. It's still sealed in the box before purchase. What a beauty inside the box.

    The Classic wouldn't turn on. Held the power button for 20 seconds. Nothing. Plugged it in and the battery was at 0%. After hitting 5% and still plugged in, the OS starts and I can configure the device.

    The big question. Should I be concerned? This is the first new device where the battery is empty.

    Posted via CB10
    08-09-16 08:04 PM
  2. anon(9742832)'s Avatar
    Just purchased a brand new BlackBerry Classic off Kijiji. It's still sealed in the box before purchase. What a beauty inside the box.

    The Classic wouldn't turn on. Held the power button for 20 seconds. Nothing. Plugged it in and the battery was at 0%. After hitting 5% and still plugged in, the OS starts and I can configure the device.

    The big question. Should I be concerned? This is the first new device where the battery is empty.

    Posted via CB10
    The long and short of it is, lithium-ion batteries do not like going to zero. But once or twice will not hurt the battery. Take the battery up to full charge and recharge every night, keep an eye on the longevity of the battery. It should improve as the battery starts to cycle. If not then send it back.
    raino and IndianTiwari like this.
    08-09-16 08:12 PM
  3. DOCTOREVIL8's Avatar
    The long and short of it is, lithium-ion batteries do not like going to zero. But once or twice will not hurt the battery. Take the battery up to full charge and recharge every night, keep an eye on the longevity of the battery. It should improve as the battery starts to cycle. If not then send it back.
    Great info to know. Thank you. I downloaded Battery Guru after it had fully charged and the phone now has 1 cycle count.

    Now I can't get my Rogers/Yahoo accounts to work.


    New Classic, dead battery-img_20160810_162658.jpg


    Any suggestions? I've tried security wipes, just did an AutoLoader, no joy. The accounts I use work fine on my Passport. I don't get it.

    Posted via CB10
    08-10-16 04:17 PM
  4. anon(9742832)'s Avatar
    Great info to know. Thank you. I downloaded Battery Guru after it had fully charged and the phone now has 1 cycle count.

    Now I can't get my Rogers/Yahoo accounts to work.


    Click image for larger version. 

Name:	IMG_20160810_162658.jpg 
Views:	163 
Size:	21.5 KB 
ID:	406022


    Any suggestions? I've tried security wipes, just did an AutoLoader, no joy. The accounts I use work fine on my Passport. I don't get it.

    Posted via CB10
    Did you do a hard restart?
    IndianTiwari likes this.
    08-10-16 04:21 PM
  5. Drenegade's Avatar
    Similar thing happened to me. I bought a brand new in the box Classic from Staples and it wouldn't turn on. Plugged in for 3 hours and nothing. No lights no screen nothing.

    Brought it back to the store and the salespeople figured I was trying to rip them off. Maybe they thought I switched out the classics and put an old broken one in the box. The salesman wanted to check the serial number and I warned him that the back cover wasn't removable. He wouldn't listen and broke it off.

    He looked embarrassed and gave me another classic. That one was also a piece of **** with loose keys and weird clicky tool belt buttons. Returned it and got my money back.

    Posted via CB10
    08-10-16 04:32 PM
  6. anon(9742832)'s Avatar
    Similar thing happened to me. I bought a brand new in the box Classic from Staples and it wouldn't turn on. Plugged in for 3 hours and nothing. No lights no screen nothing.

    Brought it back to the store and the salespeople figured I was trying to rip them off. Maybe they thought I switched out the classics and put an old broken one in the box. The salesman wanted to check the serial number and I warned him that the back cover wasn't removable. He wouldn't listen and broke it off.

    He looked embarrassed and gave me another classic. That one was also a piece of **** with loose keys and weird clicky tool belt buttons. Returned it and got my money back.

    Posted via CB10
    My friend had the same thing with a passport 3 duds in a row.
    IndianTiwari likes this.
    08-10-16 05:38 PM
  7. DOCTOREVIL8's Avatar
    Did you do a hard restart?
    How is a hard restart performed with the Classic? I've seen so many with volume buttons, some without, I have no idea which for the Classic.

    Posted via CB10
    08-10-16 06:12 PM
  8. anon(9742832)'s Avatar
    How is a hard restart performed with the Classic? I've seen so many with volume buttons, some without, I have no idea which for the Classic.

    Posted via CB10
    Re: How do you reboot the BB Classic
    Options

    ‎01-01-2015 01:46 AM
    Method 1) Graceful shutdown -- Hold the power button down, wait for the counter to count all the way down, then let go

    Method 2) Forced shutdown -- Hold the Volume Up/Down keys (together) down until the device fully shuts down.

    https://supportforums.blackberry.com...c/td-p/3038025
    DOCTOREVIL8 and IndianTiwari like this.
    08-10-16 06:21 PM
  9. DOCTOREVIL8's Avatar
    Re: How do you reboot the BB Classic
    Options

    ‎01-01-2015 01:46 AM
    Method 1) Graceful shutdown -- Hold the power button down, wait for the counter to count all the way down, then let go

    Method 2) Forced shutdown -- Hold the Volume Up/Down keys (together) down until the device fully shuts down.

    https://supportforums.blackberry.com...c/td-p/3038025
    Thank you. Thank you. Thank you.

    I don't know if the hard reset did it or if waiting a couple hours to try again was the solution, but I sure ain't complaining! I'm willing to bet it was the reset. Lost many hours on something so simple. Thanks again!!

    Posted via CB10
    08-10-16 06:57 PM
  10. anon(9742832)'s Avatar
    Thank you. Thank you. Thank you.

    I don't know if the hard reset did it or if waiting a couple hours to try again was the solution, but I sure ain't complaining! I'm willing to bet it was the reset. Lost many hours on something so simple. Thanks again!!

    Posted via CB10
    No problem, I have received the same kind of help side loading. Enjoy your phone.
    IndianTiwari likes this.
    08-10-16 07:08 PM

Similar Threads

  1. New Friendly Tech Talk!
    By BB10Clifton in forum Discover BBM Groups
    Replies: 65
    Last Post: 02-08-18, 07:26 PM
  2. BBM is chewing up battery life
    By bluetroll in forum BlackBerry Priv
    Replies: 7
    Last Post: 08-10-16, 12:05 PM
  3. When will Best Buy have the new Blackberry D50?
    By Trentp03 in forum Ask a Question
    Replies: 3
    Last Post: 08-10-16, 02:30 AM
  4. Insert new line in Blend BBM
    By kingstu in forum BlackBerry Blend
    Replies: 0
    Last Post: 08-09-16, 03:22 PM
  5. Replies: 1
    Last Post: 08-09-16, 02:46 PM
LINK TO POST COPIED TO CLIPBOARD