01-11-15 07:10 PM
42 12
tools
  1. SackHarry's Avatar
    So the classic I'm using, the battery goes down pretty quick, not sure if this is normal.

    It went from 64% to 52% in 30 minutes of not using the phone but just letting it sit on my counter..
    I started using the phone from 7am this morning at 100% and it's now at 40% and it's only 10am... this is with light internet usage no videos no phone calls...????

    This normal or I have a damaged phone battery?

    Posted via CB10
    Last edited by SackHarry; 01-01-15 at 09:10 AM.
    01-01-15 08:50 AM
  2. Xenolock's Avatar
    I think it has more to do with the initial 10.3.1 bugginess. My Z30 does the same thing sometimes, like it switches off charging at some point overnight but thinks the battery is still 100% in the morning. Then an hour or two in the day I suddenly lose 20%. The battery analyzer also seems confused, so I think it's a software issue. I'm interested to see if the new 10.3.1 leak solves these bugs.

    Posted via CB10
    01-01-15 09:10 AM
  3. SackHarry's Avatar
    This is completely ridiculous it went from 100% at 7am now at 35% at 10;17am
    Wow.

    Posted via CB10
    01-01-15 09:18 AM
  4. Xenolock's Avatar
    Ya, I saw similar things happening on the Z30 with 10.3.1.1154 leak, and other people reporting charging issues on their Classics. I'd give the new leak a try.

    Posted via CB10
    01-01-15 09:28 AM
  5. Alain_A's Avatar
    how long since you first got it?
    01-01-15 09:32 AM
  6. SackHarry's Avatar
    how long since you first got it?
    Like 1 week

    Posted via CB10
    01-01-15 09:47 AM
  7. VeryBumpy's Avatar
    One possibility, check the Device Monitor and see what's draining it. I have found an app that if left in Active Frame, sucks ridiculous amounts of battery.
    01-01-15 09:57 AM
  8. SackHarry's Avatar
    One possibility, check the Device Monitor and see what's draining it. I have found an app that if left in Active Frame, sucks ridiculous amounts of battery.
    The only active frame I had open were: phone, bbm

    Posted via CB10
    01-01-15 10:21 AM
  9. Alain_A's Avatar
    in the device monitor you can closed some of the app that are running in the back ground

    and I never leave any active frame open
    01-01-15 11:15 AM
  10. mad_mdx's Avatar
    Check your device monitor.
    Have you tried simply rebooting the phone?

    You didn't damage the battery but the software is acting a bit strange.
    01-01-15 11:30 AM
  11. SackHarry's Avatar
    Check your device monitor.
    Have you tried simply rebooting the phone?

    You didn't damage the battery but the software is acting a bit strange.
    How do you do the reboot again?

    Posted via CB10
    01-01-15 02:18 PM
  12. th.1977's Avatar
    Press and hold the power button.


    I have had serious drain issues on my z10 and the Batt monitoring led me straight to BBM. I did a reboot and it's been good since

    Posted from my z10 via cb 10
    01-01-15 02:54 PM
  13. gimjay's Avatar
    After your reset, go to your decide monitor and capture a snap shot and post it here so we can all help diagnose what the heck is going on. Good luck

    Posted via CB10
    01-01-15 03:08 PM
  14. miketko's Avatar
    I experienced the same battery drain issues. Decided to return the classic and grab the passport. Battery life is very important to me. I hope a simple OS update will resolve the issue with the classic

    Posted via CB10
    01-01-15 03:41 PM
  15. SackHarry's Avatar
    So I fully charged it to 100% and got 3.5-4 hours until it went to 10%...

    Is this normal, ppl with classics what are you experiencing with battery life?

    Posted via CB10
    01-01-15 06:15 PM
  16. Alain_A's Avatar
    So I fully charged it to 100% and got 3.5-4 hours until it went to 10%...

    Is this normal, ppl with classics what are you experiencing with battery life?

    Posted via CB10
    more than that for sure
    01-01-15 06:24 PM
  17. splatterb0y's Avatar
    How long did you have the device before posting about that behaviour?
    01-01-15 06:49 PM
  18. LatinoLoco24's Avatar
    Post your device monitor numbers. This is not normal behaviour for this phone's battery capacity. Two Classics in the household and both have respectable battery life. At least for our usage here.

    Posted via CB10 with the beautiful keyboard of the BlackBerry Classic
    01-01-15 06:59 PM
  19. SackHarry's Avatar
    Is my classic's battery damaged?-img_20150101_211716.png

    Posted via CB10
    Attachment 324733
    01-01-15 08:17 PM
  20. kanshuderen's Avatar
    Actually I have same problem, slightly use about 2 hours and lose about 30% battery power. Some time even do nothing, still lose power quickly.

    Posted via CB10
    01-01-15 08:24 PM
  21. SackHarry's Avatar
    Actually I have same problem, slightly use about 2 hours and lose about 30% battery power. Some time even do nothing, still lose power quickly.

    Posted via CB10
    Yup same thing with me even if I leave my phone on the counter and don't touch it I can notice the battery drains about 30% every hour

    Posted via CB10
    01-01-15 11:38 PM
  22. AmritD's Avatar
    I would say some android app might be doing this.

    Q5 SQR100-3/10.2.1.3442
    01-01-15 11:58 PM
  23. kanshuderen's Avatar
    Never install any android apps. For me, I find out the power goes quickly if without WiFi and under 4GLTE circumstance.

    Posted via CB10
    01-02-15 01:08 AM
  24. Timchuckbo's Avatar
    Same thing happened to mine when it was first shipped. But now I have great battery life.

    The key was to let it drain right down to nothing. This took many hours at 0% before it died. I then charged it up fully. Now the battery is a champ! Works well and I can almost get 2 full days with regular use.

    Posted via CB10
    01-02-15 06:18 AM
  25. Xenolock's Avatar
    Same thing happened to mine when it was first shipped. But now I have great battery life.

    The key was to let it drain right down to nothing. This took many hours at 0% before it died. I then charged it up fully. Now the battery is a champ! Works well and I can almost get 2 full days with regular use.

    Posted via CB10
    I'd second this. It seemed like mine wasn't reading the battery level correctly with 10.3.1

    From a Z30
    01-02-15 07:49 AM
42 12

Similar Threads

  1. Why does the browser on my Playbook ignore some searches?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-17-15, 07:51 PM
  2. Replies: 40
    Last Post: 02-13-15, 09:57 AM
  3. I just got my PP but dropped and dented bottom corner of SS bezzel
    By sportsbarismint in forum BlackBerry Passport
    Replies: 14
    Last Post: 01-01-15, 11:38 PM
  4. Why isn't my 9900 reading my sd card?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-01-15, 12:54 PM
  5. Replies: 1
    Last Post: 01-01-15, 05:42 AM
LINK TO POST COPIED TO CLIPBOARD