1. mattvallen's Avatar
    I recently purchased a classic online. The microphone does not work, it works with a headset and speakerphone. I returned the phone and received a replacement. The replacement has the same issue. I find it hard to believe they both have hardware issues. Any ideas? I’ve ran bbve and it doesn’t test the phone microphone only the speakerphone and headset. Thanks.

    Tried hard reset, soft reset.
    09-25-18 05:12 PM
  2. Niallac's Avatar
    Install a fresh version of the OS using an autoloader. If that fails to fix it, you are out of luck, short of stripping it down and trying a new microphone. Try eBay and eTradeSupply for the part.

    Posted via CB10
    09-26-18 02:26 AM
  3. curves2000's Avatar
    I recently purchased a classic online. The microphone does not work, it works with a headset and speakerphone. I returned the phone and received a replacement. The replacement has the same issue. I find it hard to believe they both have hardware issues. Any ideas? I’ve ran bbve and it doesn’t test the phone microphone only the speakerphone and headset. Thanks.

    Tried hard reset, soft reset.

    I doubt this is the problem but it could be dust/dirt perhaps. I had this issue with my Passport and I recently did a little cleaning. I took an old toothbrush and some eyeglass cleaner and I cleaned the speaker grills and the microphone as well.

    It appears to have helped so try that. Good luck!

    Posted via CB10
    09-26-18 03:30 AM
  4. mattvallen's Avatar
    So I think we are narrowing it down with the help of BlackBerry. I will need to do a reboot of the software from my computer before I can proceed, but we’ve found that the microphone works with the remember app, just not phone calls, so it’s definitley a software issue and not the microphone. More to follow.
    09-26-18 12:56 PM
  5. mattvallen's Avatar
    So @blackberryhelp was NO help. I ran some tests they asked me to do, we established it wasn’t a hardware issue, and they left me hangjng with “take it to a repair shop”. No hint as to what needed to be fixed. #useless
    09-27-18 07:32 PM

Similar Threads

  1. Replies: 10
    Last Post: 01-12-19, 05:09 AM
  2. KEYone Bluetooth and Volume issues
    By bikefiend in forum Ask a Question
    Replies: 1
    Last Post: 09-25-18, 05:30 PM
  3. Replies: 1
    Last Post: 09-25-18, 08:11 AM
  4. HUB+ Services BETA issue
    By jhimmel in forum BlackBerry HUB+ Suite
    Replies: 3
    Last Post: 09-24-18, 11:49 AM
  5. Issue with Office Suite
    By fixit1971 in forum BlackBerry KEYone
    Replies: 4
    Last Post: 09-24-18, 07:52 AM
LINK TO POST COPIED TO CLIPBOARD