1. StumptownBold's Avatar
    Hello!

    I've been trying to backup my Blackberry Classic (10.3.3.1463, Verizon). While it does connect to Link, I keep getting the error message:

    "Verify that your device is turned on and connected to Blackberry Link and try again"

    Thus, I'm unable to backup my device. I've removed and reinstalled Link several times, and disabled virus protection (as I read this elsewhere), but no luck.

    I'm running Windows 10 (everything is update to date). It's a newer laptop and I only have USB3 (and Thunderbolt port as well).

    Any ideas? I need to both backup my Classic and potentially do a reinstall of the software due to the phone powering itself off. Please help! Thank you!

    Attachment 427721Attachment 427722
    Attached Thumbnails Link issue:  "Verify that your device is turned on and connected to Blackberry Link and try again"-error-1.png   Link issue:  "Verify that your device is turned on and connected to Blackberry Link and try again"-error-2.png  
    07-26-17 10:42 AM
  2. Dunt Dunt Dunt's Avatar
    If you do a search.. you come to find that you are not alone in having issues with LINK. It's not "officially" supported on Windows 10 nor on USB3 Ports.

    Their are a number of different things to try and fix your issue... you do seem to be doing better than some of us as it seems to initially recognize your phone. As I said do a search and try some of these fixes....
    07-26-17 11:17 AM
  3. krazyatom's Avatar
    I had similar issue but fresh new installed window 10 didn't have issues so I concluded that itune was the problem. I didn't install itune with freshly installed window 10.

    Posted via CB10
    07-26-17 01:40 PM
  4. StumptownBold's Avatar
    thanks for your response. i don't have itunes on my computer. i wonder what else it could be.
    07-26-17 03:03 PM
  5. thoughtfulreader's Avatar
    I'm having this issue also. Has there been any solution found? Thanks!
    09-02-17 11:08 PM
  6. StumptownBold's Avatar
    I'm having this issue also. Has there been any solution found? Thanks!

    I used an old laptop with Windows 7 and the backup was successful. I also did a factory reinstall of software at the same time using a Windows 7 computer.

    Per other posts, it appears Link is not optimized for Windows 10.
    09-04-17 01:15 PM
  7. edensgardener's Avatar
    I finally got Link to work with Win 10! There were a few updates that didn't get loaded (in Windows), my IT guy updated those, and then I uninstalled and reinstalled LINK and it worked!!!

    So, be sure your updates are all current in 10, then, try uninstalling and reinstalling LINK - and do so, after rebooting. It was driving me CRAZY too! So hard to upload pics w/o LINK>
    09-04-17 03:22 PM
  8. David Hollister's Avatar
    Windows 10 will happily back up my Classic but not the Passport, although photos come across to the PC.
    Ten.

    Posted via CB10
    09-10-17 02:14 AM

Similar Threads

  1. How to do a complete backup?
    By coffee-turtle in forum BlackBerry Mobile Support
    Replies: 8
    Last Post: 08-19-17, 04:27 AM
  2. Text messages lost on Verizon
    By mdittyCB in forum BlackBerry KEYone
    Replies: 2
    Last Post: 07-26-17, 06:38 PM
  3. Any diabetics on BB?
    By No Quarter in forum Ask a Question
    Replies: 2
    Last Post: 07-26-17, 05:24 PM
  4. Stream app to MP3
    By cbr629 in forum Ask a Question
    Replies: 1
    Last Post: 07-26-17, 04:26 PM
  5. why can I not open/view jpeg, wave and pdf files attached to emails?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-26-17, 09:27 AM
LINK TO POST COPIED TO CLIPBOARD