1. transportin's Avatar
    I have found that the 4G signal is rock solid compared to my Z10. However, I find that I get 1 to 2 bars of LTE on the classic whereas I use to get a constant 3 to 4 bars on the Z10 on Rogers in Guelph, Ontario, Canada. The LTE signal on the classic is often changing between 1 and 2 bars. This is not a problem, as Internet browsing etc is quite fast.

    The Rogers classic has the same LTE frequencies as the Z10. The Rogers classic also has the 2600 frequency.

    Please share your experience with your classic.

    Posted via CB10
    01-13-15 07:07 AM
  2. _tC's Avatar
    The Passport camp will tell you their calls are faster. The Classic camp will tell you it's easier to end the call.

    Posted via CB10
    01-13-15 07:17 AM
  3. transportin's Avatar
    Lol!

    Posted via CB10
    01-13-15 07:20 AM
  4. LostOnThePianoRoll's Avatar
    I'll tell you something about crackberry.
    If you see no one complaining about it, then it's probably as good as it should be.
    We're fussy around here we don't let anything slip

    Posted via CB10
    _tC and transportin like this.
    01-13-15 07:23 AM
  5. transportin's Avatar
    I'll tell you something about crackberry.
    If you see no one complaining about it, then it's probably as good as it should be.
    We're fussy around here we don't let anything slip

    Posted via CB10
    Thanks. I'm sure it's not a problem. I'm just interested in becoming more familiar with my classic by hearing from other classic owners.

    Posted via CB10
    01-13-15 07:29 AM

Similar Threads

  1. WhatsApp: Can you send a message through the Contacts?
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 01-13-15, 12:46 PM
  2. I'm getting this on my phone screen www.bberror.com/bb10-0015 what to do?
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 01-13-15, 07:53 AM
  3. Why IP CAM Viewer does not work on my Q10 ?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-13-15, 07:29 AM
  4. Resetting the Hub
    By yank89 in forum BlackBerry Q10
    Replies: 1
    Last Post: 01-13-15, 06:47 AM
  5. How do I remove the notification?
    By uktivo in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 01-13-15, 06:10 AM
LINK TO POST COPIED TO CLIPBOARD