1. Akis Tsirogiannis's Avatar
    Okay - once I praised my classic, I immediately experience serious battery problems now!

    Yesterday, when battery was at 45% it suddenly shut down. When I put to charge the LED was yellow for 5 seconds, then turned GREEN, meaning it's fully charged (not the case of course) . When I start BB10 it says 100%, but performance is laggy and after some minutes it crashes.

    I wiped the device, but that didn't help.

    Since then same thing happens. I let it charging over night and it seems to charge, although it stays at 100% constantly, but today at 65% it shut down again.
    Once connected to charger, same issue : green LED, up to 100%...

    Battery charger app sais the health is 100%.

    I need help, especially cause I am travelling long term now...

    Thankful for any advice!

    Posted via CB10
    03-11-17 03:36 AM
  2. santoshwins's Avatar
    Have you tried charging with a different charger and cable setup. This is a rather simple advice but might be helpful?
    Also - how old is your phone?
    03-11-17 05:15 AM
  3. Akis Tsirogiannis's Avatar
    Have you tried charging with a different charger and cable setup. This is a rather simple advice but might be helpful?
    Also - how old is your phone?
    I did - both from the wall, Tablet and power bank with different cables.

    I bought it on day one - 17th December 2014, so almost 2,5 years. Is the possibility high of being a battery issue?

    Using 10.3.3.1435.

    Posted via CB10

    Attachment 419183

    Zoomed in:

    Attachment 419184
    03-11-17 05:18 AM
  4. santoshwins's Avatar
    I did - both from the wall, Tablet and power bank with different cables.

    I bought it on day one - 17th December 2014, so almost 2,5 years. Is the possibility high of being a battery issue?

    Posted via CB10
    Yes it is poissble. However, this sounds extreme. My older Q5 (which now is my backup phone) is about 3.5 years old but still holds charge for about 15 hours or so.

    But since your phone is over two years old - it is possible that the battery might be the culprit. Do you have any friend who also has a classic? I cant remember if classic had the removable battery or not like the Q10.
    03-11-17 05:21 AM
  5. Akis Tsirogiannis's Avatar
    @santoshwins:

    I am the only one with a BB :P

    The classic has no removable battery unfortunately. I HATE that!

    I remember similar issues with my BOLD 9780 after 2,5 years back in time.

    Posted via CB10
    03-11-17 05:24 AM
  6. santoshwins's Avatar
    @santoshwins:

    I am the only one with a BB :P

    The classic has no removable battery unfortunately. I HATE that!

    I remember similar issues with my BOLD 9780 after 2,5 years back in time.

    Posted via CB10
    Uh oh :-( Looks like it will need to go to the doctor since it seems like you have already tried pretty much everything. Is it holding any charge at all? In terms of minutes I mean. Also - an OS reload is an option but it very much looks like a battery dead issue.
    03-11-17 05:29 AM
  7. Akis Tsirogiannis's Avatar
    @santoshwins:

    I wiped it last night and don't think a reinstall with an autoloader will solve the problem, considering that it doesn't seem to be the software...

    I can easily put out the sim card and sd card, it's no problem.

    It's just surprising me, because till yesterday it was performing so well and nice - how can it go from perfect to unusable? :/

    I am in Thailand right now, maybe I should find someone to replace the battery here. But WHERE to get a new battery? Still an unanswered questions to me...

    Posted via CB10
    03-11-17 05:45 AM
  8. hazmaju's Avatar
    https://www.etradesupply.com/blackbe...0-battery.html

    Posted using BlackBerry  Classic/SQC100-1 on 10.3.3.2205
    03-11-17 06:20 AM
  9. Akis Tsirogiannis's Avatar
    https://www.etradesupply.com/blackbe...0-battery.html

    Posted using BlackBerry  Classic/SQC100-1 on 10.3.3.2205
    Thanks for that!

    Posted via CB10
    03-11-17 06:33 AM
  10. hplovecraft's Avatar
    There's an app called 'Battery Charger' in the bb10 app store. It tells you also your battery health.

    I had a bad battery on my PP and the app told me it was 34%..so real bad.. I exchanged it and now - as it should be - I am back to 100%. The battery health is an indication if you have a physical problem with the battery. If you have one I am sorry that only an exchange will solve the issue.

    Good luck

    CB10 on my PP SE
    03-11-17 09:06 AM
  11. Akis Tsirogiannis's Avatar
    @hplovecraft:

    Thanks for your advice - I already used this app (like I wrote above) to test my battery, but it still says 100% - what obviously can't be true...:/

    Posted via CB10
    03-11-17 09:40 AM
  12. hplovecraft's Avatar
    Ahhh I see it now that you already tested your battery health.

    That makes it even stranger.

    CB10 on my PP SE
    03-11-17 09:43 AM
  13. sir mictol's Avatar
    Okay - once I praised my classic, I immediately experience serious battery problems now!

    Yesterday, when battery was at 45% it suddenly shut down. When I put to charge the LED was yellow for 5 seconds, then turned GREEN, meaning it's fully charged (not the case of course) . When I start BB10 it says 100%, but performance is laggy and after some minutes it crashes.

    I wiped the device, but that didn't help.

    Since then same thing happens. I let it charging over night and it seems to charge, although it stays at 100% constantly, but today at 65% it shut down again.
    Once connected to charger, same issue : green LED, up to 100%...

    Battery charger app sais the health is 100%.

    I need help, especially cause I am travelling long term now...

    Thankful for any advice!

    Posted via CB10
    Question : 1.do you let your phone die before you plug it to charge? This is always a bad practice and diminishes the battery life drastically. If question one isnt the problem, well it still means you need to replace the battery (if it was like the Q or Z 10, you could lend a friend's battery just for test, but this isnt the case).
    Good luck mate.

    Posted via CB10
    03-11-17 09:52 AM
  14. sir mictol's Avatar
    Green LED and 100 % charge, although battery empty - HELP!-img_20170311_162822.png

    Posted via CB10
    03-11-17 10:30 AM
  15. Akis Tsirogiannis's Avatar
    @sir mictol:

    No- it was 45% like I described and suddenly it died, what never happened before.

    In this case I don't think I can trust the battery health indicator...


    Green LED and 100 % charge, although battery empty - HELP!-img_20170311_225434.png

    Posted via CB10
    03-11-17 10:54 AM
  16. Dealazer's Avatar
    The latest update for 0S 10.2 had problems to many different things. I had to get an autoloader beta. It has watermark and you can uninstall android apps as you couldn't with 10.2 update. Beta is at 10.13.448. The watermark will be gone as soon beta gold is released.

    I tried back then too edit database files to avoid virus, but it also made apps hang up but battery could then be 0% days after days.

    Editing or malfunction in db folder might change phone state. Most often you need to security wipe everything. So make backup.

    Posted via CB10
    03-15-17 08:14 AM
  17. stlabrat's Avatar
    you might need a new battery.
    03-15-17 10:15 AM

Similar Threads

  1. Issues with BB Classic and Link, Blend and OS Upgrade
    By Gordonv123 in forum BB10 Leaked/Beta OS
    Replies: 4
    Last Post: 09-19-17, 05:11 PM
  2. Replies: 153
    Last Post: 06-19-17, 11:24 PM
  3. I need help regarding clash of clans?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 04-02-17, 11:05 AM
  4. Please help Me!!! Passport + android apps+ apk mods
    By dr_russian_kourt in forum Android Apps
    Replies: 5
    Last Post: 03-25-17, 07:02 PM
  5. Replies: 5
    Last Post: 03-11-17, 09:19 AM
LINK TO POST COPIED TO CLIPBOARD