11-02-15 08:01 AM
63 123
tools
  1. gokulesh's Avatar
    As we all know,

    specs don't matter because BB10 is super duper therefore...

    the slowness and lagging must be a... feature, it helps give the feeling of BB OS 6 & 7 for those transitioning to the Classic.
    Sarcasm at its finest from the spec gang.



    Posted Via The Classic
    12-23-14 06:48 PM
  2. gokulesh's Avatar
    Hi everyone... I am still experiencing problems.... I just uploaded a video to YouTube, but CrackBerry won't let me post the link because I am too new. The title of the video is "BlackBerry Classic Freeze". youtu.be/blg8fnR8a2w

    You can see that the display gets stuck between two screens of apps. The video is 17 seconds long but it took more than three minutes for the phone to become functional on this occasion.

    Any chance accounts are still updating on this thing? (I set up three e-mail accounts -- no idea how many messages are supposed to sync. I really just want to be able to view new incoming messages and do not care about syncing my pre-existing library).

    Should I look to exchange it for another one?
    How long have you had it? Also did you use link or set it up from scratch? As others have pointed out setting up from scratch works best. On day one the phone is slower. I don't have the issues you are having and I have had the phone for about 4 days. The only app that seems to lag is the CB10 app but it does that on my Z30 too. On the weekend I will check the CB10 app on my passport and see if there is any change.

    Posted Via The Classic
    12-23-14 06:53 PM
  3. 9700Guy's Avatar
    How long have you had it? Also did you use link or set it up from scratch? As others have pointed out setting up from scratch works best. On day one the phone is slower. I don't have the issues you are having and I have had the phone for about 4 days. The only app that seems to lag is the CB10 app but it does that on my Z30 too. On the weekend I will check the CB10 app on my passport and see if there is any change.

    Posted Via The Classic
    I have had it since Sunday --- two and a half days. I set it up from scratch. I do not have the CB10 app

    Thanks for the help, everyone. I am definitely going to exchange it. The tough thing is that the store where I bought it (and seemingly most stores) will not have any stock until the New Year, so I have to keep my voice usage under 30 minutes during that time --- I always find that policy weird.
    12-23-14 09:29 PM
  4. BEEBEEBEEBEE's Avatar
    Spend the "frozen time" pondering what u r about 2 do.

    Posted via CB10
    12-23-14 10:56 PM
  5. gvs1341's Avatar
    I never understood all of the crap about Link. Mine has always worked like it's supposed to...
    I also wondered about people complaining about Link, until it stopped working on my Windows PC after being flawless for almost two years.

    CB10 @ Q5
    12-24-14 12:15 PM
  6. slagman5's Avatar
    I also wondered about people complaining about Link, until it stopped working on my Windows PC after being flawless for almost two years.

    CB10 @ Q5
    Hopefully that doesn't happen. *fingers crossed*

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    12-24-14 01:35 PM
  7. mmk1954's Avatar
    Got the classic last Thursday and spent an hour setting it up on Friday. I left Canada on Saturday and am now in the UK. Not one issue so far. Battery life is great. Keyboard is great. The square screen is good for me. The switch from Z10 was a good decision for me.

    Using my BlackBerry Classic :-)
    geekaren likes this.
    12-24-14 01:56 PM
  8. deadcowboy's Avatar
    I never understood all of the crap about Link. Mine has always worked like it's supposed to...

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    Have you noticed that it's impossible to disassociate individual computers with your BBID? My Passport sees 20 different computers when I first set it up. I just turn off remote sync because computers that don't exist invariably find there way into my file manager. So stupid.

    Posted via CB10
    BEEBEEBEEBEE likes this.
    12-24-14 03:55 PM
  9. slagman5's Avatar
    Have you noticed that it's impossible to disassociate individual computers with your BBID? My Passport sees 20 different computers when I first set it up. I just turn off remote sync because computers that don't exist invariably find there way into my file manager. So stupid.

    Posted via CB10
    Lol, oh I always have that setting off anyway. :-)

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    12-24-14 04:02 PM
  10. 9700Guy's Avatar
    Well, it turned out that the store actually had some more in stock, so I did the exchange today. So far it is smooth sailing with the new one and I swear that it is snappier (certainly no instances of freezing yet), but I have not had much chance to play with it at all. I am only going to add apps/accounts on it very slowly.
    kbz1960 and Vintage123 like this.
    12-24-14 07:06 PM
  11. tpaul_1's Avatar
    I got a new Classic, and it took over 8 hours with Roger's tech support to transfer my data from my old Z10. The new Classic would not accept my calendar AND it freezes repeatedly (just like this forum). What a dud. So I am transferring back to my Z10
    11-01-15 07:09 PM
  12. gjh1978's Avatar
    I got a new Classic, and it took over 8 hours with Roger's tech support to transfer my data from my old Z10. The new Classic would not accept my calendar AND it freezes repeatedly (just like this forum). What a dud. So I am transferring back to my Z10
    If I could still use or if they made the 9700 with LTE I'd gladly use BBOS again, BB10 sucks a lemon...I've used the Z10, Q10, Classic and Passport and.l the OS is amongst the buggiest, worst I've ever seen.
    11-02-15 06:40 AM
  13. slagman5's Avatar
    I got a new Classic, and it took over 8 hours with Roger's tech support to transfer my data from my old Z10. The new Classic would not accept my calendar AND it freezes repeatedly (just like this forum). What a dud. So I am transferring back to my Z10
    Odd, I never had any of those issues with either of the Classics I've had... I bought it when it first came out, then got the AT&T version with wireless charging when it came out. Neither had any trouble setting up or getting the data restored from my old phone (Q10), my calendar syncs fine (using Outlook), and it never freezes...

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    11-02-15 08:01 AM
63 123

Similar Threads

  1. Does Uber work on the Classic?
    By CrackBerry Question in forum Ask a Question
    Replies: 11
    Last Post: 09-19-15, 11:40 AM
  2. Why isn't my BlackBerry Q10 turning on and only flashes a LED Red light?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-10-15, 06:57 AM
  3. Any all touch fans get the Classic?
    By WileECoyoteBB in forum BlackBerry Classic
    Replies: 3
    Last Post: 12-23-14, 03:36 PM
  4. Compare Classic and Q10 battery life
    By arlene_t in forum BlackBerry Classic
    Replies: 1
    Last Post: 12-23-14, 02:01 AM
  5. Why are callers unable to hear me on my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 12-23-14, 01:32 AM
LINK TO POST COPIED TO CLIPBOARD