1. markmall's Avatar
    It happened to me and on my one collectible BB10 device -- my blue Classic.

    Has anyone ever replaced their headphone jack? How do you take these apart?

    I've tested the earphones out and tried other earphones on the Classic. It's the Classic's fault. Maybe I should find my stock earphones and see if they work.
    09-15-18 01:53 AM
  2. markmall's Avatar
    Anyone?

    Posted via CB10
    09-15-18 07:41 PM
  3. Cainamzak's Avatar
    There is a video on youtube that shows disassembly, not the smoothest but at least you can see what is ahead of you.

    I feel it would be easier to just use bluetooth.

     Classic SQC100-2 I 10.3.2.2813
    09-15-18 09:32 PM
  4. markmall's Avatar
    There is a video on youtube that shows disassembly, not the smoothest but at least you can see what is ahead of you.

    I feel it would be easier to just use bluetooth.

     Classic SQC100-2 I 10.3.2.2813
    I might have to or risk ruining the device.

    Posted via CB10
    09-15-18 09:42 PM
  5. markmall's Avatar
    I've had this happen to so many devices that are BB10 that I am wondering if earphones with an in-line microphone is not ruining the jocks.

    Maybe the dimensions of the prongs for inlines are different enough that they are stretching something out or bending something.

    Posted via CB10
    09-16-18 12:10 AM
  6. markmall's Avatar
    Before everything was made in China this never happened to electronic devices. I used micro earphone Jacks for decades and all of a sudden this happens constantly. I have seen the same thing with other types of devices that never used to break but now do.

    Posted via CB10
    09-16-18 12:12 AM
  7. Ragbert's Avatar
    This is not meant to be a stupid question, but have you tried clearing dust/lint out of the jack by blowing into it? Or gently poking a pipe cleaner or pointed cotton swab in there to pull out any built-up crud? (Some people have used paper clips too, but I think the risk of breaking something that way is too great.)

    Typed on my Q10, SQN100-2, 10.3.2.2813
    09-16-18 02:11 PM
  8. markmall's Avatar
    Now the jack is working with the same earphones. It felt tight when I put the thing in.

    Another thing I've noted is that it sometimes malfunctions. The inline mic earphones also have controls on the mic piece -- volume up, down and start/stop.

    This leads me to conclude that it's a physical problem in the jack caused by poor manufacture. I guess that was the main culprit.

    Taking these apart looks risky. Probably will get Bluetooth earphones since most of what I'm listening to is spoken word these days. Audio quality is not the biggest concern.

    Posted via CB10
    09-17-18 05:03 PM
  9. Chuck Finley69's Avatar
    Now the jack is working with the same earphones. It felt tight when I put the thing in.

    Another thing I've noted is that it sometimes malfunctions. The inline mic earphones also have controls on the mic piece -- volume up, down and start/stop.

    This leads me to conclude that it's a physical problem in the jack caused by poor manufacture. I guess that was the main culprit.

    Taking these apart looks risky. Probably will get Bluetooth earphones since most of what I'm listening to is spoken word these days. Audio quality is not the biggest concern.

    Posted via CB10
    The comment above you from Ragbert is good suggestion with all devices. Lower tolerances encourage dirt and such to get pushed down into ports etc.

    Recommend Qtips on both ends, device and user...... LOL not just BB10 thing.
    09-17-18 09:49 PM
  10. markmall's Avatar
    The comment above you from Ragbert is good suggestion with all devices. Lower tolerances encourage dirt and such to get pushed down into ports etc.

    Recommend Qtips on both ends, device and user...... LOL not just BB10 thing.
    Are you sure this isn't a sign that I should buy a Key2? (Haha.)

    Posted via CB10
    09-18-18 01:10 AM
  11. Ragbert's Avatar
    Gettin' kinda personal, aren't we?

    Recommend Qtips on both ends, device and user...... LOL not just BB10 thing.


    Typed on my Q10, SQN100-2, 10.3.2.2813
    09-19-18 02:01 AM
  12. Chuck Finley69's Avatar
    Gettin' kinda personal, aren't we?





    Typed on my Q10, SQN100-2, 10.3.2.2813
    Yes, but markmall tolerates me as long as I promise to be polite, neutral and fair towards BB10 users and threads.......
    09-19-18 06:29 AM
  13. markmall's Avatar
    It somehow started working again for last few days. Maybe debris or something else.

    Posted via CB10
    09-23-18 05:21 AM
  14. Ragbert's Avatar
    As I said, clean out your jacks first, before you panic that the issue is worse than that. :-)

    Typed on my Q10, SQN100-2, 10.3.2.2813
    09-23-18 09:56 AM

Similar Threads

  1. Headphone Jack
    By The_Dark_Knight_Forever in forum BlackBerry Motion
    Replies: 3
    Last Post: 09-18-18, 02:22 PM
  2. This $10 under-desk headphone mount is a great addition to any workspace
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 09-13-18, 10:10 AM
  3. Settings Moved in Oreo - Not sure where to go
    By sqlt in forum BlackBerry KEYone
    Replies: 2
    Last Post: 09-12-18, 09:39 PM
  4. Earphone jack NOISE
    By Norihisya in forum BlackBerry KEYone
    Replies: 2
    Last Post: 09-11-18, 11:13 AM
  5. Email notifications in Hub slow to go
    By Dewcal in forum BlackBerry HUB+ Suite
    Replies: 0
    Last Post: 09-07-18, 03:09 PM
LINK TO POST COPIED TO CLIPBOARD