1. kris t's Avatar
    hello,

    i'm using my US Tmobile Classic in Poland (with Polish/French Orange sim card). Was assured that LTE would be working great and...it does not....well, it does - in a few places only, really
    called them and they say that everything is fine and should work but it does not,
    quite confusing - especially that my other phone (galaxy s5) works with LTE...
    max speed/transfer i can get is 3G or H+
    and we hit the real problem now - the phone switches between 3G and H+ and sucks battery out in hours

    just want to share it...
    kt

    Posted via CB10
    07-18-16 11:21 PM
  2. Gajja's Avatar
    hello,

    i'm using my US Tmobile Classic in Poland (with Polish/French Orange sim card). Was assured that LTE would be working great and...it does not....well, it does - in a few places only, really
    called them and they say that everything is fine and should work but it does not,
    quite confusing - especially that my other phone (galaxy s5) works with LTE...
    max speed/transfer i can get is 3G or H+
    and we hit the real problem now - the phone switches between 3G and H+ and sucks battery out in hours

    just want to share it...
    kt

    Posted via CB10
    1. Can you go into settings and set it to prefer 3G or whatever? so it doesn't keep switching between them.
    2. It might be your SIM card that's the LTE problem, not your device? Although noted it's the US market devices that are often "a bit weird" if you look at it from the rest of the world's perspective.
    07-19-16 08:15 AM
  3. kris t's Avatar
    changed settings and sim card (3-4times) - didn't help
    so I'm afraid the problem lays on "weirdnessy" of the US device
    thank you

    Posted via CB10
    07-19-16 11:08 PM
  4. Observer2's Avatar
    If encryption is on, then turn off. Try turning back on at a later time.


    Posted via CB10
    07-23-16 01:27 PM
  5. CivilDissident's Avatar
    When all else fails:

    SECURITY WIPE / FACTORY RESET**




    ** Remember to back up your data BEFORE you perform your Device Wipe!!

    Posted via CB10
    07-24-16 12:01 AM
  6. Invictus0's Avatar
    How many bars are you usually getting on 3G and H+?

    The lack of LTE in certain areas could just be a coverage issue. You should check to see if your carrier has an LTE coverage map on their website and if it lines up with your coverage experiences.
    07-24-16 09:53 AM

Similar Threads

  1. Extended battery case for Q10?
    By mh1983 in forum BlackBerry Q10
    Replies: 3
    Last Post: 07-20-16, 09:15 PM
  2. Priv battery life after latest system update.
    By oldsoul123 in forum BlackBerry Priv
    Replies: 2
    Last Post: 07-18-16, 08:12 PM
  3. Battery life: WiFi vs Cellular
    By darkwater79 in forum BlackBerry Priv
    Replies: 4
    Last Post: 07-18-16, 06:46 PM
  4. Replies: 1
    Last Post: 07-18-16, 11:44 AM
  5. What network type are you using to conserve battery?
    By ReinGutierrez in forum BlackBerry Priv
    Replies: 2
    Last Post: 07-18-16, 09:02 AM
LINK TO POST COPIED TO CLIPBOARD