1. Frosty_Power's Avatar
    Classic has been working great since day 1. No issues until now. I took out my SD card cause I needed to use it for other things and when I went to put it back in(Classic was still powered on), the phone instantly turned off and now I can't turn it back on. Did I just fry something with what I have done? I guess I'm kicking myself now that I should have powered it off first. Am I SOL and need warranty work or is there another way to get this powered up? Tried everything so far. No LED when it's plugged in charging. Nothing....oh well, back to the Passport until I get this thing fixed.
    02-28-15 12:24 PM
  2. anon(9208252)'s Avatar
    Try holding the power button down for a long time while plugged in.
    02-28-15 12:27 PM
  3. anischab's Avatar
    You can trigger it by USB cable linked to the computer

    BlackBerry|Q10, SQN100-3, OS; BlackBerry|Passport, SQW100-1, OS
    02-28-15 12:30 PM
  4. Frosty_Power's Avatar
    Thanks for the suggestions guys. I tried both of those and no go. It's like it is completely dead.
    02-28-15 12:43 PM
  5. anon(9208252)'s Avatar
    Leave it plugged into the wall charger for an hour or so to make sure its not a dead battery, or you could try loading an auto loader to it and see if it wakes it up, or might just have to return for warranty,

    02-28-15 12:46 PM
  6. Frosty_Power's Avatar
    Still no luck and still can't find anyone to fix it. No contact number on BB's website, tweeted @blackberryhelp and no response. I will even pay to get it fixed but have no idea where to go?
    03-05-15 02:35 PM
  7. Ben Bolyan Jr's Avatar
    Same issues here and tried it all... looks like im headed to verizon tomorrow
    05-26-15 12:06 AM

Similar Threads

  1. NETFLIX on Amazon App Store GONE?
    By nt300 in forum Android Apps (Amazon Store & APK Files)
    Replies: 20
    Last Post: 03-08-15, 04:50 PM
  2. How can I get the famous blackberry message tone on the passport
    By BBlunatic in forum BlackBerry Passport
    Replies: 17
    Last Post: 03-01-15, 11:15 PM
  3. Android apps not running on mobile Data services -
    By Krishna Kichambare in forum BlackBerry P'9982
    Replies: 1
    Last Post: 03-01-15, 05:14 PM
  4. z30 10.3 random actions while on phone
    By gothicave in forum BlackBerry Z30
    Replies: 4
    Last Post: 03-01-15, 02:13 PM
  5. how do I integrate and use an Android Ringtone App on my Q10 OS10.3.1
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-28-15, 12:53 PM