1. edikat's Avatar
    My problem is the battery cuts out at 26% although up until then I get around 3 days usage, so happy with the battery life, it seems that 26% is actually 0% (faulty measurement) - I have tried everything to reset it (including full discharges and charging up) but it still cuts out at this level.

    Anybody have any suggestions as to how I can possibly reset the battery gauge..I don't want to full reset as I have spent much time setting up the device how I like it.

    Other than that it is great (one system freeze in a month though).

    Device was purchased used but had seen very little use (looked new and seemed like it had never been used).

    Thanks!
    01-16-19 12:05 PM
  2. Dunt Dunt Dunt's Avatar
    There are a few different things people do... but usually it comes back.

    If you are getting 3 Days of usage... I wouldn't mess with anything.
    01-17-19 09:30 AM
  3. edikat's Avatar
    Actually I am getting six days with light usage )))) I once got seven with very little use (but always on cellular and data).

    Thanks for the response!

    I am going to buy a Q10 as a second phone (or maybe a Z10) as they have replaceable original batteries.... and use this alongside the Classic.
    01-17-19 12:10 PM
  4. Dunt Dunt Dunt's Avatar
    Actually I am getting six days with light usage )))) I once got seven with very little use (but always on cellular and data).

    Thanks for the response!

    I am going to buy a Q10 as a second phone (or maybe a Z10) as they have replaceable original batteries.... and use this alongside the Classic.
    Just keep in mind that BB10's EOL happens at the end of the year... how useful those devices will be at that point, has yet to be determined. It's your money...
    01-17-19 03:53 PM
  5. edikat's Avatar
    Battery started cutting out at 75%

    So I did the following:

    Complete hard reset (factory wipe)... made no difference
    Autoloader (?) exe file... wipe and low level re-install..... no difference

    Incidentely the autoloader version was different from the final installed version... it did wipe as I saw the screen say writing segement XXX (or whatever it says on low level install) after cobbection to boot rom?

    Anyway made no difference.

    Left to charge overnight... (it took hours to charge from 95% to 100%) so I think the calibration is way off and that is the problem.

    As I said before can get 3-7 days standby but the battery will cut out at some level whether 50%, 75% or 30% (changes depending on how charged the phone is, when FULLY charged cuts off at 30%).

    I still love this phone though.
    01-22-19 07:53 AM
  6. WES51's Avatar
    I had something similar. Battery would cut off around 60%.

    I tried to discharge/charge a couple of times, but it never produced any mentionable difference.

    Then I read a thread here about disconnecting the battery. I did that and that SOLVED the issue.

    I let the battery discharge until the phone turned off and that is when I disconnected/connected the battery a couple of times. Then I charged it to full and again disconnected/connected the battery a couple of times more. I repeated the entire process 2x more times, just to be sure.

    Disconnecting the battery is a bit tricky. The back cover needs to come off of course. So first I watched a video on YouTube about Classic's disassembly. The back cover is clipped-on AND glued via black-tape-glue at two spots at the top and bottom. The clips are popped relatively easily with a guitar pick, but when you try prying it off, the glue holds it and it feels like it does not want to come off. I used a hair dryer to heat up the rear cover and that helped somewhat to release the rear cover. The contact of the battery is a pushed down contact. After opening the two screws and removing the bracket, it can be carefully preyed up (lever up) with a small screwdriver. There is no other release mechanism to undo. It can be simply pushed back on and it clicks back into place.
    09-19-19 09:46 AM
  7. dubengeldu's Avatar
    My problem is the battery cuts out at 26% although up until then I get around 3 days usage, so happy with the battery life, it seems that 26% is actually 0% (faulty measurement) - I have tried everything to reset it (including full discharges and charging up) but it still cuts out at this level.

    Anybody have any suggestions as to how I can possibly reset the battery gauge..I don't want to full reset as I have spent much time setting up the device how I like it.

    Other than that it is great (one system freeze in a month though).

    Device was purchased used but had seen very little use (looked new and seemed like it had never been used).

    Thanks!
    Irepaired about 8 blackberryclassic s maybemore maybe one less,

    -try battery fiction light first
    Ifitdoesnt get better
    -replace the battery. Imsure theres a videosomewhere. Its fairly doable. The disassemblyofthe back cover is abit problematic


    Posted via CB10
    09-20-19 04:21 PM
  8. Chuck Finley69's Avatar
    Irepaired about 8 blackberryclassic s maybemore maybe one less,

    -try battery fiction light first
    Ifitdoesnt get better
    -replace the battery. Imsure theres a videosomewhere. Its fairly doable. The disassemblyofthe back cover is abit problematic


    Posted via CB10
    Have you considered using a repaired BB10 device so your words don’t run together?
    09-20-19 06:50 PM
  9. dubengeldu's Avatar
    Have you considered using a repaired BB10 device so your words don’t run together?
    Toomuch fhantastic sex. And now youknow. Yeees? This canhapppentoyou aswell... oneday... ifyouwork hard and followtherules and

    Posted via CB10
    09-20-19 07:06 PM
  10. WES51's Avatar
    Toomuch fhantastic sex. And now youknow. Yeees? This canhapppentoyou aswell... oneday... ifyouwork hard and followtherules and

    Posted via CB10
    If you think what you are doing is cool, then you must be very young and extremely inexperienced for your age.
    09-20-19 07:41 PM
  11. Chuck Finley69's Avatar
    Toomuch fhantastic sex. And now youknow. Yeees? This canhapppentoyou aswell... oneday... ifyouwork hard and followtherules and

    Posted via CB10
    Obviously you are using the device one handed as the other is busy I guess or something?? Are your keys all stuck together? I’m confused what you’re saying.
    09-20-19 10:04 PM

Similar Threads

  1. bbm voice call.. not working?!
    By Qwerty6666 in forum BlackBerry Classic
    Replies: 3
    Last Post: 01-19-19, 09:19 AM
  2. KEY2 keyboard issues
    By quizm in forum BlackBerry KEY2
    Replies: 3
    Last Post: 01-16-19, 03:36 PM
  3. Classic Owners Group 3 Years Thanks
    By bakron1 in forum Discover BBM Groups
    Replies: 2
    Last Post: 01-16-19, 03:17 PM
  4. Replies: 1
    Last Post: 01-16-19, 09:46 AM
  5. when is the next bbm update on the classic?
    By Qwerty6666 in forum BlackBerry Classic
    Replies: 1
    Last Post: 01-16-19, 09:26 AM
LINK TO POST COPIED TO CLIPBOARD