1. edikat's Avatar
    My problem is the battery cuts out at 26% although up until then I get around 3 days usage, so happy with the battery life, it seems that 26% is actually 0% (faulty measurement) - I have tried everything to reset it (including full discharges and charging up) but it still cuts out at this level.

    Anybody have any suggestions as to how I can possibly reset the battery gauge..I don't want to full reset as I have spent much time setting up the device how I like it.

    Other than that it is great (one system freeze in a month though).

    Device was purchased used but had seen very little use (looked new and seemed like it had never been used).

    Thanks!
    01-16-19 12:05 PM
  2. Dunt Dunt Dunt's Avatar
    There are a few different things people do... but usually it comes back.

    If you are getting 3 Days of usage... I wouldn't mess with anything.
    01-17-19 09:30 AM
  3. edikat's Avatar
    Actually I am getting six days with light usage )))) I once got seven with very little use (but always on cellular and data).

    Thanks for the response!

    I am going to buy a Q10 as a second phone (or maybe a Z10) as they have replaceable original batteries.... and use this alongside the Classic.
    01-17-19 12:10 PM
  4. Dunt Dunt Dunt's Avatar
    Actually I am getting six days with light usage )))) I once got seven with very little use (but always on cellular and data).

    Thanks for the response!

    I am going to buy a Q10 as a second phone (or maybe a Z10) as they have replaceable original batteries.... and use this alongside the Classic.
    Just keep in mind that BB10's EOL happens at the end of the year... how useful those devices will be at that point, has yet to be determined. It's your money...
    01-17-19 03:53 PM
  5. edikat's Avatar
    Battery started cutting out at 75%

    So I did the following:

    Complete hard reset (factory wipe)... made no difference
    Autoloader (?) exe file... wipe and low level re-install..... no difference

    Incidentely the autoloader version was different from the final installed version... it did wipe as I saw the screen say writing segement XXX (or whatever it says on low level install) after cobbection to boot rom?

    Anyway made no difference.

    Left to charge overnight... (it took hours to charge from 95% to 100%) so I think the calibration is way off and that is the problem.

    As I said before can get 3-7 days standby but the battery will cut out at some level whether 50%, 75% or 30% (changes depending on how charged the phone is, when FULLY charged cuts off at 30%).

    I still love this phone though.
    01-22-19 07:53 AM

Similar Threads

  1. bbm voice call.. not working?!
    By Qwerty6666 in forum BlackBerry Classic
    Replies: 3
    Last Post: 01-19-19, 09:19 AM
  2. KEY2 keyboard issues
    By quizm in forum BlackBerry KEY2
    Replies: 3
    Last Post: 01-16-19, 03:36 PM
  3. Classic Owners Group 3 Years Thanks
    By bakron1 in forum Discover BBM Groups
    Replies: 2
    Last Post: 01-16-19, 03:17 PM
  4. Replies: 1
    Last Post: 01-16-19, 09:46 AM
  5. when is the next bbm update on the classic?
    By Qwerty6666 in forum BlackBerry Classic
    Replies: 1
    Last Post: 01-16-19, 09:26 AM
LINK TO POST COPIED TO CLIPBOARD