1. mowienay's Avatar
    My classic has a relatively high battery charge loss while being idle. For example my phone is 100% before bed, I wake up after 3 hours with 80%.
    On the other hand, my wife's Z30 get more than 95% for the same scenario. I am not comparing apples to apples as battery capacities are different and even BB10 versions are different with her's on 10.2 and mine on 10.3.3., yet I have a feeling that my Classic has an issue given that everyone talks about how efficient it is.
    It seems like my phone does not sleep or something.
    Is anyone facing the same issue? If yes, how to troubleshoot to know the root cause?

    Posted via CB10
    07-21-17 10:38 AM
  2. bh7171's Avatar
    Go into settings, security and app permissions and check each app permissions. Turn off the "run in background or run when minimized" on each app. It is an app and likely an android port causing the issue. Hope this helps.

    Via the Cobalt Classic
    07-21-17 01:44 PM
  3. mowienay's Avatar
    Thanks for the valuable advise. I just did that for all android apps. I will check tonight!!

    Posted via CB10
    07-21-17 05:55 PM
  4. bh7171's Avatar
    Hope it helped. I would advise doing it for all apps Android port or BlackBerry 10 developed. For my needs I don't need anything running in the background. Be Weather Pro for example does not need to be doing anything for me unless I open it.

    Via the Cobalt Classic
    07-22-17 04:14 PM
  5. mowienay's Avatar
    Thanks. Did it for all apps except for Cobalt's android apps as it does not allow me. I also deleted all android apps from maps to pocket to wunderlist. I will see tonight. Hopefully the drain will stop then I can start adding my android apps one by one.

    Posted via CB10
    07-23-17 12:00 AM
  6. mowienay's Avatar
    Reporting back: Significant improvement. Lost 12% instead of 25% on the course of idle 6 hours. However 12% is still a significant drain with android player responsible for half the drain.
    I guess I will backup and reset the phone. May be there are some residues in the android system that did not stop even after deleting all apps.

    Posted via CB10
    07-23-17 11:35 AM
  7. bh7171's Avatar
    A hard reset of holding the power button down until the red led light goes out should help. Glad you realized some improvement. ;o)

    Via the Cobalt Classic
    07-23-17 02:20 PM
  8. mowienay's Avatar
    Thanks bh7171. I did a security wipe and should asses again tonight. Since, you are using Cobalt's method, are you facing above avg battery consumption*?

    Before wiping the phone, I had deleted every single android app except the three Cobalt's apps. So I suspected they might be the reason behind the above avg android player consumption.

    Posted via CB10
    07-23-17 06:07 PM
  9. bh7171's Avatar
    I do not use Cobalt's method on my Classic as I have had no personal need. I have a Passport I purchased prior to my Classic and I have it on that device. Although with Cobalt on my Passport there is no high rate battery drain on that device either.

    Via the Cobalt Classic
    07-24-17 01:51 PM
  10. mowienay's Avatar
    Thanks a lot bh7171. You have been very helpful!!

    Posted via CB10
    07-24-17 03:33 PM

Similar Threads

  1. No Battery Saver in quick settings
    By Birpal Singh Bhinder in forum BlackBerry Passport
    Replies: 4
    Last Post: 07-25-17, 07:35 AM
  2. Keyone Media use battery consumption
    By AhabSnake in forum BlackBerry KEYone
    Replies: 4
    Last Post: 07-22-17, 01:46 AM
  3. Restoring lost data on a Blackberry Classic
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 07-21-17, 05:15 PM
  4. Best place to unlock a Classic?
    By curves2000 in forum BlackBerry Classic
    Replies: 3
    Last Post: 07-21-17, 12:39 AM
  5. battery life is amazing
    By Kazuki454 in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-21-17, 12:26 AM
LINK TO POST COPIED TO CLIPBOARD