1. all3n7's Avatar
    I love My Q10 and it's latest 10.2 OS version. It's fast enough, productive enough, just a perfect match. When I found out about 10.3 leaked. I took the time and read some reviews about it. Many claimed it was slow, sluggish, battery doesn't perform well. Despite of it I decided to DL it anyway so I could experience it myself. Loaded it and did finds some few bugs. So after few days of playing with it. I decided to Down grade back to 10.2.1

    I wonder does anyone with their Classic downgrade to 10.2.1? Is it possible to even do so? And if it does, how is the performance against Q10's lastest and most last OS 10.2.1 ? Thanks

    Posted via CB10
    01-04-15 11:46 PM
  2. MrDoreth's Avatar
    Don't think it works because of 10.3 being pre-installed but good luck with that!
    I would just use 10.3

    Posted with my awesome  Z10

    EDIT: and yeah a lot of people say it's better after their update so maybe see why it doesn't work very well. Maybe you took a leak full off bugs because some are buggy!
    reppnda954@aol.com likes this.
    01-05-15 12:05 AM
  3. johnburton_uk's Avatar
    I doubt 10.2.1 is programmed to be able to use the tool belt and trackpad. I'm running 10.3.1 on my Q10 and Z10 and I wouldn't turn back.

    Posted via CB10
    01-05-15 12:09 AM
  4. Taigatrommel's Avatar
    10.2.1 is indeed not capable of using either the trackpad or toolbelt keys, even the original 10.3 is not capable of doing so. In short: Anything below 10.3.1 won't work with the Classic.

    Regarding your experience with the Q10: Keep in mind as of now all 10.3.x versions for existing devices are all leaked versions, not intended for final release. I don't think they are completely optimised or tested for those phones. The Classic however got the an official final release of 10.3.1 and we can also expect future improvements with additional updates.

    Posted via CB10
    01-05-15 03:30 AM
  5. garycui's Avatar
    I have purchased classic and have the exactly the same thoughts with you. I've tried to use 10.2 autoloaders to downgrade the device. It could be written into classic. However, the device could not be started after the process. So I had to reinstall 10.3
    01-10-15 10:02 PM
  6. ChainPunch's Avatar
    10.3.1 is the baseline for the classic, as someone else mention, as toolbelt support was not added until 10.3.1
    01-10-15 10:30 PM

Similar Threads

  1. Safe mode option on curve 9300
    By amritanshu singh in forum Ask a Question
    Replies: 1
    Last Post: 02-12-15, 01:14 PM
  2. Disable Blend Notification on Device?
    By SeeBeeEss in forum BlackBerry 10 OS
    Replies: 19
    Last Post: 01-30-15, 06:41 AM
  3. Replies: 8
    Last Post: 01-12-15, 11:19 AM
  4. Annoying issue with BB10 on blackberry passport...
    By hasa77 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 01-11-15, 11:29 AM
  5. No sound on video recorder of z30. Pliz help
    By abdinjamal in forum BlackBerry Z30
    Replies: 7
    Last Post: 01-11-15, 10:53 AM