1. jtmo3's Avatar
    I've asked this question before but wanted to see if there's been any update or anyone else have similar or opposite experience with their classic on at&t. I get LTE most everywhere. Anywhere from 1 bar to 5. However, when I go to make a call, the phone drops to 4g (normal) and I usually lose a bar or two signal strength. For instance, in my basement, I get 2 bars lte. When I go to make a call, it drops to one bar and about 75% of the time, the call goes through, but not always. This is my second classic. at&t sent me another several months back for this issue and it seems to be no different.

    Just wondering what others on at&t are seeing. And if they're seeing the same issue. It seems worse when I have under 3 bars signal. Tested with an iphone in the same places and it's signal strength usually goes up when making calls, rather than down.
    07-20-15 10:58 AM
  2. anon8237442's Avatar
    I can't verify this but I assume the different brands operate on a different lte channel (apple vs. BlackBerry) if I am right then you could have a device interfering with the BlackBerry Classic signal. My Classic beats about every other AT&T phone I've ever owned in general signal strength and speed...

    Posted via CB10
    07-20-15 05:22 PM
  3. momofteme's Avatar
    I am on Verizon, and I will drop calls for while the phone shows 2 or 3 bars of LTE.

    Many times my phone won't even ring when someone calls...I only get the voicemail alert.

    My wife's z30 seems to be better in this respect, but I can't tell for sure because she won't let me take it and use it for an extended amount of time.

    I live in what should be a good signal area, but inside my house or shed the phone reception is near terrible.

    I was ready to try to geta replacement from Verizon, but I am about ready to get a z30 off of ebay and see how it does.



    Posted via CB10
    07-23-15 07:35 AM
  4. Cameo Gonzales1's Avatar
    My classic does the same thing! my calls always go through though and I always get calls so it's not a big deal to me

    Posted via CB10
    07-23-15 07:47 AM
  5. jtmo3's Avatar
    Thanks for that. I have a replacement coming (third classic) to see if maybe it's the phone. Daily dropped calls and no network available errors, and I've had enough. No other phones I've used or others around me are having the issue. I put my sim back in my iphone yesterday morning and haven't seen any issues since as far as signal dropping when making calls or dropped calls. Maybe third phone is a charm, otherwise, not too happy with the classics radio.
    07-23-15 07:49 AM
  6. TorchFrank's Avatar
    same thing happened on my iphone 5s too. I think it has something to do with being able to talk and text at the same time on at&t's network. I'm no expert though

    Posted via CB10
    07-23-15 04:48 PM
  7. jtmo3's Avatar
    Just a follow up. I received my replacement and it is worse than the one I have. For me on at&t this has to be a device problem with whatever bands at&t uses for their 4g. My iPhone and a windows phone show lte when making calls. The BB Classic drops to 4g and the signal fluctuates badly and drops. It's an issue I don't see with other phones and that leads me to believe it's a BB issue with their hardware or the way they're implementing it in the software. At the end of the day, it doesn't matter what the issue is. If I can't reliably use my phone as a phone (been through 3 classics now and they ALL exhibit this) then it's time to move to a phone that will function. Really stinks because I dislike iPhone a bunch.
    07-24-15 09:31 AM
  8. eywong's Avatar
    My classic does the same thing! my calls always go through though and I always get calls so it's not a big deal to me
    I concur. My Z10STL100-3/10.3.2.2339 exhibits the same behavior and it works OK.
    07-24-15 09:48 AM
  9. Don_Henry's Avatar
    Just a follow up. I received my replacement and it is worse than the one I have. For me on at&t this has to be a device problem with whatever bands at&t uses for their 4g. My iPhone and a windows phone show lte when making calls. The BB Classic drops to 4g and the signal fluctuates badly and drops. It's an issue I don't see with other phones and that leads me to believe it's a BB issue with their hardware or the way they're implementing it in the software. At the end of the day, it doesn't matter what the issue is. If I can't reliably use my phone as a phone (been through 3 classics now and they ALL exhibit this) then it's time to move to a phone that will function. Really stinks because I dislike iPhone a bunch.
    Jtmo - you have not stated what OS you are using. I am also on AT&T with my Z10; my wife's Classic is also on AT&T.

    I have found that using a different radio file on our devices makes a huge difference. For example, I am running OS 19.3.2.2339, which has corresponding radio file 2340. That radio had poor signal, lots of dropped calls, and poor battery performance.

    I am now running radio file 841 with the 2339 OS - great signal, no more dropped calls, and much better battery performance.

    So before you give up in your Classic - you may want to try the latest OS (2339) and either the 841 or 859 radio files. Many people are reporting great success with that combination.

    Z10 /3 - 10.3.2.2239/841 - AT&T (posted via CB10)
    07-24-15 11:25 AM
  10. jtmo3's Avatar
    Thanks for the suggestion. I've tried quite a few. Tried 2339 and it didn't make much difference. Tried the original, I believe, 3.2.400 that I got when I received this classic, that att put out. Now using the released version from att 556. None made a difference worth mentioning. They all exhibited the same problem/behavior. I notice that if I am outside, my 4g is much better. When I go indoors almost anywhere that's when the issue shows itself. It's like when on 4g, the classic never really gets a stable signal and it's always hunting. When on lte, it's rock solid though. It's just when it switches to make or receive a call. And unfortunately, I use my phone as a phone a lot. Can't count the number of dropped calls and inability to make a call, much less missed calls. Issues I don't see when using the iPhone or a windows phone I have. I also didn't see this issue with a passport I had and got rid of because it was just too big for me.
    07-24-15 12:02 PM

Similar Threads

  1. Why cell phones do not use solar batteries ?
    By weijing3333 in forum Ask a Question
    Replies: 13
    Last Post: 08-07-15, 01:39 AM
  2. Verizon Classic but AT&T signal?
    By samsamleelee in forum BlackBerry Classic
    Replies: 6
    Last Post: 07-21-15, 07:03 AM
  3. Why is my signal not working on my BB 9930?
    By Click Click in forum BlackBerry Bold 9930/9900
    Replies: 5
    Last Post: 07-20-15, 05:32 AM
  4. Z3 frequently dropping signal
    By mustang_bb in forum Ask a Question
    Replies: 5
    Last Post: 07-16-15, 08:26 AM
  5. BlackBerry maps on z30 doesn't find gps signal.
    By MarkyZ10 in forum Ask a Question
    Replies: 4
    Last Post: 07-14-15, 11:20 PM
LINK TO POST COPIED TO CLIPBOARD