1. Jg2's Avatar
    My car charger from my old 9900 worked on my q10 but doesn't work on my classic. Are the micro plugs different?
    My classic charged fine with my home q10 charger cable , Wondering what is different on the car charger.
    03-02-15 03:32 PM
  2. jamesharmeling's Avatar
    Invest a few bucks and get the BlackBerry charger.

    http://www.amazon.com/gp/aw/d/B00D8Y...UvbUpU11421213

    Works beautifully.

    BlackBerryaholic by choice.
    03-02-15 03:51 PM
  3. Jg2's Avatar
    It is a blackberry charger but originally bough for my 9900 which worked fine on my q10. Just not on the classic.
    03-02-15 03:56 PM
  4. jamesharmeling's Avatar
    It is a blackberry charger but originally bough for my 9900 which worked fine on my q10. Just not on the classic.
    I'm not sure why it doesn't work, but I seem to remember it happening to me. Might be how many amps it puts out. Get a new one.

    BlackBerryaholic by choice.
    03-02-15 04:01 PM
  5. Jg2's Avatar
    Ok. Thanks for the link.
    jamesharmeling likes this.
    03-02-15 04:09 PM
  6. wilber1's Avatar
    Had the Classic for 2 months and tried to charge in car and old charger did not work either ?? Bought a new one and Whamo! works like a charm ??
    jamesharmeling likes this.
    03-02-15 04:14 PM

Similar Threads

  1. Which PMA charger for AT&T Classic?
    By steinercat in forum AT&T
    Replies: 6
    Last Post: 03-18-15, 06:58 PM
  2. Replies: 4
    Last Post: 03-15-15, 11:36 PM
  3. Blackberry 9900 - picky about chargers?
    By Trevor_9900 in forum BlackBerry Bold 9930/9900
    Replies: 4
    Last Post: 03-08-15, 03:06 PM
  4. Why does my phone not recognize my car stereo as line-out?
    By Dominic Bartnick in forum BlackBerry Passport
    Replies: 13
    Last Post: 03-02-15, 10:32 AM
  5. Is connecting my charger while updating my Z3 necessary?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-02-15, 12:35 AM
LINK TO POST COPIED TO CLIPBOARD