1. lipoff's Avatar
    I've had my Classic since April (was using a Q10 before) and for the most part I love it, but I have five annoyances in my daily use that keep grating on me. I am running OS 10.3.2.556.

    Are there any solutions to these issues?

    (1) Web search queries disappear if typed too quickly

    I open the browser, and type into the bottom bar where it says "Type search or address"; if I don't pause after typing in a search query or web address before I hit the [Enter] key, the entire text string I've typed just disappears. Relatedly if I don't pause after typing, sometimes a search query ends up parsed as a web address (instead of "this is a google search" it would render as "http://this.is.a.google.search") and sometimes a web address gets truncated (instead of "http://crackberry.com" it renders as "http://crackberry.co"). Yes, I could learn to count to two before I hit the [Enter] key after I type a search query, but why should I have to?

    (2) Programs randomly restart every couple days

    At what seems like random intervals, maybe everyday 1-3 days, some open programs on my BlackBerry Classic will restart. Sometimes it appears that the entire BlackBerry performs an uncommanded reset --- although I've never watched that happen sometimes all the open programs restarted. But the upshot is that while programs like What'sApp and WeChat reload fine, all of the open tabs in my Browser have closed. While I can go and search for them manually in the history and reopen them, one by one, this is really annoying. If the BlackBerry has to restart randomly, I should at least offer the option to reopen all the accidentally closed tabs in one fell swoop (obviously not require re-opening all tabs, since its conceivable that one of those open tabs is what caused the restart).

    (3) Sometimes I loose draft emails that haven't been explicitly saved as a draft

    Sometimes I'm working on composing an email on an IMAP account, and I change to another application, take an incoming call, put down the phone for a while, etc. and when I return to finish my e-mail, it's gone. Totally gone. Not in the Drafts folder, not sitting in the inbox in green. When this happens I hadn't explicitly hit "Save Draft" before leaving the composition screen, but I didn't explicitly discard it either. Why should it ever delete an incomplete composition? This is really frustrating.

    (4) Gallery takes a long time to load

    I have many photos on the 32 GB mircoSD card on my phone. About 5000 photos taken with the BlackBerry's camera, and many 1000s more in various folders under ~\removable_SDCARD\photos\ Opening the gallery/photo-picker from any application can be excruciatingly slow. Sometimes even saving a new photo from an application can require 5-10 seconds of waiting before I can press save. Would a faster SD card ameliorate this issue? Should I try moving photos from the ~\removable_SDCARD\photos\ folder into sub-folders, or from ~\removable_SDCARD\Camera\ into sub-folders under ~\removable_SDCARD\photos\ ? Having these photos available on my BlackBerry is important to me, but the delays in choosing them are getting excruciating.

    (5) PIM Services sometimes drains the battery quickly

    I have three email accounts, Facebook, What'sApp and WeChat (in addition to BBM, which I do not use, but seems to necessarily be installed). Sometimes I get through a day with 12+ hours of battery life and an average of ~20% CPU usage. Sometimes there are long periods of 50% - 70% where the PIM services are what's draining the battery and I barely get 4-5 hours of battery life. What is going on here? I have two Exchange accounts and one IMAP account. I have turned off Contacts, Calendar, Tasks and Memos syncing. I have deleted each email account, restarted the device, and reinstalled each account.

    Any help with any of these issues would be most appreciated!
    08-30-15 06:28 AM
  2. mohammad barati's Avatar
    i have classic but i haven't non of ur problems!!
    08-30-15 06:34 AM
  3. Mausje75's Avatar
    The only help I could provide :

    Maybe change the SD could solve you photo issues.

    For the rest I don't have those problems (yet)

    Posted via my awesome Classic
    08-30-15 06:43 AM
  4. conite's Avatar
    Quick fix for #4. Just toggle off automatic stories in pictures app.

    PassportSQW100-4/10.3.2.2639
    servandohv likes this.
    08-30-15 07:07 AM
  5. lipoff's Avatar
    I'm not sure this solves all my photo issues, especially when the file picker is spawned from other applications, but WOW, turning off Automatic Stories makes a huge difference in improving the speed of the Pictures app, especially in the Date view. Thanks very much. I'm also embarrassed to say that I didn't know there was a setting to geotag photos taken with the camera until now. Why geotagging is disabled by default and automatic stories is enabled I do not know.
    08-30-15 10:30 AM
  6. Don_Henry's Avatar
    Hi lipoff,

    The other issues you are having may be caused by a bad OS install. Did you go to 556 OTA, or nondestructively, or did you use an autoloader?

    You may want to consider reinstalling with an autoloader - this would wipe out anything that is causing glitches in operation (will also wipe all your apps and data, so do backups) but this may solve all the other issues.

    Z10 /3 - 10.3.2.2639/2640 - AT&T (posted via CB10)
    08-30-15 10:46 AM
  7. Percy Marsan's Avatar
    reset the OS and install a fresh new OS...too many issues to be good.

    Posted via CB10
    08-30-15 11:23 AM
  8. kgbbz10's Avatar
    I've had my Classic since April (was using a Q10 before) and for the most part I love it, but I have five annoyances in my daily use that keep grating on me. I am running OS 10.3.2.556.

    Are there any solutions to these issues?

    (1) Web search queries disappear if typed too quickly

    I open the browser, and type into the bottom bar where it says "Type search or address"; if I don't pause after typing in a search query or web address before I hit the [Enter] key, the entire text string I've typed just disappears. Relatedly if I don't pause after typing, sometimes a search query ends up parsed as a web address (instead of "this is a google search" it would render as "http://this.is.a.google.search") and sometimes a web address gets truncated (instead of "http://crackberry.com" it renders as "http://crackberry.co"). Yes, I could learn to count to two before I hit the [Enter] key after I type a search query, but why should I have to?

    (2) Programs randomly restart every couple days

    At what seems like random intervals, maybe everyday 1-3 days, some open programs on my BlackBerry Classic will restart. Sometimes it appears that the entire BlackBerry performs an uncommanded reset --- although I've never watched that happen sometimes all the open programs restarted. But the upshot is that while programs like What'sApp and WeChat reload fine, all of the open tabs in my Browser have closed. While I can go and search for them manually in the history and reopen them, one by one, this is really annoying. If the BlackBerry has to restart randomly, I should at least offer the option to reopen all the accidentally closed tabs in one fell swoop (obviously not require re-opening all tabs, since its conceivable that one of those open tabs is what caused the restart).

    (3) Sometimes I loose draft emails that haven't been explicitly saved as a draft

    Sometimes I'm working on composing an email on an IMAP account, and I change to another application, take an incoming call, put down the phone for a while, etc. and when I return to finish my e-mail, it's gone. Totally gone. Not in the Drafts folder, not sitting in the inbox in green. When this happens I hadn't explicitly hit "Save Draft" before leaving the composition screen, but I didn't explicitly discard it either. Why should it ever delete an incomplete composition? This is really frustrating.

    (4) Gallery takes a long time to load

    I have many photos on the 32 GB mircoSD card on my phone. About 5000 photos taken with the BlackBerry's camera, and many 1000s more in various folders under ~\removable_SDCARD\photos\ Opening the gallery/photo-picker from any application can be excruciatingly slow. Sometimes even saving a new photo from an application can require 5-10 seconds of waiting before I can press save. Would a faster SD card ameliorate this issue? Should I try moving photos from the ~\removable_SDCARD\photos\ folder into sub-folders, or from ~\removable_SDCARD\Camera\ into sub-folders under ~\removable_SDCARD\photos\ ? Having these photos available on my BlackBerry is important to me, but the delays in choosing them are getting excruciating.

    (5) PIM Services sometimes drains the battery quickly

    I have three email accounts, Facebook, What'sApp and WeChat (in addition to BBM, which I do not use, but seems to necessarily be installed). Sometimes I get through a day with 12+ hours of battery life and an average of ~20% CPU usage. Sometimes there are long periods of 50% - 70% where the PIM services are what's draining the battery and I barely get 4-5 hours of battery life. What is going on here? I have two Exchange accounts and one IMAP account. I have turned off Contacts, Calendar, Tasks and Memos syncing. I have deleted each email account, restarted the device, and reinstalled each account.

    Any help with any of these issues would be most appreciated!
    1) Stop typing faster than the OS can handle and make sure it's correct before hitting enter.
    2) You have limited RAM to keep those apps open for days at a time so this should be obvious as to why it does this. If your BlackBerry restarts then any open apps will be there once the phone restarts. They will appear as grey boxes on the homescreen until you reopen them.
    3) I never had this issue. You can sync other email folders to the hub, like drafts or trash. It's under settings in the HUB. Maybe your draft folder isn't synced, might help.
    4) 1000's of pics and you wonder why it takes so long to load smh. Go open them on the PC and watch how long it takes that OS to open 1000's of pics with thumbnail view on. Might give you some perspective.
    5) You can turn off push under the HUB settings for your emails.


    BBClassic10.3.2.2639
    Heavens1 likes this.
    08-30-15 01:47 PM
  9. mad_mdx's Avatar
    1) Stop typing faster than the OS can handle and make sure it's correct before hitting enter.
    2) You have limited RAM to keep those apps open for days at a time so this should be obvious as to why it does this. If your BlackBerry restarts then any open apps will be there once the phone restarts. They will appear as grey boxes on the homescreen until you reopen them.
    3) I never had this issue. You can sync other email folders to the hub, like drafts or trash. It's under settings in the HUB. Maybe your draft folder isn't synced, might help.
    4) 1000's of pics and you wonder why it takes so long to load smh. Go open them on the PC and watch how long it takes that OS to open 1000's of pics with thumbnail view on. Might give you some perspective.
    5) You can turn off push under the HUB settings for your emails.


    BBClassic10.3.2.2639
    This is the worst response here.
    OP needs to reload OS without restore.
    08-31-15 09:18 AM
  10. kgbbz10's Avatar
    This is the worst response here.
    OP needs to reload OS without restore.
    Maybe I'm reading it differently then you but it seems most of it seems like user error and impatience. Never hurts to reload the OS, but it isn't going to give him patience.

    BBClassic10.3.2.2639
    08-31-15 10:32 AM
  11. Derekor's Avatar
    Strange, I haven't had any of these issues. Definitely go through your settings as previous posters have advised. Good luck!
    08-31-15 12:28 PM
  12. gloommerchant's Avatar
    #1 drives me crazy.

    Posted via CB10
    08-31-15 01:47 PM
  13. paul360's Avatar
    I have the same issue with #1 - it is reaaaally annoying!

    Both with google searches as well as web addresses. After hitting enter, I'd get the address or search but with the last 5-6 letters just missing..
    09-01-15 12:41 PM
  14. eliirodz's Avatar
    I was having some seemingly random or hardware issues and it was my SIM card. I got a new one and the problems were gone!

    Posted via CB10
    09-01-15 12:46 PM
  15. Boattown Jim's Avatar
    The PIM issue is an endemic problem with the Classic. The file hangs up at the least opportune time. Once the PIM file hangs up the phone battery will be dead in a matter of hours.....even if it was at 100% charged when the issue started.

    I have been thru the mill with BB on this. They can't solve the problem. This is after nearly a year.

    I had to get Verizon involved. They have a device lab that functions as a liaison in dealing with BB. That is much needed as BB will not own up to the problem and or does not know how to fix it.

    I have reloaded the OS several times on the original device. No real improvement. The replacement unit has the same issue. I feel like BB should be paying me for all the time this device has required.

    It is a nice device when it runs properly.....but the battery consumption related to the PIM file hanging up and an intermittent issue with it auto deleting sent emails on the device make it an unacceptable business tool for me. Thank goodness I have an exchange server at work that records everything.....i.e. sent mail that the device somehow auto deletes. BB has no idea what is causing that.

    Good luck!
    09-01-16 06:23 PM
  16. Niallac's Avatar
    1) Inherent limitation of the dated hardware. There are not many 'core' operations that will catch out your Classic in terms of processing power, but this is one.

    2) The restarts are common to every one of the 5 BB10 devices I have owned. At least they don't just stop working when they encounter a serious problem, but restart themselves. Both my Z30s turned themselves off in my pocket, which was seriously inconvenient.

    3) Sounds like a corrupt OS. When loading a new OS version, always use an autoloader (preferable) or the device updater on your PC. Turn off the automatic system updates on your device, and don't use OTA updates at all. IMHO these will often lead to an unstable device.

    4) Try reformatting your existing SD card on your computer, and reorganise the photos onto it. I've got a Class10 card, with 1,500 or so photos, and after the first load from the card after an OS reinstall (this takes 20 minutes or so, ditto music), it is fine.

    5) See 3)

    HTH

    Niall

    Posted via CB10
    09-03-16 03:10 AM
  17. dpgo's Avatar
    Why not using a different browser? I.e Opera or Firefox
    For my email thing, I use a gpl android software K9, it is plenty of features for email and it supports many accounts and protocols

    Posted via CB10
    09-03-16 03:19 AM
  18. FahedAlDerbi's Avatar
    For #1 you can add Google as your homepage and search through it directly and also you could use BlackBerry Assistant for web search

    Posted via CB10
    09-03-16 05:05 AM
  19. KrispyKorpz's Avatar
    #6 when you can't chose between playing with me classic and m Spanky rat. . .
    09-03-16 08:14 AM

Similar Threads

  1. Blackberry z10 'unknow error'
    By yumbox in forum BlackBerry Z10
    Replies: 11
    Last Post: 04-16-18, 04:08 AM
  2. OEM Battery cover for Classic?
    By Oz Inglorious in forum BlackBerry Classic
    Replies: 1
    Last Post: 08-30-15, 11:27 PM
  3. Please I need help, Any alternate app for BlackBerry phone like AirDroid?
    By CrackBerry Question in forum Android Apps (Amazon Store & APK Files)
    Replies: 5
    Last Post: 08-30-15, 03:04 PM
  4. BlackBerry 10 OS
    By muhdabdoul in forum Ask a Question
    Replies: 1
    Last Post: 08-30-15, 05:55 AM
  5. Replies: 0
    Last Post: 08-30-15, 02:39 AM
LINK TO POST COPIED TO CLIPBOARD