1. hanswurst98's Avatar
    About a week ago I bought a used BlackBerry classic. it looked like it was in very good condition and I liked it allot. But now I am noticing that when the phone is just laying the screen keeps on turning on and off without touching the phone. I also can't copy anything onto the phone from my pc because when I plug it in nothing happens. And the last problem I have is that I can only charge it with 2A charger and not the BlackBerry 850mA. It would be really helpful if someone knew what I could do because I really like the phone.

    Posted via CB10
    07-30-15 11:55 PM
  2. velkod's Avatar
    Try a hard reset buddy. Hold both volume buttons down till BlackBerry Classic logo comes up. BlackBerry Link can be weird when using. Make sure drivers install n what not. Plug it in a few times till link reads the phone. Lemme know if any of that helps
    07-31-15 02:02 AM
  3. BlackBerryPancakes's Avatar
    There is a setting somewhere to enable connections to a PC (sorry, I don't have time to find it). Is that enabled?

    There is also a setting to allow USB connections to only charge the phone and not allow any data transfer. Is that turned off?

    Posted via CB10
    07-31-15 02:35 AM
  4. C_Suzuki's Avatar
    I have the same problem with the phone turning on and off with out touching the phone.

    Anyone else experience this and have any fixes?

    Posted via CB10
    07-31-15 05:11 AM
  5. Fastmarc's Avatar
    Which software are you on?

    Posted via CB10
    07-31-15 06:52 AM
  6. hanswurst98's Avatar
    I am using

    I tried too hard reset it, I even did a security wipe but nothing changes.

    When It is pluged in to the computer and I restart it the computer makes a sound that it is connected but it disconnects after 2 seconds.

    Posted via CB10
    07-31-15 07:50 AM
  7. jae hoon's Avatar
    Are those behavior issues related to Adavanced Interactions options maybe?

    How about turning off the options?: lift to wake and hold to stay awake too.

    Posted via CB10
    07-31-15 08:33 AM
  8. hanswurst98's Avatar
    No I only used flip to save power but I tried to turn that off but the same things happen.

    Posted via CB10
    07-31-15 09:22 AM
  9. endashep's Avatar
    Hi, I recently noticed a similar problem with my classic. Assuming that like me it's nothing to do with advanced interactions what I found the issue to be was my SD card. I messed around with it, turning off encryption on the sd card and such but in the end I took out the sd card and it worked find no more screen turning on, I tried a different sd card I had and still works perfect. Must of been some issue with my last sd card which I think related to the encryption too but still no probs having it with the new card. Hope this helps and no need to reset phone.

    Posted via CB10
    12-24-15 03:54 AM

Similar Threads

  1. My BlackBerry clasic doesn't work properly
    By hanswurst98 in forum Ask a Question
    Replies: 1
    Last Post: 08-26-15, 12:02 PM
  2. Pics of BlackBerry slider, and it's NOT running BB10! (Humour)
    By higherdestiny in forum Rehab & Off-Topic Lounge
    Replies: 20
    Last Post: 07-31-15, 10:20 PM
  3. Classic makes Verizon's Editor's Choice list
    By rickkel in forum BlackBerry Classic
    Replies: 4
    Last Post: 07-31-15, 09:30 AM
  4. Replies: 1
    Last Post: 07-30-15, 09:26 PM
  5. Using BlackBerry Link vs OTA
    By rsp21286 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 07-30-15, 09:15 PM