1. h3bdullah97's Avatar
    I charged to 100% came back after 14hrs and it drained to 88%

    before 100% charge it lasted me 3 full days
    01-19-19 03:47 AM
  2. Gene Fells's Avatar
    12% for 14 hours is normal.

    Posted via CB10
    01-19-19 04:59 AM
  3. falbo's Avatar
    It would also help to know if you had wifi and Bluetooth etc turned on or anything else!

    Posted via my Awesome passport
    01-19-19 05:55 AM
  4. h3bdullah97's Avatar
    Just airplane mode with battery saving
    01-19-19 11:10 AM
  5. mh1983's Avatar
    Hmmm yeah, that doesn't seem good. Have you tried a hard reboot lately? Do you have Android apps installed?

    Posted via CB10
    01-19-19 11:20 AM
  6. Tim-ANC's Avatar
    Did you check app usage in device monitor?
    h3bdullah97 likes this.
    01-19-19 11:20 AM
  7. mh1983's Avatar
    Did you check app usage in device monitor?
    Exactly. Sounds like something is overactive in the background.

    Posted via CB10
    h3bdullah97 likes this.
    01-19-19 11:27 AM
  8. joeldf's Avatar
    Still on the original battery?

    They start to get noticeably weak after a couple years.

    I still have Z10 with its notoriously undersized battery that is now pushing 6 years old. Right before I retired the phone a year and a half ago, I was getting maybe 8 hours of full use out of it - that's mobile data, wi-fi and 3 email accounts syncing (2 EAS and 1 IMAP), and that's with some browsing and lots of CrackBerry forum reading. I never used Bluetooth on it.

    When it was new, I got maybe 16-18 hours. Don't know about "stand-by" time as it was in constant use.

    After its retirement, the mobile data was turned off (SIM deactivated), ran only wi-fi, and only occasionally looked at. My youngest son played with the Story Maker app a lot. Now I get up to just over 4 days before I have to charge it up.

    Wi-fi is not the big power drain. The cellular connection is.
    01-19-19 12:17 PM
  9. h3bdullah97's Avatar
    Still on the original battery?

    They start to get noticeably weak after a couple years.

    I still have Z10 with its notoriously undersized battery that is now pushing 6 years old. Right before I retired the phone a year and a half ago, I was getting maybe 8 hours of full use out of it - that's mobile data, wi-fi and 3 email accounts syncing (2 EAS and 1 IMAP), and that's with some browsing and lots of CrackBerry forum reading. I never used Bluetooth on it.

    When it was new, I got maybe 16-18 hours. Don't know about "stand-by" time as it was in constant use.

    After its retirement, the mobile data was turned off (SIM deactivated), ran only wi-fi, and only occasionally looked at. My youngest son played with the Story Maker app a lot. Now I get up to just over 4 days before I have to charge it up.

    Wi-fi is not the big power drain. The cellular connection is.
    its new classic bough 10days back
    01-20-19 02:11 AM
  10. h3bdullah97's Avatar
    Last 48 hrs, system 32%
    android player 4.6%
    standby 4%
    imo beta 3%
    pin service1.2%
    payment options 0.92%
    display 0.92%
    lite measenger 0.51%
    telegram 0.36%
    home acrewn 0.29%

    and so so


    ive resetwd twice after buying the moment i bought just like that randomly

    and these are my apps installed

    from bbworld
    vat calculator
    scan to text pro
    screen recorder

    twitter10
    maps10
    cleaner
    face10
    supertube
    messengr 10
    effetic pro
    cb10
    browsie browser
    easy gpa
    cleartrip parrot


    and my android apks are

    telegram
    messenger lite

    from amazon appstore just this one mxplayer
    01-20-19 02:15 AM
  11. h3bdullah97's Avatar
    It would also help to know if you had wifi and Bluetooth etc turned on or anything else!

    Posted via my Awesome passport
    just charged it to 100% and left it two days to see my standby time now its 50% just by sitting with airplane mode ajd battery saver

    check i posted my usage down
    01-20-19 02:18 AM
  12. h3bdullah97's Avatar
    It would also help to know if you had wifi and Bluetooth etc turned on or anything else!

    Posted via my Awesome passport
    No Sire, have a look down i write my usages
    01-20-19 02:18 AM
  13. m3ach's Avatar
    its new classic bough 10days back
    New means it's been sitting on a shelf for 3 or 4 years without being charged which is not good for battery life in the long term unfortunately.

    Posted via CB10 using my P'9982 running 10.3.3.3216
    01-20-19 08:11 AM
  14. joeldf's Avatar
    its new classic bough 10days back
    New means it's been sitting on a shelf for 3 or 4 years without being charged which is not good for battery life in the long term unfortunately.

    Posted via CB10 using my P'9982 running 10.3.3.3216
    Exactly. The last Classic was made in mid-2016. Coming up on three years, and that's if what you got was among the last ones made.
    01-20-19 08:28 AM
  15. h3bdullah97's Avatar
    New means it's been sitting on a shelf for 3 or 4 years without being charged which is not good for battery life in the long term unfortunately.

    Posted via CB10 using my P'9982 running 10.3.3.3216
    you’re right , guess bad luck
    01-20-19 10:00 AM
  16. h3bdullah97's Avatar
    Exactly. The last Classic was made in mid-2016. Coming up on three years, and that's if what you got was among the last ones made.


    thanks for checking out ny issues and replying
    01-20-19 10:01 AM
  17. mh1983's Avatar
    Last 48 hrs, system 32%
    android player 4.6%
    standby 4%
    imo beta 3%
    pin service1.2%
    payment options 0.92%
    display 0.92%
    lite measenger 0.51%
    telegram 0.36%
    home acrewn 0.29%

    and so so


    ive resetwd twice after buying the moment i bought just like that randomly

    and these are my apps installed

    from bbworld
    vat calculator
    scan to text pro
    screen recorder

    twitter10
    maps10
    cleaner
    face10
    supertube
    messengr 10
    effetic pro
    cb10
    browsie browser
    easy gpa
    cleartrip parrot


    and my android apks are

    telegram
    messenger lite

    from amazon appstore just this one mxplayer
    Surprised no one's mentioned the system usage being quite high. Something's keeping the processor throttled on high which is why your battery's draining (age/battery health aside).

    I'd go to security > app permissions under settings and make sure "run when minimized" is disabled for apps. Experiment with a few and see if that helps. Android apps tend to drain the most battery but you don't have many. Hopefully changing this permission shows an improvement.

    Posted via CB10
    brookie229 likes this.
    01-20-19 10:56 AM
  18. mh1983's Avatar
    System usage should be 5-10% when the device is idle.

    Posted via CB10
    01-20-19 11:02 AM
  19. the_boon's Avatar
    In my experience, yes it sucks
    01-20-19 12:23 PM
  20. brookie229's Avatar
    I'd go to security > app permissions under settings and make sure "run when minimized" is disabled for apps
    Yep--I second that suggestion and for virtually ALL apps.
    01-20-19 12:27 PM
  21. skrble's Avatar
    It's been always bad with my Q10 (I've had it for year and half). Q10 and Classic are bad, Z10 is really hard to go through a day (considering you are one of us who use it mid-heavily though the day). Still far from Priv, that was a pure disaster.
    01-20-19 01:19 PM
  22. h3bdullah97's Avatar
    Surprised no one's mentioned the system usage being quite high. Something's keeping the processor throttled on high which is why your battery's draining (age/battery health aside).

    I'd go to security > app permissions under settings and make sure "run when minimized" is disabled for apps. Experiment with a few and see if that helps. Android apps tend to drain the most battery but you don't have many. Hopefully changing this permission shows an improvement.

    Posted via CB10
    Yes i did have that disabled right after i bought the device/after resetting
    01-21-19 03:36 AM
  23. h3bdullah97's Avatar
    Yep--I second that suggestion and for virtually ALL apps.
    i forgot to mention that , i did have that disabled and another one run on background md am gettinf bad battery yet :/
    01-21-19 03:37 AM
  24. h3bdullah97's Avatar
    I have gone through it again and put all of them disabled run when minimized and run ij background for all of them.

    Just for one Screen Recorder ,

    Regarding parrot app to work properly would those work if disabled?
    01-21-19 03:49 AM

Similar Threads

  1. BlackBerry KEY3 is pretty much confirmed
    By Uzernemm in forum BlackBerry KEY2
    Replies: 54
    Last Post: Today, 04:51 PM
  2. Whatever the BBI100 is
    By thurask in forum Rumored Devices
    Replies: 36
    Last Post: Yesterday, 09:35 AM
  3. Is there LinkedIn apk app that works out there?
    By truth4u in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 01-21-19, 07:42 PM
  4. So BB10 outlasts Windows Mobile 10...
    By EFats in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 01-20-19, 01:25 PM
  5. Replies: 3
    Last Post: 01-17-19, 03:48 PM
LINK TO POST COPIED TO CLIPBOARD