1. JStone3000's Avatar
    Hi. I've gone through older threads and can't seem to find a fix. Here's my details and actions:

    • BB Classic running OS
    • Lenovo Thinkpad running Windows 7
    • BB Desktop

    • Tried connecting through all USB ports
    • Checked in Device Connections that all connections are allowed. Also checked in Networks and Connections and verified that the phone registers as connected via USB when it is plugged in (it does).
    • Checked that IPv6 is enabled (it is)
    • Tried reinstalling BB Desktop
    • Shut off and restarted both phone and computer several times, in different orders, both connected by USB and disconnected (i.e. plugged in afterward).
    • Switched/Forgot devices several times and started connection over again. Never recognizes anything via USB in Link or Blend.
    • Right-clicked on Windows notification icon for Blend and selected "Start on USB Device Connection", closed program, restarted program, and connected BB. Also restarted with BB already connected.
    • Took it out of the Otterbox and connected it via various USB ports in case that was affecting the connection.

    Plugging in the phone does not prompt anything on the computer, although the phone begins charging. Can only open the phone as a network once it is recognized via wireless connection (i.e. the phone doesn't automatically appear as a drive through Windows). Ultimately, I just want to A) add all my important files to the phone in a fast manner, 2) import all of my contacts in a batch format (not upload each one individually through Blend), and 3) backup the phone.

    Any help or workarounds are appreciated. Thanks.
    Last edited by JStone3000; 01-12-16 at 10:12 AM.
    01-12-16 09:21 AM
  2. fschmeck's Avatar
    The most obvious thing I would try would be another usb cable, if you haven't already. I know I have 1 usb cable that literally only works for charging, no data.

    Once that is eliminated, the next is to eliminate the PC. I had the same problem with my Playbook, and it took removing the RIM usb drive completely and re-installing, in spite of the fact that it "claimed" being connected.

    Wish I could be more help, but I'm still on the fence as to whether this is a phone or PC problem, and am leaning towards PC. Trying on another system would at least establish that, or have you already done so?
    01-12-16 07:02 PM
  3. JStone3000's Avatar
    Thanks for the response. I have indeed used two different cables, the other being an identical LG cable from my old Verizon phone. I could probably fish around and find a third one to try as well.
    I'm leaning towards PC too, simply because the phone claims to be connected while the PC is the one that seems confused. I just googled an article on how to do a clean uninstall and will follow the directions (previously I have only removed the Desktop program, but did not clear the registries, etc.).
    I can't try it on another PC: I am a lonely Windows nomad in a strange land of Macs. But maybe demonstrating that it works on an Apple device would eliminate the phone.
    Any other advice is appreciated. Thanks again.
    01-12-16 10:29 PM
  4. JStone3000's Avatar
    Deleting and reinstalling (including deleting registries) didn't work. :/
    01-14-16 08:07 AM
  5. fschmeck's Avatar
    Is there not a way to remove the Blackberry usb entry completely? I wonder if it would behave differently in safe mode?

    Posted via CB10
    01-14-16 05:30 PM
  6. L_O_D_B's Avatar
    I have experienced the same issue. Blend worked smoothly with my Z10, for the most part, but has not been a pleasant experience at all with the Classic. Hopefully the next BB10 OS update will resolve these issues but we all know the demise is near.

    Posted via CB10
    01-15-16 12:22 AM
  7. JStone3000's Avatar
    Is there not a way to remove the Blackberry usb entry completely? I wonder if it would behave differently in safe mode?

    Posted via CB10
    Thanks for this - it helped me figure it out. I was deleting the registry keys, but only for the software. Then I tried to delete the registry keys for the USBSTORE, and most of it came out, but some wouldn't. Then I used an app "USBDeview" and removed the RIM associations with the F drive. I then restarted, connected the BB, and then disabled USB mass storage settings. This prompted BB to install its own drivers, and when it did the install from the internet, it installed an older version of Blend. This recognized my BB via USB, although it eventually prompted me to install the updates to the new software. Not sure which of these steps was the killer point, but it all culminated in success. Thanks for all the recommendations.
    Last edited by JStone3000; 01-19-16 at 06:32 AM.
    01-18-16 11:09 PM
  8. Mic2cool7's Avatar
    I am having the exact same issue. It is good you figured it out, but I can't seem to get it to work. I'm using a Mac and I have to chalk this up to a bug in the software. BB Link recognizes my Classic, but says it can't communicate with it. Is anyone else having issues with BB Link/Blend with their Classic?
    05-10-16 09:15 PM

Similar Threads

  1. I can't save Local contacts to SIM card
    By thelynchies in forum BlackBerry Z10
    Replies: 3
    Last Post: 01-15-16, 03:58 PM
  2. Failed to send message big red X. How can I fix it?
    By CrackBerry Question in forum BlackBerry Bold 9930/9900
    Replies: 2
    Last Post: 01-12-16, 07:05 PM
  3. Anyone else having problems signing on to Blend?
    By Tamashek in forum Ask a Question
    Replies: 1
    Last Post: 01-12-16, 07:58 AM
  4. How to delete contacts from SIM card?
    By Matt J in forum BlackBerry Priv
    Replies: 0
    Last Post: 01-12-16, 07:11 AM
  5. I already have a BlackBerry ID but it's not working. What can I do?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 01-12-16, 06:22 AM