1. nimra66's Avatar
    Since the update onto 10.3.3.2137 my battery shows strange behavior... it shows like only 5% and after charging it for 10 minutes is on 85% but then again using the phone for 5 min back to red figures.
    I did a full security wipe and then it only charged up to 85% - not more, even after 2 hrs and then after warm reset it went to 75% and would charge higher and again after a few minutes stand by its down to 10 %...
    Any ideas and help is appreciated!
    09-21-18 06:23 PM
  2. Bla1ze's Avatar
    Check BlackBerry Virtual Expert and see what it says about your battery status. It happening after the update could just be coincidence.
    09-21-18 11:01 PM
  3. curves2000's Avatar
    Check BlackBerry Virtual Expert and see what it says about your battery status. It happening after the update could just be coincidence.

    I used this app just now and it shows my battery health at Orange/yellow. Any thoughts?? I tried finding a chart to show what the battery health is but I couldnt.

    I used to use a BlackBerry app for my Playbook that showed the health of the battery and how many charges I had. I can't seem to find it now.

    Thanks

    Posted via CB10
    09-21-18 11:32 PM
  4. Bla1ze's Avatar
    I used this app just now and it shows my battery health at Orange/yellow. Any thoughts?? I tried finding a chart to show what the battery health is but I couldnt.

    I used to use a BlackBerry app for my Playbook that showed the health of the battery and how many charges I had. I can't seem to find it now.

    Thanks

    Posted via CB10
    Orange / yellow would be standard for a device as old as the Classic. I dunno, that's a hard issue to pin down really. I'd suggest a reset but you've already done that. The only other thing I can think of would be to try changing your charging cables and see if your device reacts different on a different cable. Which also brings up something else I suppose, the charging port itself could be going bad.
    09-21-18 11:43 PM
  5. brookie229's Avatar
    I used this app just now and it shows my battery health at Orange/yellow.
    That means your battery is NOT optimal. Green would be good -- yellow/orange is usable but needs changing soon.
    09-21-18 11:55 PM
  6. curves2000's Avatar
    Orange / yellow would be standard for a device as old as the Classic. I dunno, that's a hard issue to pin down really. I'd suggest a reset but you've already done that. The only other thing I can think of would be to try changing your charging cables and see if your device reacts different on a different cable. Which also brings up something else I suppose, the charging port itself could be going bad.

    Thanks for your suggestions. My device is actually a Passport SE and just under 2 years old. I hijacked the thread and the Classic forum.

    I was just looking at the battery health and it isn't the same as when I bought the phone but it seems to be depleting rather quickly now that it's almost 2 years. I might be lucky to get 12 hours on a easy day but more like 9-10 if it's busy

    Posted via CB10
    09-21-18 11:57 PM
  7. nimra66's Avatar
    Check BlackBerry Virtual Expert and see what it says about your battery status. It happening after the update could just be coincidence.
    Tku !

    The virtual expert shows just the percentage and if it's loading or not not loading - but no thing more!
    Also changed the cable for loading - still same problem!
    I suspected that the percenatge is wrong but don't know how to recalibrate this battery!
    Will now load it for a few hrs then let it fully discharge until device stops and the load it again - any others suggestions?
    09-22-18 04:52 AM
  8. m3ach's Avatar
    I recently read an old thread which was about this issue and one solution, which seemed to work for several of those who participated, was to keep using the phone past 0% battery, some found the phone carried on working for hours past the 0% then would recharge properly and cure the problem.

    Personally I haven't had the issue but it may be worth trying, I wouldn't normally recommend letting the battery go lower than 20% before recharging however, if your battery is on the way out it probably doesn’t matter.

    Posted via CB10 using my Classic running 10.3.3.3216
    09-22-18 10:54 AM
  9. nimra66's Avatar
    ok - did that: made the battery loose juice completely and after two times doing this with full charge up it again seems to be back in a quite normal range, at least for now!
    thanks for your inputs!
    09-29-18 06:32 AM
  10. m3ach's Avatar
    You're welcome, glad it worked for you.

    Posted via CB10 using my Classic running 10.3.3.3216
    nimra66 likes this.
    09-29-18 07:31 AM

Similar Threads

  1. Battery Draining
    By mohammad alam in forum BlackBerry Leap
    Replies: 5
    Last Post: 09-24-18, 07:47 PM
  2. battery of BlackBerry keyone
    By WorldWideBenz in forum Ask a Question
    Replies: 1
    Last Post: 09-22-18, 07:18 PM
  3. Save up to 40% on Anker's chargers, cables, portable batteries and more
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 09-21-18, 08:00 AM
  4. Battery life in Oreo
    By juanmad in forum BlackBerry KEYone
    Replies: 18
    Last Post: 09-20-18, 10:19 AM
  5. KEYone battery issues
    By George Bekei in forum Ask a Question
    Replies: 1
    Last Post: 09-17-18, 01:54 PM
LINK TO POST COPIED TO CLIPBOARD