1. gregsnyder@yahoo.com's Avatar
    I've done a lot of searching to see what's written about the Classic being out of battery even though all indicators--icon, Device Manager, Battery Analyzer app-- show 50%. I've found information about the Z30, but that doesn't apply because the Z30 has a removable battery. My battery is draining at a normal rate, but from what I've observed, the battery "meter" is going down at 1/2 the actual rate. When the level shows a 10% drop, I think it's actually 20%. A 20% drop is actually 40%, so a 50% drop is actually 100%.

    I'm running 10.3.3.1463. I think this problem started around that update. I've not been able to find any kind of battery re-calibration method, so I imagine that there is not one available.

    I've run the battery to depletion, then back to 100%. Once the charge is sufficient to start the phone, the meter shows 50%. I don't want to do a total reset because I'll lose the play store apps and my classic doesn't play well with the side load. Does anyone know of any other solution? If not, knowing how the battery meter is functioning, I"ll just consider that it's using twice what its showing.
    09-23-17 03:37 PM
  2. eiruvrav's Avatar
    Use your phone until the battery shows 0%. If it keeps running don't charge it until it dies and see how much time you get from 0 until it dies. It seems the fix to this is let the phone die completely and give it a full charge after while off.
    09-23-17 08:31 PM
  3. gregsnyder@yahoo.com's Avatar
    I'll try that. Problem is that the phone shuts down at 50 percent and gives me the red battery symbol. I try to restart it and it won't re-initialize. I have to plug it in, and then it shows 50 percent. The battery circuit may be faulty and giving a bad readout.

    Posted via CB10
    09-23-17 08:50 PM
  4. eiruvrav's Avatar
    Try to deplete your battery as much as possible before charging. If it dies at 50% put it in for a charge and don't remove for 5-6 hours even if it shows 100%. If possible do not use the phone while it is charging after it dies until it is fully charged.
    09-23-17 08:55 PM
  5. gregsnyder@yahoo.com's Avatar
    Thank you. I will give that a whirl.

    Posted via CB10
    09-24-17 12:19 AM
  6. goodayeh's Avatar
    Mine had started shutting down initially at about 20 %.

    With time it is getting worse.
    Now at 50 , goes dead.

    Once plugged in , it will be fully charged within about 1/2 hour.

    I believe it would have to be a faulty battery.
    10-04-17 07:09 AM

Similar Threads

  1. Replies: 32
    Last Post: 10-02-17, 05:37 PM
  2. Q10 future vs battery availability
    By petercreasey in forum BlackBerry Q10
    Replies: 7
    Last Post: 09-24-17, 05:20 AM
  3. Battery (Not) Optimization to improve cell signal
    By sandyhois in forum BlackBerry KEYone
    Replies: 1
    Last Post: 09-23-17, 04:04 PM
  4. AT&T *only* sell their Space Black model.
    By johnb_xp in forum BlackBerry KEYone
    Replies: 1
    Last Post: 09-22-17, 10:53 PM
  5. why my DTEK60 battery is discharging rapidly
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-22-17, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD