1. MissMy9630's Avatar
    Anyone else having issues charging their Classic? Multiple wall warts up to 2A (including the one it shipped with) and my Bolse multiport charger all report the "To charge your device faster..." error, and do not charge slowly or otherwise. The only working methods I've found are connecting to a laptop, or a vehicle cigarette lighter with USB adapter.
    06-15-15 04:24 PM
  2. diegonei's Avatar
    But does it charge? And does it take less than 2 hours to?

    A loose connector can cause that error (and by the makers, most BB made cables/ports feel lose when used with pretty much anything else). But if that 2500 battery is charged from 0-100 in less than 2 hours, I'd say all is working as it should.

    EDIT: This site says it should take a little over 90 minutes for a 2A charger to get a Classic ready to go. If you're getting something around that, the error is just a mild annoyance that can be ignored.
    06-15-15 07:13 PM
  3. Fastmarc's Avatar
    I got that message from day 1 (in December) with the original charger, but since I use it to charge it over night it's not an issue and figure the slower charge rate could be beneficial. I have no idea how long it takes to charge.
    I don't get that message with the PlayBook charger and I would use that if I need to charge it quickly which is rarely.

    Posted via CB10
    06-15-15 10:41 PM
  4. MissMy9630's Avatar
    Hi All,
    Thanks for the interest/replies. To clairify, unless connected to a computer or the cigarette lighter/usb adapter in my daily driver, the Classic is not charging at all.

    diegonei - It doesn't take a charge even at the slower rate. After seeing the above error, I left it about 8 hours on the bedside connected to the factory charger. In the morning the battery showed less charge than the night before.

    Fastmarc - Agreed, slower charging rate is kinder to the batteries, and overnight charging is my usual mode of operation. Sounds like you're seeing the error/message, followed by a successful trickle charge. Unfortunately not my experience.

    As an update, I did some camping over the weekend and the cigarette lighter/usb trick didn't work for me. Other than a different vehicle, everything (adapter, cable, device) was the same. When connected to the new vehicle I saw a new message saying "The USB port has experienced a surge state. The USB port will be disabled to protect the device."

    Starting to think it's an issue for BB warranty service to handle.
    06-22-15 08:17 PM

Similar Threads

  1. How many apps do you have?
    By FCSC in forum BlackBerry 10 OS
    Replies: 19
    Last Post: 07-08-15, 09:04 PM
  2. Z10 Freezing - During a call Issue
    By kingrizz in forum BlackBerry Z10
    Replies: 5
    Last Post: 06-16-15, 12:06 PM
  3. Have Classic, Thinking of Passport
    By slowsteve in forum BlackBerry Passport
    Replies: 14
    Last Post: 06-16-15, 10:40 AM
  4. Replies: 1
    Last Post: 06-16-15, 12:56 AM
  5. Latest update to Book-zy adds Passport and Classic support, new features, and bug fixes
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 06-15-15, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD