1. BbClassic's Avatar
    I am noticing a slew of posts about Classics freaking out and running on their own and being non-responsive... only to suddenly behave again. Some folks have said it is a cache thing and others are blaming the digitizer or sun/humidity on the screen. Mine just did this for a few hours and now is perfectly fine again. I have one of the 1st Classics that came out from Verizon and have never had anything like this happen before. I really wonder if the latest software update is the culprit? So strange that so many of us have this all of a sudden!
    Last edited by BbClassic; 04-17-16 at 06:51 PM.
    04-17-16 06:38 PM
  2. ClassicChris's Avatar
    I hope it wont, but if you exprience it,will happens again

    Posted via CB10
    04-17-16 07:02 PM
  3. JeBe4's Avatar
    Just buy a new one it's only $299

    J Be....Here But Gone...
    04-17-16 09:44 PM
  4. rhoric's Avatar
    No issues here. Had mine for a year. Still running 2474 as I have turned off automatic updates

    Posted via CB10
    04-17-16 09:54 PM
  5. SK122387's Avatar
    Just buy a new one it's only $299

    J Be....Here But Gone...
    Ha.

    Posted via CB10
    04-18-16 02:44 AM
  6. wilber1's Avatar
    Strange Magic .
    04-18-16 07:31 AM
  7. Trist's Avatar
    I am noticing a slew of posts about Classics freaking out and running on their own and being non-responsive... only to suddenly behave again. Some folks have said it is a cache thing and others are blaming the digitizer or sun/humidity on the screen. Mine just did this for a few hours and now is perfectly fine again. I have one of the 1st Classics that came out from Verizon and have never had anything like this happen before. I really wonder if the latest software update is the culprit? So strange that so many of us have this all of a sudden!
    Since you're on Verizon... what's your OS ver.?

    Posted via CB10
    04-18-16 08:49 AM
  8. CivilDissident's Avatar
    Had this Classic for over a year and no issues here... I use it HARD too... Functions like a champ... but then again so do my 9900, 9780, etc... I've had a pretty decent track record with my beloved Berrys thus far... The Classic continues to follow suit...

    Posted via CB10
    04-18-16 05:21 PM
  9. BbClassic's Avatar
    HEY TRIST - "Since you're on Verizon... what's your OS ver.?"

    10.3.2.858
    04-18-16 06:50 PM
  10. Trist's Avatar
    HEY TRIST - "Since you're on Verizon... what's your OS ver.?"

    10.3.2.858
    If I'm not mistaken, the latest version for OS10 should be 10.3.2.2876, which btw is giving lot of people battery and android runtime issues. I believe android runtime received an update via BlackBerry World to correct the issue, but the battery drain still remains.

    I just checked my Verizon Classic's software release and mine's at 10.3.2.556. I wanted to see if we both had the same release so we can confirm that it's not software update related, but I guess that elimination is out the window..

    Are you using the stock factory charger? Does this occur while it's charging?

    Posted via CB10
    04-19-16 06:23 AM
  11. BbClassic's Avatar
    If I'm not mistaken, the latest version for OS10 should be 10.3.2.2876, which btw is giving lot of people battery and android runtime issues. I believe android runtime received an update via BlackBerry World to correct the issue, but the battery drain still remains.

    I just checked my Verizon Classic's software release and mine's at 10.3.2.556. I wanted to see if we both had the same release so we can confirm that it's not software update related, but I guess that elimination is out the window..

    Are you using the stock factory charger? Does this occur while it's charging?

    Posted via CB10


    YA KNOW.... I was using an old charger that came from some other phone like an LG right before my Classic freaked out. Been using the stock charger and no trouble again. I used non stock chargers in the past though, and never had the freakout so?
    04-19-16 04:19 PM
  12. Trist's Avatar
    YA KNOW.... I was using an old charger that came from some other phone like an LG right before my Classic freaked out. Been using the stock charger and no trouble again. I used non stock chargers in the past though, and never had the freakout so?
    When I was using my Motorola charger that has 2 USB ports, my iPhone 6+ would randomly open apps. This happened overnight and only when I was utilizing both ports.

    Most people's initial reaction is "oh, I've been hacked!" but it turns out a voltage ripple is the main culprit. Using the OEM charger fixed it. 3rd party chargers could have cheap circuitry, and other manufacturers' chargers may be rated differently.

    Posted via CB10
    04-19-16 10:53 PM
  13. ClassicChris's Avatar
    if you drop your BlackBerry just once, digitizer's done.Then the phone is acting crazy. My humble thinking

    Posted via CB10
    04-20-16 06:23 AM
  14. CivilDissident's Avatar
    if you drop your BlackBerry just once, digitizer's done.Then the phone is acting crazy. My humble thinking

    Posted via CB10
    That can't be true... I've dropped my Classic quite a few times over the year+ I've had it in use. (Some of the falls were quite righteously gnarly too...) While I DO have a hybrid case on it, I don't think if the Classic were as fragile as your post implies, the case would be of any help and by your words I should have a fairly unresponsive Classic by now, but (thankfully) this is NOT the case...

    I think any issues that have arisen in regards to this plight are the result of BlackBerry's receding quality control (or 'quasi-quality control' being the more accurate choice in wording as of late). Their devices tend to be fairly hit or miss these days, especially since the 3rd wave of layoffs and beyond happened a few years ago... Sometimes you find a dud, sometimes you find a winner and occasionally you discover your 'winner' turned out to simply be a late blooming dud after all...

    Posted via the CrackBerry App for Android
    Last edited by CivilDissident; 04-20-16 at 10:52 AM.
    04-20-16 07:02 AM
  15. ClassicChris's Avatar
    I love that phone so freaking much tho.....lol....why,why.......

    Posted via CB10
    04-20-16 07:21 AM
  16. lrblair13's Avatar
    My classic froze last week when I tried to restart it. I tried to reload on Link, charge to a wall, laptop, car, nothing worked. I brought it into AT&T, tried autoloader on here, nothing worked. AT&T insurance sent me a brand new classic and it was working perfectly for 4 days, now it's frozen again on the power down screen. I had the latest update, Amazon App Store worked the first couple days then stopped working, so I tried a restart again. HUGE MISTAKE. Any suggestions?
    Last edited by lrblair13; 04-25-16 at 02:53 AM. Reason: solved
    04-25-16 02:22 AM

Similar Threads

  1. CrackBerry Sure Posts a Lot
    By Rare BlackBerry Fan in forum Rehab & Off-Topic Lounge
    Replies: 99
    Last Post: 06-07-16, 07:16 AM
  2. The Blackberry SE is an 80's throwback
    By sesp9 in forum BlackBerry Passport
    Replies: 30
    Last Post: 04-21-16, 06:31 PM
LINK TO POST COPIED TO CLIPBOARD