1. yamee0102's Avatar
    so i have BB 9700,i have no problem setting up wifi connections both at home and in the office....i can easily access the internet at home using wifi but when im here in the office it shows that i am also connected to wifi and the signal is very strong but the problem is i cant access the internet anymore..i can not browse, cant even use whatsapp or facebook which is so strange coz i dont get this problem when im at home..please i really need ur help...
    Last edited by yamee0102; 06-02-13 at 09:22 AM.
    06-02-13 04:29 AM
  2. anon(153966)'s Avatar
    With the WIFI at work, are you required to enter a password to use it? If so, remove the WIFI connection and re-add it, and try again.

    Failing that, maybe they have restrictions on it?

    PS: Thread title changed, too
    06-02-13 12:35 PM
  3. agp101's Avatar
    I used to have the same problem at my gfs house with her router. Everywhere else my 9700 worked fine but with her router, no matter what I changed in its settings, I would have the same problem. My problem would go like this: Connect to wifi, 4 bars full strength works for up to 10 minutes. After 10 minutes the 4 bars are still there and at full strength, but I have zero packets going in or out through my phone. Of course, the Bold thinks it's connected to wifi so it tries to keep using it, but to no avail. If I disconnect wifi and reconnect again it will work for another 10 minutes more or less. For this reason I always just left wifi off over there, I have a sufficient data plan. All of her devices including I pods, laptops, android, symbian, and even my playbook, would work without issues. The 9700 though just didn't like that router. I lived with the problem for about a year till I got a 9320 and that worked fine with her router. For a year I searched extensively at random and I just never find a solution. I suggest if this is the case for you, if this is what's happening, then you either live with it or purchase a new router if you can't live with it. Is this at all what you're experiencing?

    Posted via CB10
    06-02-13 04:21 PM
  4. Rootbrian's Avatar
    The "mimo" series of belkin routers or similar ones like it are prone to incompatibility with blackberry smartphones. I owned one before and it just wouldn't connect. Turns out, even with the firewall and all security turned off on the thing, it was preventing all data transmission to and from the wifi connected blackberry, due to "icmp attacks" which always showed up in the log every single time it tried to load a page.

    If your issue is similar, you'll need a new router.

    Sent from my BlackBerry Bold Touch 9900 using Tapatalk
    06-09-13 06:23 AM
  5. andyhs's Avatar
    there's possibility that the router has setup an mac address filtering, in this case, even the device can connect to the router, it won't have any access.
    or there's also possible, that the router require using proxy as the gateway, which so far i don't think any blackberry devices (up to os 7.1, at least) capable to use wifi via proxy.
    06-09-13 07:22 AM
  6. Rootbrian's Avatar
    there's possibility that the router has setup an mac address filtering, in this case, even the device can connect to the router, it won't have any access. or there's also possible, that the router require using proxy as the gateway, which so far i don't think any blackberry devices (up to os 7.1, at least) capable to use wifi via proxy.
    Exactly. I tried everything with that beklin mimo router and had no choice but to get one of those d-link types and haven't had any issues since then. Any mimo router could be plagued with issues, regardless if the firmware is updated or not.
    06-09-13 07:34 AM

Similar Threads

  1. HELP!! Media Card issue on my 9700!!
    By mevolcom3 in forum BlackBerry Bold Series
    Replies: 5
    Last Post: 03-23-11, 09:36 AM
  2. Really strange wifi issue on my Storm 2
    By BBBowner in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 01-08-10, 08:21 AM
  3. HEEELP!!! Wifi issues on my flip
    By Eraw890 in forum BlackBerry Pearl Series
    Replies: 1
    Last Post: 02-05-09, 08:24 AM
  4. WIFI issue on my new 8820
    By big_coop69 in forum General BlackBerry News, Discussion & Rumors
    Replies: 3
    Last Post: 03-12-08, 01:39 PM
LINK TO POST COPIED TO CLIPBOARD