1. agha123's Avatar
    Hey guys,I am facing a strange problem,whenever I turn WIFI on and try to browse from BB browser,I get an error message which says thathat there is no connection.Then ,when I turn on data services from options ,then I can browse fine provided WIFI is also on. Consequently my prepaid credit starts to get gobbled up as data services is on. My question is why can't I use only WIFI for internet browsing? Why do I have to turn on data services from mobile network connections? . I have no data plan or any sort of BIS services activated. Thanks in advance for the help guys

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-11 10:58 AM
  2. Fubaz's Avatar
    you need data on so that your phone can receive data.
    its like trying to get internet on a laptop with WiFi off or the cable unplugged.

    some providers do not let you use your BB on WiFi, and then when it sees your browsing uses standard WAP/Mobile Internet charges and applies them to your account.

    What you can try, is download Opera or Bolt browser, and then try surfing with your mobile network off, and that will help you see if the WiFi is working.
    05-25-11 11:30 AM
  3. skfreak's Avatar
    try surfing with your mobile network off, and that will help you see if the WiFi is working.
    Yap, I would also recommend this. Best thing would be to get yourself a data plan, so not all of your Prepaid credit keeps fading
    05-25-11 01:54 PM
  4. mv-clear's Avatar
    If you are using the BB browser, have you configured the browser as hotspot browser? Launch the browser, go into options and ensure it's set to hotspot. If it is, then it should work with the data turned off.
    05-25-11 02:23 PM
  5. Phill_UK's Avatar
    If you are using the BB browser, have you configured the browser as hotspot browser? Launch the browser, go into options and ensure it's set to hotspot. If it is, then it should work with the data turned off.
    There is no hotspot browser in OS6
    05-25-11 02:36 PM
  6. stitch69's Avatar
    see if the APN is configured/enabled in
    options >> device >> advanced system settings >> tcp ip
    05-25-11 04:56 PM
  7. agha123's Avatar
    @ Fubaz
    Nope,no luck with opera,same issue

    @stitch.69
    Ok I have enabled APN,now what? Sorry I don't understand what this would do?

    And yes I will get a data plan in the near future ,however, I just wanted to check I'd WIFI works without data services checked

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-11 09:49 PM
  8. stitch69's Avatar
    you should disable the APN so it won't try to, or connect to gprs, not BIS (after you turn data off)

    not 100% sure abt this, just pitching ideas...
    05-25-11 11:58 PM
  9. agha123's Avatar
    you should disable the APN so it won't try to, or connect to gprs, not BIS (after you turn data off)

    not 100% sure abt this, just pitching ideas...
    No luck stich.69 but thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-26-11 12:07 AM
  10. BlackBerry.est08's Avatar
    I don't know if this matters since you're on a prepaid plan but have you tried to turn on data services + wifi but turning off mobile network? For those who have a data plan, we use this when roaming to connect to BIS without incurring extra charges.
    05-26-11 01:02 AM
  11. agha123's Avatar
    Browsing still works but I've yet to see if this method takes up credit,will report back...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-26-11 08:04 AM
  12. stacycullenblack's Avatar
    Same problem here, with my bold 9000. Does anyone else have any other opinions?
    11-01-11 02:56 PM
  13. raino's Avatar
    Same problem here, with my bold 9000. Does anyone else have any other opinions?
    Hi, as Fubaz suggested, turn off your mobile network, and set your browser configuration to Hotspot (I don't remember the exact steps to it, but I'm sure they are on the forum somewhere.)

    You don't NEED to turn mobile network off to surf on Wi-Fi, but it's the best way to avoid any direct on indirect carrier data charges. Good luck.
    11-01-11 07:24 PM
  14. app00's Avatar

    I get an error message which says thathat there is no connection.Posted from my CrackBerry at wapforums.crackberry.com

    Are you setting up a wifi connection first ?
    11-02-11 12:40 PM
  15. blackberry-unlocking710's Avatar
    Some carriers are providing pre-paid SIM cards with Data plan for Blackberry... i think it's the best solution for you..

    If your Blackberry unlocked then it's not a problem to change to a different carrier because if you are using pre-paid you have no contract with it.
    11-05-11 03:55 PM
  16. ishti26's Avatar
    Hei.can someone plz help me?I'm using my bb for last 6months.first 5months it was ok.but since last 25days,it has been using up my credit.evn when its on wifi or not.ihow can I fix it?
    06-29-13 04:14 PM
LINK TO POST COPIED TO CLIPBOARD