1. Oofa's Avatar
    I have two 9930 phones along with other BB, Android and iPhones. These two 9930s can't seem to hold a wifi connection. It disappears and reappears no matter where I am. I've done battery pulls and even complete wipes on both but they still don't hold a wifi connection for more than a couple of hours at a time. All my other phones are fine and steady in the wifi dept. Anyone have a clue as to what it could be?
    08-02-13 02:41 PM
  2. Morty2264's Avatar
    Hello!

    I'm not sure if I can help you, but I do want to ask a question about your Wi-fi. Where is it set up? Where is the signal strength highest? If the modem is downstairs, do your other phones get great signal strength upstairs - just not the two BlackBerrys you mentioned? If so, maybe it is a software issue with the two phones; but I myself, with my BlackBerry 9780 and now my Q10, do not get high Wi-fi strength if I'm upstairs and the modem is downstairs. Sometimes you just need to reset your modem. Have you tried doing that? Wi-fi can be annoying when it doesn't work! Who is your Internet with? If it's someone like Bell or Rogers, you can always call and ask what they think the problem is (though you might be on the phone for a long time, especially with Rogers).

    I hope you get this resolved, and have a good day!
    08-02-13 02:59 PM
  3. hamsterwheel's Avatar
    I used to have that problem as well...turned out it was the hardware itself....it seems some of these units have wifi antenna issues.
    Had to have it fixed. Do you still have warranty?
    08-02-13 03:02 PM
  4. monkor's Avatar
    Dude I'm having the same problem recently. It'll just say "Wi-Fi Disabled" at the top on the notification bar. I have to disable and enable it a bunch to get it started again. On some connections it doesn't do it, but on most it does. Very frustrating. It shouldn't be hardware because it can still see the connection, it just won't connect


    Sent from my BlackBerry 9900 using Tapatalk
    Morty2264 likes this.
    08-02-13 05:30 PM
  5. Oofa's Avatar
    Thanks for the responses. This happens on any wifi. Not just my home wifi. I've been using both phones for quite some time now and this just started happening about a week ago. I get that "wifi disabled" message at the top of the screen and can not manually enable it. After a few hours and once even a few days, it enables itself without me doing anything. I suppose it's a hardware issue and I should see if Sprint can deal with it. It's just strange that it started happening only on the 9930s and at the same time after having used them without any problem for quite a while. I always think I have too many phones but sometimes I'm glad I do have back-ups.
    08-02-13 06:10 PM
  6. howards's Avatar
    There is a thread here on the forum that fixes the wifi antenna that is not placed quite properly in many 9900/30 phones. I followed the instructions and did the fix a few months ago and it really works. If you search you'll see it but if not let me know and I'll send it to you.

    Sent from my BlackBerry 9900 using Tapatalk
    08-03-13 11:21 AM
  7. goodayeh's Avatar
    Try this:

    forums.crackberry.com/blackberry-bold-9930-9900-f235/bold-9900-wifi-signal-find-fix-hardware-751180/
    08-03-13 03:37 PM
  8. monkor's Avatar
    Great thanks! I'm a little chapped that i have to void my warranty to fix it. I'm considering sending it back. But that might be too much of a hassle.

    Sent from my BlackBerry 9900 using Tapatalk
    08-03-13 04:04 PM
  9. Oofa's Avatar
    I appreciate the link and it's quite interesting but I'm not about to start disassembling my phone to fix what might or might not be wrong with it. I am not technically inclined and don't want to mess things up more than they are.
    Until I can get it to a Sprint service center, I'm back to my 9850 which is quite a nice phone except for that horrible keyboard that I can only use in landscape mode.
    08-04-13 10:17 AM
  10. goodayeh's Avatar
    Guys , any repair you do on the device is at your own risk.
    If it's still under warranty , then just take it back for repair / replacement.
    08-04-13 07:08 PM
  11. kazin's Avatar
    Great thanks! I'm a little chapped that i have to void my warranty to fix it. I'm considering sending it back. But that might be too much of a hassle.

    Sent from my BlackBerry 9900 using Tapatalk
    Warranty it. Don't void it to take a look in the back. Although my warranty has already expired, when I took it apart the wifi antenna was fine.
    08-04-13 10:05 PM

Similar Threads

  1. Skype for OS7?
    By RaverWild in forum BlackBerry OS
    Replies: 3
    Last Post: 07-22-15, 02:59 PM
  2. I'm Phone Obsessed, and I Like It!
    By Morty2264 in forum General BlackBerry News, Discussion & Rumors
    Replies: 19
    Last Post: 08-04-13, 01:30 PM
  3. I updated my BB Q10 to 4181 and couldn't make or receive calls.
    By Fadi Maalouf in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 08-02-13, 08:21 PM
  4. Replies: 3
    Last Post: 08-02-13, 04:34 PM
LINK TO POST COPIED TO CLIPBOARD