03-10-15 07:45 PM
135 1234 ...
tools
  1. Gerrardough's Avatar
    These are the sites to download them. I use the semibold one. Also, I included a zip file for another version that's thicker.

    br.blackberry.com/assets/fonts/blackberrylove-semibold-webfont.ttf
    br.blackberry.com/assets/fonts/blackberrylove-bold-webfont.ttf
    br.blackberry.com/assets/fonts/blackberrylove-medium-webfont.ttf

    TUTORIAL:

    1 - rename the extension from ".ttf" to ".font"

    2 - place in phone's device storage, in the "fonts" folder (Device Storage>appdata>rim>fonts) MAKE SURE YOU HAVE YOUR "HIDDEN" FOLDERS VISIBLE.

    3 - now once placed in folder reboot(battery pull/soft reset) phone.

    4 - all fonts should be visible in your display settings.
    It's not working in my phone either

    I do all the above as instructed. But when I get to step 2 It doesn't give me the options to save under appdata>rim>fonts. It only goes as far as device, and there isn't anymore options after that. When I do save, it goes to /Device/home/user/. I can't move the file to the font file. Haaaalp!!! It doesn't work on my computer either, I'm using a Mac, maybe that's the problem
    04-07-12 02:46 AM
  2. tre5tackz's Avatar
    It's not working in my phone either

    I do all the above as instructed. But when I get to step 2 It doesn't give me the options to save under appdata>rim>fonts. It only goes as far as device, and there isn't anymore options after that. When I do save, it goes to /Device/home/user/. I can't move the file to the font file. Haaaalp!!! It doesn't work on my computer either, I'm using a Mac, maybe that's the problem
    You have to make all folders visible! "appdata>rim>fonts" are hidden folders. I don't know how to make these folders visible on mac, but I know how to do it from your phone.

    > Go to "Files" app (check in your application folder)
    > Go into "Files Folder"
    > Press Blackberry button, choose "show hidden".
    > Go into "device", and you should now see "appdata".
    > Place the fonts onto your phone's storage(does not matter where), and choose "cut" and "paste" them into the "appdata>rim>[fonts]" folder.
    > MAKE SURE THE EXTENSION IS RENAMED ".font" & NOT ".ttf"
    > Reboot Phone, Voila!
    04-07-12 03:04 AM
  3. Gerrardough's Avatar
    actually, my font file is not hidden. right when I "click" on device the font folder is right under files. When I choose "show hidden" then "click" on appdata>rim then that's it no font folder. weird?!?

    Sent from my BlackBerry 9900 using Tapatalk
    04-07-12 03:11 AM
  4. Gerrardough's Avatar
    I forgot to mention that when I use the mac book and click on the bb icon and it opens up the device folder, the font folder is not hidden. I renamed the file to .font and clicked and dragged it to the font folder. i eject the BB, reboot then reboot the phone. After rebooting I can see the file under the font folder but the font doesn't show up when I'm trying to change the font under options. Hope that clears things up.

    Sent from my BlackBerry 9900 using Tapatalk
    04-07-12 03:17 AM
  5. tre5tackz's Avatar
    actually, my font file is not hidden. right when I "click" on device the font folder is right under files. When I choose "show hidden" then "click" on appdata>rim then that's it no font folder. weird?!?

    Sent from my BlackBerry 9900 using Tapatalk
    Is this when you do it from your Mac or do it from your phone? I don't know how to instruct you from the mac because the folders are different, as you can see. just throw the fonts on your phone, and do the rest DIRECTLY FROM YOUR PHONE. This is our common ground. I can't help you from a macs stand point.
    04-07-12 03:17 AM
  6. Gerrardough's Avatar
    sorry for the confusion. The first post was from my phone, the second post was from my mac.

    Sent from my BlackBerry 9900 using Tapatalk



    As you can see from the first picture I click on device, then from the second picture the font folder is not hidden.
    Last edited by Gerrardough; 04-07-12 at 03:35 AM.
    04-07-12 03:20 AM
  7. tre5tackz's Avatar
    sorry for the confusion. The first post was from my phone, the second post was from my mac.

    Sent from my BlackBerry 9900 using Tapatalk
    You're gonna have to keep troubleshooting. That "fonts" folder should be in the "rim" folder. And, I just checked and it isn't hidden. only appdata&rim are hidden folders, but fonts is still inside of rim.
    04-07-12 03:33 AM
  8. Gerrardough's Avatar
    I will keep trouble shooting. At least you can see that my "font" folder is not hidden. Maybe thats whats causing the font not showing up? It seems that there is not a option to move the "font" folder inside the "rim" folder.

    Sent from my BlackBerry 9900 using Tapatalk
    04-07-12 03:39 AM
  9. Bilaal's Avatar
    Nice! Which one is that? BlackberryLove-Bold or the other Bold?
    The Blackberrylove-bold-webfont
    tre5tackz likes this.
    04-07-12 04:40 AM
  10. Alex_Hong's Avatar
    Thought I'd show users what they're missing out on

    Click to view quoted image
    its a nice font, but i'm too anal about typography to use it. haha. the kerning is a little off.
    04-07-12 05:19 AM
  11. nashshafrulrezza's Avatar
    sorry for the confusion. The first post was from my phone, the second post was from my mac.

    Sent from my BlackBerry 9900 using Tapatalk
    Click to view quoted image

    Click to view quoted image


    As you can see from the first picture I click on device, then from the second picture the font folder is not hidden.

    why you not press show hidden?

    Sent from Crackberry forums app with the awesome Bold 9900 keyboard.
    04-07-12 06:00 AM
  12. PeterRei's Avatar
    Same problem here: I don't have a "fonts"-folder inside the rim-folder. Didn't find any .font-files at all...
    Wait a wee bit... installed a fonts-manager, installed the fonts, deleted the manager... now I have that folder inside "rim", but the fonts don't show up...
    Last edited by PeterRei; 04-07-12 at 07:42 AM.
    04-07-12 07:23 AM
  13. ria__x's Avatar
    sorry for the confusion. The first post was from my phone, the second post was from my mac.

    Sent from my BlackBerry 9900 using Tapatalk
    Click to view quoted image

    Click to view quoted image


    As you can see from the first picture I click on device, then from the second picture the font folder is not hidden.
    what font are you using in these screenies i really like it

    ** sorry for ignorance read through post and got the fonts. thankyou for telling me how to put fonts on my phone too!
    Last edited by ria__x; 04-07-12 at 09:29 AM.
    04-07-12 08:54 AM
  14. blueyestm's Avatar
    Those bold love fonts just look like arial to me. Never was fond of that group of fonts. I have jester and smythe on mine that I flip back and forth with using the font collection app
    04-07-12 09:20 AM
  15. Gerrardough's Avatar
    what font are you using in these screenies i really like it

    ** sorry for ignorance read through post and got the fonts. thankyou for telling me how to put fonts on my phone too!

    Verdana, I have it set to bold and italic.

    Sent from my BlackBerry 9900 using Tapatalk
    ria__x likes this.
    04-07-12 09:30 AM
  16. mysticmeg's Avatar
    Thought I'd show users what they're missing out on



    Click to view quoted image

    Woooow I thought the original poster probably had a e font but after looking at your screenshot I'm defos gunna be installing this!!!

    Sent from my BlackBerry Bold 9900 using Tapatalk
    04-07-12 11:35 AM
  17. Gerrardough's Avatar
    You're gonna have to keep troubleshooting. That "fonts" folder should be in the "rim" folder. And, I just checked and it isn't hidden. only appdata&rim are hidden folders, but fonts is still inside of rim.




    Now you can see the font has been renamed and its in the "fonts" folder. When I try to change the fonts under options the new font is not showing. I've also renamed the file ".swf" just to see what happens and it's still not showing. What gives!?!

    Sent from my BlackBerry 9900 using Tapatalk
    Last edited by Gerrardough; 04-07-12 at 12:49 PM.
    04-07-12 12:43 PM
  18. rookie127's Avatar
    This method also works on 9700!!!!
    Sweet
    THX!!!!!!!

    Sent from my BlackBerry 9700 using Tapatalk
    04-07-12 01:00 PM
  19. robkd's Avatar
    I had the same trouble when I was trying to do this on my phone, but I was able to do it once I plugged my Bold into my Windows 7 laptop. The above fonts folder (with the two Microsoft swf files) is not the one you want to place your font files in.

    Plug your phone into your computer and do this through USB; you will then see the appdata folder the OP was referring to when you go the device root folder in your file explorer. It's there that you'll have to show all hidden folders in order to see the proper folder. Just go to your device folder on your computer (and not the media card folder).
    Last edited by robkd; 04-07-12 at 06:52 PM.
    04-07-12 01:05 PM
  20. Gerrardough's Avatar
    I had the same trouble when I was trying to do this on my phone, but I was able to do it once I plugged my Bold into my Windows 7 laptop. The above fonts folder (with the two Microsoft swf files) is not the one you want to place your font files in.

    Plug your phone into your computer and do this through USB; you will then see the appearance folder the OP was referring to when you go the device root folder in your file explorer. It's there that you'll have to show all hidden folders in order to see the proper folder. Just go to your device folder on your computer (and not the media card folder).
    I will try this at work on monday since I only have a mac at home, and I use windows 7 at work.
    04-07-12 01:24 PM
  21. Ben1232's Avatar
    You have to make all folders visible! "appdata>rim>fonts" are hidden folders. I don't know how to make these folders visible on mac, but I know how to do it from your phone.

    > Go to "Files" app (check in your application folder)
    > Go into "Files Folder"
    > Press Blackberry button, choose "show hidden".
    > Go into "device", and you should now see "appdata".
    > Place the fonts onto your phone's storage(does not matter where), and choose "cut" and "paste" them into the "appdata>rim>[fonts]" folder.
    > MAKE SURE THE EXTENSION IS RENAMED ".font" & NOT ".ttf"
    > Reboot Phone, Voila!
    I have tried this several times after downloading the provided link. I am not able to get it onto my Bold.

    If something is too difficult - try try try then just give up.....Homer Simpson
    04-07-12 03:22 PM
  22. ria__x's Avatar
    I have tried this several times after downloading the provided link. I am not able to get it onto my Bold.

    If something is too difficult - try try try then just give up.....Homer Simpson
    you doing it on your phone or computer have you got hidden folders showing? after you rename the files disconnect your device and do a battery pull
    04-07-12 03:27 PM
  23. SCrid2000's Avatar
    Thanks very much! I didn't know RIM had it's own fonts!
    04-07-12 03:28 PM
  24. Ben1232's Avatar
    you doing it on your phone or computer have you got hidden folders showing? after you rename the files disconnect your device and do a battery pull
    Hey, yeah I done it on my bb. Followed the instructions and rebooted. Done this 4 times without luck.
    04-07-12 03:30 PM
  25. ria__x's Avatar
    oh ok well it's better to do it on your laptop i found, try it that way?
    Ben1232 likes this.
    04-07-12 03:31 PM
135 1234 ...
LINK TO POST COPIED TO CLIPBOARD