1. Steve_S_T's Avatar
    Hey all.

    Although there are similar threads to this I've not yet found one that offers me a solution to my problem, which is simply that I can't activate wi-fi.

    When I first got my Bold it had the default connection setting of "Wi Fi preferred" and I became aware of battery drain when I was away from my wi-fi zones as the handset searched for a wi fi connection. As the 3G was pretty quick anyway, and I have an unlimited data plan, I decided to just use the Bold on 3G and so changed from "Wi Fi preffered" to "3G & 2G" in the "Manage Connections" section. Yesterday I tried to temporarily re-enable the "Wi Fi Preferred" option, and it's not there. I've been through what seems like all of the opitons to re-connect it and can't do it. I've also tried to connect to 3 different wi fi systems that I know worked previously. When I go into "Manage Connections" Wi Fi (and the network name) is ticked, but the right hand box has a white dash instead of a green tick (or a red cross), just like the Bluetooth option. Any ideas?

    Thanks in advance.
    06-23-09 05:38 AM
  2. Kidcobalt's Avatar
    Did you do a battery pull?
    06-23-09 06:32 AM
  3. dictoresno's Avatar
    the white dash means its not connected but on. the wi-fi preferred option is seperate than the 3G & 2G option. under network options, the connection preference options should say 4 options : wifi only/preferred and mobile network only/preferred. i dont have my Bold with me, but i think i recall that the 3G&2G option is below and seperate from that. sounds like your phone is choosing mobile preferred instead of wifi prefered.
    06-23-09 06:35 AM
  4. Steve_S_T's Avatar
    Yeah, did a battery pull. No good but thanks for the input.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-23-09 06:35 AM
  5. mgumbrell's Avatar
    I had the same. I got the connection after getting into the settings of my router. I did nothing in particular just looked at a few things, gave up and when I came out the BB connected and has done so ever since. I still don't know why it didn't connect until then.

    Good luck.
    06-23-09 06:48 AM
  6. Steve_S_T's Avatar
    the white dash means its not connected but on. the wi-fi preferred option is seperate than the 3G & 2G option. under network options, the connection preference options should say 4 options : wifi only/preferred and mobile network only/preferred. i dont have my Bold with me, but i think i recall that the 3G&2G option is below and seperate from that. sounds like your phone is choosing mobile preferred instead of wifi prefered.
    That's the problem Dictoresno, I don't have that Wifi prepared option in Mobile Network Options, just 2G, 3G and 2G&3G.
    06-23-09 11:22 AM
  7. Steve_S_T's Avatar
    That's the problem Dictoresno, I don't have that Wifi prepared option in Mobile Network Options, just 2G, 3G and 2G&3G.
    Interestingly though if go through the process of setting up the wi fi connection again the Bold does discover my network and say's that it's connected, even though it's not.
    06-23-09 11:26 AM
  8. bt224's Avatar
    Reboot the router at the same time you hit connect after the scan.
    06-23-09 11:28 AM
LINK TO POST COPIED TO CLIPBOARD