1. giper54's Avatar
    I am on my 3rd bold with the last two trackballs getting stuck. I got it through Best Buy and they have replaced both for free. I got a new one two weeks ago and put on the 4.6.0.282 OS and it seemed to work well. A few days later all I got was a white screen, but I turned the Bold off, popped out the battery put it back in and all was fine for a week. This morning I woke up the screen was white tried turning it off and popping out the battery and all I get is a white screen again. Is my Bold a Brick now. If so what next? Any suggestions?
    07-27-09 02:38 PM
  2. Wirelezz's Avatar
    No sounds like a defect, bricked is more just a red flashing led and no screen
    And then its still easy to unbrick, try reinstalling the firmware ! Might solve it

    Posted from my CrackBerry at wapforums.crackberry.com
    07-27-09 03:15 PM
  3. bmwmpower's Avatar
    Depends. What does the screen say on it? You've got to be more specific. Try separating your question into paragraphs if it must be that long.

    If your screen says error 507 and has a circle and some funny shapes, then simply install your OS again. Did you screw with any files, settings or anything?
    07-27-09 03:58 PM
  4. Raven Valkyrie's Avatar
    Reinstall your OS.. I don't think it's a hardware issue
    07-27-09 04:01 PM
  5. laollis's Avatar
    Leave the phone ON and do a battery pull.
    07-27-09 04:27 PM
  6. giper54's Avatar
    Depends. What does the screen say on it? You've got to be more specific. Try separating your question into paragraphs if it must be that long.

    If your screen says error 507 and has a circle and some funny shapes, then simply install your OS again. Did you screw with any files, settings or anything?
    I just have a white screen. Like when you are breaking in a plasma tv. phone works though I could check my voice mail by pressing 1. I will try reinstalling an older firmware later.
    07-27-09 04:52 PM
  7. mandeepkavita's Avatar
    Which .282 OS do u have? Asian CSL??? Or Rogers or Vodafone UK?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-27-09 05:04 PM
  8. giper54's Avatar
    It was the Asian Version.
    07-28-09 12:57 PM
  9. bmwmpower's Avatar
    If your phone works while your screen is white, then your phone is fux0red. Get a new one. (perhaps LCD, but too costly to play guessing games)
    07-28-09 01:03 PM
  10. giper54's Avatar
    I put an older OS on 266 I think and it is working now. Thanks for the help.
    07-28-09 01:05 PM
  11. bmwmpower's Avatar
    Interesting. Good luck!
    07-28-09 01:08 PM
  12. Prosa's Avatar
    If your phone works while your screen is white, then your phone is fux0red. Get a new one. (perhaps LCD, but too costly to play guessing games)
    I have exactly the same problem, you're saying my Berry is broke and i should get a new one? Please tell me that's not true!
    07-28-09 01:34 PM
  13. Prosa's Avatar
    I put an older OS on 266 I think and it is working now. Thanks for the help.
    So i've also put on 266 on my berry but it still shows a white screen.
    Does anybody else have any suggestions?
    07-28-09 02:04 PM
  14. photoshop's Avatar
    I got this exact issue when I left my Bold on overnight without charging - bright white screen and nothing else (beats me how if the batt is dead it can shine out a white screen like a floodlight!). I plugged it back in expecting to get a response, but nothing. I left it plugged in for more than two hours, and finally it kicked into life, although still with a blank, but black screen showing a faint battery logo.

    Advise you check its not a batt exhaustion issue before messing about with the OS side of things - might just save you a lot of trouble if the device fails again mid-install!!

    Hope you get it sorted!

    Steve
    07-28-09 02:05 PM
  15. Prosa's Avatar
    So you recommend to leave my BB in the charger for a couple of hours?
    07-28-09 05:57 PM
  16. Shoogster's Avatar
    Had the same problem... I'm afraid it's not software-related. I've upgraded and downgraded the device software many times. But the white screen kept showing from time to time (mainly when left untouched for some time). I think it's due to a faulty LCD. Your carrier will (probably) fix it for free, as your handset is was faulty to begin with.
    Last edited by Shoogster; 07-28-09 at 08:36 PM.
    07-28-09 08:33 PM
  17. Prosa's Avatar
    Went to the vodafone store yesterday, the guy over there told me that he couldn't fix it. He would've sent it to RIM to fix it over there but it would cost me €500,- that's like 700 US dollars. Think i need to replace the screen. How do i know which screen is the right one?

    OP sorry for jacking your thread but your question is being answered already and nobody is replying to the thread i made

    Thanks for the help thusfar guys
    07-29-09 08:45 AM
  18. EvilOne70's Avatar
    Had the same issue with a refurb AT&T sent me. Mine was definately hardware.
    07-29-09 09:08 AM
  19. Prosa's Avatar
    Ok so I switched my screen with my dad's Bold screen, and his device also gave just a white screen. Pretty sure it's the screen now. I sold my old 8820 so I'm using Pearl now, used to belong to my sister. Needs some getting used to but it's still a BlackBerry so I can live with it.

    Going to buy a new lcd of ebay or something so me and my Bold can be reunited again.
    07-29-09 01:09 PM
LINK TO POST COPIED TO CLIPBOARD