1. kino92's Avatar
    My phone received some water damage about a week ago now. Its still not working. I initial tried putting it in some uncooked rice for 3 days then that didn't seem to work so i put it the airing cupboard for a few days to dry and still no luck.

    When i insert the battery, the red light comes on for about 20secs then turns off for 10secs then this process repeats itself whilst the screen stays black. Nothing comes on the screen.

    Can anybody help me please?
    08-30-11 06:37 AM
  2. Phill_UK's Avatar
    It's toast I'm afraid

    Posted from my CrackBerry at wapforums.crackberry.com
    08-30-11 06:41 AM
  3. kino92's Avatar
    oww damn thanks for breaking the bad news to me!
    08-30-11 09:52 AM
  4. Rootbrian's Avatar
    How to Deal with a BlackBerry thats Gotten Wet--THE RIGHT WAY - BlackBerry Forums at CrackBerry.com

    Wish this was stickied. Sorry for your loss!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-30-11 12:39 PM
  5. kino92's Avatar
    when i plug my bb to the laptop, it still connects and my laptop recognises the device. am i still not able to revive it using app loader or anything?
    09-01-11 06:03 PM
  6. Rootbrian's Avatar
    when i plug my bb to the laptop, it still connects and my laptop recognises the device. am i still not able to revive it using app loader or anything?
    You could chance it. If by anything it works out and loads the OS, you're a lucky one! Use OS 5 if possible.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-01-11 06:08 PM
  7. kino92's Avatar
    You could chance it. If by anything it works out and loads the OS, you're a lucky one! Use OS 5 if possible.

    Posted from my CrackBerry at wapforums.crackberry.com
    Thanks, i'll give it a go! Fingers crossed.
    09-02-11 06:02 AM
  8. kino92's Avatar
    Yes it worked! Whooop, i've revived my phone to OS 5. I might try upgrading it to OS 6
    09-02-11 04:10 PM
  9. kino92's Avatar
    I can't seem to upgrade to OS6 for some reason. It keeps getting too the stage 'Reconnecting to JVM' and my phone just keeps turning on and off. Any ideas how to fix this?
    09-02-11 07:21 PM
  10. Rootbrian's Avatar
    I can't seem to upgrade to OS6 for some reason. It keeps getting too the stage 'Reconnecting to JVM' and my phone just keeps turning on and off. Any ideas how to fix this?
    I guess 6 isn't the best option. :/

    Posted from my CrackBerry at wapforums.crackberry.com
    09-02-11 11:22 PM
LINK TO POST COPIED TO CLIPBOARD