1. James Wang's Avatar
    Hey guys,

    So I got a new voicemail yesterday, listened to it, then deleted it. However, the little voicemail icon at the top with the two loops never went away even after rebooting. I have no other voicemails so I don't know why it stays there. I'm using the native voicemail inbox that came with my 9930 (running .267)

    Anybody got any ideas?
    04-24-12 11:44 AM
  2. edu3110's Avatar
    I had the same issue a couple of times. The first think I did was a battery pull, failed. Then I tried something different, here is what I did and I was able to fix it.

    Call yourself from another phone and leave a voice mail. Then call your voice mail and delete the message. It worked for me, I hope it works for you.

    Please let me know if it did.
    Myrene Treick and James Wang like this.
    04-24-12 12:37 PM
  3. James Wang's Avatar
    It did work. But does this mean I'll have to do this for every other voicemail I receive?
    04-24-12 01:00 PM
  4. totallygone's Avatar
    That still happens to me. I just ignore it and after a few screenlock/unlocks of my phone, it disappears on its own.
    04-24-12 01:12 PM
  5. RegN's Avatar
    I get that with missed calls too, if I delete the missed call the icon will go away but if I return the call it stays. For a test try to delete the incoming call from the call list. I don't have voicemail so not sure how it shows the call in the call list.
    04-24-12 01:16 PM
  6. edu3110's Avatar
    It did work. But does this mean I'll have to do this for every other voicemail I receive?
    I'm glad it worked and I was able to help. No, I had it like twice.
    04-24-12 01:18 PM
  7. SaintThomasAquinas's Avatar
    Hey guys,

    So I got a new voicemail yesterday, listened to it, then deleted it. However, the little voicemail icon at the top with the two loops never went away even after rebooting. I have no other voicemails so I don't know why it stays there. I'm using the native voicemail inbox that came with my 9930 (running .267)

    Anybody got any ideas?
    Had the same problem with a Bold 9000. Annoyed me to no end for three weeks! What worked for me was my wife washed the phone.

    Never had a problem with the message icon after that...

    04-24-12 01:28 PM
  8. Mystic205's Avatar
    I am on Sprint and this happens when i am in a rush.. It can happen if you cut the connection with the voicemail server too quickly..

    Go back into voicemail, and let the nice lady tell you you have no new and no saved messages, then hangup...it will then clear

    Hey guys,

    So I got a new voicemail yesterday, listened to it, then deleted it. However, the little voicemail icon at the top with the two loops never went away even after rebooting. I have no other voicemails so I don't know why it stays there. I'm using the native voicemail inbox that came with my 9930 (running .267)

    Anybody got any ideas?
    04-24-12 02:43 PM
  9. Grand Piano's Avatar
    I am on Sprint and this happens when i am in a rush.. It can happen if you cut the connection with the voicemail server too quickly..

    Go back into voicemail, and let the nice lady tell you you have no new and no saved messages, then hangup...it will then clear

    I always listen to vm and then hit * *
    04-24-12 03:24 PM
  10. Mackiddy3's Avatar
    I also have the same problem. I've had my 9900 for about 6 months, multiple OS upgrades, currently on .342. Nothing i do seems to work. Including calling myself and battery pulls. Help please!
    04-24-12 03:58 PM
  11. melander's Avatar
    I also have the same problem. I've had my 9900 for about 6 months, multiple OS upgrades, currently on .342. Nothing i do seems to work. Including calling myself and battery pulls. Help please!
    I always listen to vm and then hit * *
    I'm able to hangup after listening to vm when the nice lady immediately follows with 'first saved message. I have Sprint with abbreviated vm turned on
    04-25-12 12:40 AM
  12. James Wang's Avatar
    I'm able to hangup after listening to vm when the nice lady immediately follows with 'first saved message. I have Sprint with abbreviated vm turned on
    Wait how do you turn on abbreviated vm??
    04-25-12 12:41 AM
  13. Mystic205's Avatar
    my habit had been to press "7" to delete a message and just hang up.. and occasionally the VM icon remains.. have never tried ** and probably wont..lol

    simply offering a proven theory that fits the OP's facts.. and in this case, you can pull the battery all you like, but if the system thinks you have a vm you will get the icon back


    I always listen to vm and then hit * *
    04-25-12 10:05 AM
  14. Myrene Treick's Avatar
    You won't have to call your voicemail each time and leave yourself a voicemail.

    This worked for me...and I'm not an expert. Again, if the voicemail icon gets "stuck", call your cell phone from another telephone line. IMPORTANT: Leave a long enough message on your voicemail so that the voicemail counter knows to count your voicemail. Now your VM icon should say you've got 2 voicemail messages, instead on 1 voicemail message. Go to your BB voicemail, listen and delete each voicemail, and the "stuck" counter should go back to zero (0) and disappear.

    Worked for this grandma when I did it once. Didn't reoccur.

    Omie (retired, tired RN)
    06-23-13 07:10 PM
  15. iamq's Avatar
    Which network are you on? - the OP that is.

    Gointo your voicemail settings, change the alert type to get rid of the icon - then go back into the settings and reset the icon alert it should fix it.

    I have this problem from time to time with O2 UK and the voicemail icon getting stuck. Hasn't happened in a while but last time it did - i did what I've just put above.
    06-24-13 12:27 PM
LINK TO POST COPIED TO CLIPBOARD