1. Scotty.dont's Avatar
    Hi guys,

    I'm traveling in Germany and need some help.

    I unlocked my Wind Mobile-branded 9700 (T-Mobile frequencies) the day before I left with no problems. But when I got here, it wouldn't connect to any of the networks. I couldn't even roam with my own SIM, which I was willing to do (business trip). I went to a Vodafone store and a prepaid SIM from there won't connect to the network. Everything is SOS Only.

    A girl at an o2 store had a BASE E-Plus SIM that miraculously worked straight away. But I'd prefer to go with Vodafone because they have a pre-paid BIS option with no contract.

    I was really close to buying an Android-powered Motorola Defy just to have something, but forgot my passport and the store was closing. Been thinking about leaving BB for a while but anyway.

    Any ideas why it won't work? I will try reloading OS 6 I guess.

    Thank you,
    Scott
    08-28-11 02:03 PM
  2. freethisberrydotcom's Avatar
    Did you try to switch it to 2G in mobile network options?
    08-28-11 03:56 PM
  3. Scotty.dont's Avatar
    yes, I have tried both 2G and 3G networks. I can only get emergency service "SOS" on all of them.
    08-28-11 04:18 PM
  4. Rootbrian's Avatar
    Google GSM World Map to find the frequency table for where you are. It's likely the other carrier's don't support those frequencies. You're out of luck if you don't use O2, since that seems to work fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-28-11 06:08 PM
LINK TO POST COPIED TO CLIPBOARD