08-22-13 12:12 PM
27 12
tools
  1. KRZR101's Avatar
    Okay, so I bought my Blackberry Bold 9700 a couple of months ago with Telus. I then PERSONALLY unlocked the phone and let my sister use it with her Fido sim card and everything worked great. Then I used it again and now I'm selling it and wiped the phone. I then tried to use both a Rogers and a Fido sim card and it says "Invalid Sim Card" but I know my phone in unlocked. Anyone know what's wrong?

    PS. I also sent it in for warranty repair about a month ago. Could Blackberry have re-locked it?

    I also tried doing the same procedure to unlock the phone again and it won't work. I can't get past the MEP2 part to enter the code in. When I turn on the phone it even says 'invalid sim, do u wanna unlock the phone?' and when i click yes, nothing happens.
    Last edited by KRZR101; 08-02-10 at 06:26 PM.
    08-02-10 06:24 PM
  2. felix1522's Avatar
    Do the SIM cards work in other devices?
    08-02-10 06:41 PM
  3. cooldudie3's Avatar
    Did you check if the security is disabled? If it is, then it's still unlocked. Maybe a problem with the sim cards?
    08-02-10 07:03 PM
  4. dLo GSR's Avatar
    Okay, so I bought my Blackberry Bold 9700 a couple of months ago with Telus. I then PERSONALLY unlocked the phone and let my sister use it with her Fido sim card and everything worked great. Then I used it again and now I'm selling it and wiped the phone. I then tried to use both a Rogers and a Fido sim card and it says "Invalid Sim Card" but I know my phone in unlocked. Anyone know what's wrong?

    PS. I also sent it in for warranty repair about a month ago. Could Blackberry have re-locked it?

    I also tried doing the same procedure to unlock the phone again and it won't work. I can't get past the MEP2 part to enter the code in. When I turn on the phone it even says 'invalid sim, do u wanna unlock the phone?' and when i click yes, nothing happens.
    are you sure they repaired your phone, and didn't simply replace it?
    08-02-10 07:03 PM
  5. KRZR101's Avatar
    Did you check if the security is disabled? If it is, then it's still unlocked. Maybe a problem with the sim cards?
    Ya, it's still disabled :S No, the sim cards work perfectly fine


    Do the SIM cards work in other devices?
    Ya, they work in other devices and that are unlocked as well, even BB's

    are you sure they repaired your phone, and didn't simply replace it?
    They just repaired it, didn't replace it
    08-02-10 07:07 PM
  6. cooldudie3's Avatar
    Hmmm... did you try a battery pull?
    08-02-10 07:08 PM
  7. KRZR101's Avatar
    Hmmm... did you try a battery pull?
    Ya, like ten of them, lol
    08-02-10 07:12 PM
  8. dictoresno's Avatar
    so security is disabled for every single option in the SIM menu? maybe something is wrong with the contacts on the SIM slot. have u tried other SIM cards?
    08-02-10 07:44 PM
  9. Rootbrian's Avatar
    Take the phone to the shop you got it from and have them take a look at it. Hopefully they could fix the problem.


    PS. I also use TELUS. Never had an issue.
    08-02-10 10:17 PM
  10. KRZR101's Avatar
    so security is disabled for every single option in the SIM menu? maybe something is wrong with the contacts on the SIM slot. have u tried other SIM cards?
    No, the security is disabled for every option including "Network" except the "Service Provider" :S
    I have a feeling something is wrong because I don't think the Service Provider shouldn't be active at all...

    And I've tried 3 sim cards so far...


    Take the phone to the shop you got it from and have them take a look at it. Hopefully they could fix the problem.


    PS. I also use TELUS. Never had an issue.
    I bought it from Telus, they're not gonna help me unlock it lol
    Last edited by KRZR101; 08-02-10 at 11:33 PM.
    08-02-10 11:28 PM
  11. shansmi's Avatar
    Sure they will as long as your account is in good standing.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-02-10 11:49 PM
  12. dictoresno's Avatar
    No, the security is disabled for every option including "Network" except the "Service Provider" :S
    I have a feeling something is wrong because I don't think the Service Provider shouldn't be active at all...

    And I've tried 3 sim cards so far...




    I bought it from Telus, they're not gonna help me unlock it lol
    i think it should say disabled for everything. i think i recall my unlocked 9700 being this way.
    08-03-10 12:17 AM
  13. KRZR101's Avatar
    i think it should say disabled for everything. i think i recall my unlocked 9700 being this way.
    Ya, it should. I think the Service Provider should always be disabled and I remember it always being disabled but I don't understand why all of a sudden it's active again :S
    08-03-10 12:20 AM
  14. dictoresno's Avatar
    that is strange. i dont know what wouldve made it go back to enabled.
    08-03-10 01:16 AM
  15. KRZR101's Avatar
    that is strange. i dont know what wouldve made it go back to enabled.
    If I called RIM, would they help me?
    08-03-10 08:42 AM
  16. KRZR101's Avatar
    Ugh life sucks Anyone?
    08-04-10 11:05 PM
  17. shansmi's Avatar
    Like I said before, take your SIM cards and phone to Telus. If your account is in good standing, they will unlock the phone for you. We do it all be email now.

    You said you were sure it was not swapped. How? The @-, and IMEI are the same as before?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-04-10 11:16 PM
  18. KRZR101's Avatar
    Like I said before, take your SIM cards and phone to Telus. If your account is in good standing, they will unlock the phone for you. We do it all be email now.

    You said you were sure it was not swapped. How? The @-, and IMEI are the same as before?

    Posted from my CrackBerry at wapforums.crackberry.com
    Canadian phone companies aren't like American ones. They don't unlock your phones for you
    08-04-10 11:26 PM
  19. shansmi's Avatar
    Really? You have asked and been told no?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-05-10 12:59 AM
  20. dilipc's Avatar
    How do you see that security is disabled? What's the code you have to type for a TMobile 9700?
    08-05-10 02:55 AM
  21. KRZR101's Avatar
    Really? You have asked and been told no?

    Posted from my CrackBerry at wapforums.crackberry.com
    Indeed I was.


    How do you see that security is disabled? What's the code you have to type for a TMobile 9700?
    The security isn't disabled. I never said it was :S
    08-05-10 09:00 AM
  22. ikondave#CB's Avatar
    I requested the unlock code for my BB 9700, and TMo was very prompt in emailing me the directions. I followed the instructions (not the first phone I've unlocked) and everything seemed to go as expected.

    When I arrived in London and inserted my UK SIM card, and received the message that my SIM card wasn't valid. I tried an Orange card a day or so later, and that didn't work either. The salesmen tested the card on a different phone (also unlocked) and it worked just fine.

    When I double checked my 9700's status, the SIM card option read "SIM Card: Security Disabled", which a TMo tech assured me meant that the phone was indeed unlocked. However, while trying to get my phone to work with my UK SIM card, I entered the unlock code the dreaded 10 times, and I've been told that I'm screwed.

    Any suggestions/ info will be much appreciated.
    08-09-10 09:35 PM
  23. cherryjuice's Avatar
    for a hefty price on ur credit card they will> i often bypass the charges by having technical support through my service provider connect me directly to RIM.
    08-09-10 09:59 PM
  24. felix1522's Avatar
    No, the security is disabled for every option including "Network" except the "Service Provider" :S
    I have a feeling something is wrong because I don't think the Service Provider shouldn't be active at all...

    And I've tried 3 sim cards so far...




    I bought it from Telus, they're not gonna help me unlock it lol
    That's your issue right there, you need the MEP4 code to unlock the Service Provider option as well. Otherwise, it's not unlocked.
    08-09-10 10:42 PM
  25. felix1522's Avatar
    I requested the unlock code for my BB 9700, and TMo was very prompt in emailing me the directions. I followed the instructions (not the first phone I've unlocked) and everything seemed to go as expected.

    When I arrived in London and inserted my UK SIM card, and received the message that my SIM card wasn't valid. I tried an Orange card a day or so later, and that didn't work either. The salesmen tested the card on a different phone (also unlocked) and it worked just fine.

    When I double checked my 9700's status, the SIM card option read "SIM Card: Security Disabled", which a TMo tech assured me meant that the phone was indeed unlocked. However, while trying to get my phone to work with my UK SIM card, I entered the unlock code the dreaded 10 times, and I've been told that I'm screwed.

    Any suggestions/ info will be much appreciated.
    Yeah, all the options listed on the MEPD screen need to read disabled... There's no way to get around the 10x wrong code, as far as I know... unless you get a new device.
    08-09-10 10:45 PM
27 12
LINK TO POST COPIED TO CLIPBOARD