08-31-13 05:52 PM
132 ... 3456
tools
  1. shabbs's Avatar
    By any chance, does anybody have their 'Key Rate' set to Fast? I did & I think that might be the culprit.....at least for me.
    Adjusting the key rate seems to help reduce it, but I don't think it's the issue. The issue is with a double tap being done when not expected. Hence, the period when hitting the space bar. I also seem to get it randomly on other keys. I've set my key rate to the slowest rate to see if that will help, but it's only a work around. Is it possible this is due to dirt in the keyboard triggering the double tap? Or is this just faulty hardware?
    07-22-12 11:49 AM
  2. tryfe's Avatar
    Adjusting the key rate seems to help reduce it, but I don't think it's the issue. The issue is with a double tap being done when not expected. Hence, the period when hitting the space bar. I also seem to get it randomly on other keys. I've set my key rate to the slowest rate to see if that will help, but it's only a work around. Is it possible this is due to dirt in the keyboard triggering the double tap? Or is this just faulty hardware?
    After going the day set at Medium Fast down from Fast, i've yet to have it happen. I bet I just jinxed myself..
    07-22-12 10:37 PM
  3. boss_hog's Avatar
    I noticed it imediately after updated from 7.0 to 7.1. It hasn't went away on any of the 7.1s so I just live with it.
    07-23-12 05:54 AM
  4. gq_stylz_s's Avatar
    I have this issue as well, it started about a month ago. I've tried every 7.1 software available and the problem still persists. I gave Rogers a call but that was a waste of 20min.
    A problem like this would seem like a software issue to me since my space key still clicks fine, feels solid and the random period insert only happens once every 15-20 messages.
    If it was a problem with the key itself, you think it would happen more often than it does.

    I'd hate to send my phone in for repair only to get it back with the same issue. Has anyone been able to figure this issue out or can confirm if it is in fact a hardware or software issue?

    For those who've sent it back for repair, are they repairing the phone, or replacing it with a refurb phone?
    07-24-12 12:23 PM
  5. shabbs's Avatar
    Buddy of mine had this issue with his 9900, sent it in for repairs, issue came back a few months later. Design flaw? Hardware flaw? Who knows...
    07-24-12 06:53 PM
  6. howiewolverine's Avatar
    I had this same issue and the problem was that my spacebar was sticking every so subtly. If the spacebar is held down even for a moment, it will insert a period. First, take a look and check if you see anything surrounding your spacebar you can clean out. If not, turn your device off and then just hit your spacebar repeatedly pretty hard to dislodge whatever may be making it stick. This worked for me and I haven't had the issue since. Good luck.
    bgriff25 likes this.
    07-24-12 08:56 PM
  7. CarFan's Avatar
    Anyone tried using a high quality contact cleaner like Deoxit on the keyboard? Can anyone think of a reason it's not a good idea to try it? I use it to clean rotary volume controls on my audio gear.
    07-25-12 12:47 PM
  8. Whyareallthegoodnamestaken's Avatar
    I'm glad my method has worked for a couple of people. No idea why though lol, but never had problems since.
    07-26-12 12:31 PM
  9. Double_J75's Avatar
    I am now getting double letters and period. For example a typical sentence would look like......heyy would. You like to seee my new. Blackkberry?

    I wiped the phone, tried different os versions and it still seems to persist. It is not specific letters either, and seems to be very random. I have also tried using compressed air to clean the kb.

    Any suggestions?
    07-26-12 02:44 PM
  10. Fammodjs's Avatar
    My 9900 has been doing the same thing also running. 342
    07-26-12 03:20 PM
  11. kcgenki's Avatar
    I had this happen shortly after i upgraded to 7.1 (Rogers). After reading some threads, I figured it was a hardware issue and I ordered a new full keyboard. I just tried changing the speed and everything seems fine now, wish I saw this thread earlier!!
    07-30-12 07:07 PM
  12. shabbs's Avatar
    I had this happen shortly after i upgraded to 7.1 (Rogers). After reading some threads, I figured it was a hardware issue and I ordered a new full keyboard. I just tried changing the speed and everything seems fine now, wish I saw this thread earlier!!
    Are you saying you still had the issue after replacing the keyboard? Where did you order the new keyboard from?
    07-30-12 07:34 PM
  13. Double_J75's Avatar
    I took the phone back to see if rim would cover it under warranty. Guess I will know soon enough.
    07-30-12 08:24 PM
  14. ragdeiii03's Avatar
    Are you saying you still had the issue after replacing the keyboard? Where did you order the new keyboard from?
    Did you decrease or increase the keyboard speed?
    07-30-12 08:39 PM
  15. shabbs's Avatar
    Did you decrease or increase the keyboard speed?
    Not sure if this is directed to me... but I have tried decreasing the keyboard speed but the issue remains.
    07-31-12 07:06 AM
  16. ZMc1834's Avatar
    My speed is set to Normal and I have been seeing this issue for the past month or so.
    07-31-12 07:30 AM
  17. diffused's Avatar
    I had this problem a while back for a couple of months over several OS versions until I stumbled across a solution. This worked for me, and there's no guarantee it'll work for anyone else, but it's worth you all giving it a go.

    You need to press down on your space bar quite hard...not hard to the point where you'll break it, obviously. But really rather firm, much more than you're used to. Press a thumb down hard on the left side of the bar, then the right, then the centre. Then press both thumbs down hard across the whole of the space bar.

    I don't know why, but this just worked for me.
    As stated in an earlier post, this had worked for me for quite awhile. The problem has returned and my work around has been to repeat this method with success. I upgraded to 7.1.0.580 over the weekend and the problem has again returned.
    07-31-12 08:20 AM
  18. bgriff25's Avatar
    This issue with the space bar has been bugging me more and more. To the point where I was about ready to take my BB to a Sprint store and see about getting a replacement. Having had to do this in the past I know what a pain in the you know what this can be so I was trying to avoid it. I've tried everything suggested in this thread and others, updating OS, pressing down on the space bar, but nothing has worked for more than a few hours. Yesterday I checked back on this thread to see if anyone had any new suggestions and I found this-
    I had this same issue and the problem was that my spacebar was sticking every so subtly. If the spacebar is held down even for a moment, it will insert a period. First, take a look and check if you see anything surrounding your spacebar you can clean out. If not, turn your device off and then just hit your spacebar repeatedly pretty hard to dislodge whatever may be making it stick. This worked for me and I haven't had the issue since. Good luck.
    and it worked. Here's what I did. I took the battery out held my Bold with the keyboard facing the floor. Then I pressed the space bar, repeatedly, not hard for about 60 seconds of so. So far I have not been able to recreate the problem
    I have also switched from using an OtterBox commuter case back to the OEM pocket pouch, because if the issue is caused by debris getting stuck behind the space bar I feel it will be less likely to happen in the pouch. I had been using the commuter case for so long I had forgotten how sleek the Bold is without a case, and I'm also looking forward to using the charging pod again.
    diffused likes this.
    08-03-12 07:23 AM
  19. Double_J75's Avatar
    I took the phone back to see if rim would cover it under warranty. Guess I will know soon enough.
    Got my phone back, and since it was still with in the one yr warranty they fixed it free of charge.

    Man it feels brand new again
    08-05-12 08:29 AM
  20. BuddyL's Avatar
    I had this problem a while back for a couple of months over several OS versions until I stumbled across a solution. This worked for me, and there's no guarantee it'll work for anyone else, but it's worth you all giving it a go.

    You need to press down on your space bar quite hard...not hard to the point where you'll break it, obviously. But really rather firm, much more than you're used to. Press a thumb down hard on the left side of the bar, then the right, then the centre. Then press both thumbs down hard across the whole of the space bar.

    I don't know why, but this just worked for me.

    i had this problem start to happen over the last 2 weeks to me. I tried this and it hasn't happened since. Thanks

    Sent from my BlackBerry 9900 using Tapatalk
    08-07-12 07:41 PM
  21. Whyareallthegoodnamestaken's Avatar
    You're welcome. As was mentioned by a previous poster, sometimes you will need to repeat this down the line weeks or months later. But it's not exactly much of a chore and it's quick to do. I've had to do it a few times but it works for me.


    Sent from my iPad using Tapatalk HD
    08-13-12 01:17 PM
  22. Whyareallthegoodnamestaken's Avatar
    As stated in an earlier post, this had worked for me for quite awhile. The problem has returned and my work around has been to repeat this method with success. I upgraded to 7.1.0.580 over the weekend and the problem has again returned.
    I'm sorry this solution hasn't been more permanent for you. I think this is an issue with multiple causes and manifestations, some software, some hardware perhaps. As it has multiple causes, there are probably multiple solutions. Personally, I think that RIM should design handsets with ease of user keyboard replacement in mind. Some of us use these things heavier than others.


    Sent from my iPad using Tapatalk HD
    08-13-12 01:30 PM
  23. kolok's Avatar
    This probably is a combination of software/hardware (keyboard) issue.

    I've experienced the same on at least two different firmwares on my phone (9900): 7.1.0.342 and .569 ... Once I changed firmware, the "issue" disappeared completely. This issue is even more apparent on heavily used BBs - meaning once the keyboard wears in. Changed the keyboard to a new one and still experience the odd magical "." when typing using either of those two firmwares.
    Last edited by upset; 08-13-12 at 04:30 PM.
    08-13-12 04:26 PM
  24. Whyareallthegoodnamestaken's Avatar
    Yes, you may be right. A rather difficult issue to solve permanently, indeed if it is a combination. How exactly do you replace a keyboard yourself anyway? Can anyone tell me? What I came up with does work for me but I might replace my keyboard anyway.


    Sent from my iPad using Tapatalk HD
    08-13-12 04:42 PM
  25. kolok's Avatar
    First 2 minutes of this vid shows how to remove the keyboard. Reverse procedure for installation/re-assembly.

    Very simple.

    08-13-12 04:45 PM
132 ... 3456
LINK TO POST COPIED TO CLIPBOARD