1. soe0501's Avatar
    Hi guys, I have caught some problem to my BB.

    When i start up the phone, it will suddenly pop up some notification stated that "Uncaught exception: java.lang.NullPointerException".

    I thought, it's just some minor problem, but now i realize that the icon for SMS/MMS is not there anymore and i'm shocked.

    I tried some ways like to separate them from email, but still could not solve the problem. and also i tried to free up some memory, still could not work, ><

    Please guys help me, I really don't know how to make it back again.
    06-22-09 03:44 AM
  2. phantomsax's Avatar
    If memory serves me (and it usually doesn't) this is due to either a glitch in the OS or in an app that was loaded. I've had this happen several times, to several different berries.

    I am going to give you 2 methods, one is simple and might fix it straight away; the other is not and will definitely fix it, but it will destroy your phone first so proceed to Method 2 with caution.

    Method 1:
    Uninstall any and all apps that you have loaded, one by one and see if it doesn't clear the error on start up. If you don't find it that way, download the latest OFFICIAL OS for your device from your provider and run the update using BlackBerry Desktop Manager. Hopefully the OS update will clear your error.

    Method 2:
    Here is how to fix it for sure, but you will have to brick your phone (lose EVERYTHING!!!). I know there are easier ways, but this is the only thing that has ever worked 100% of the time for me:

    Step 1 - Backup anything you don't want to lose. If you are on BES, you should have your BES profile dumped and recreated so the problem doesn't sync back when you reactivate on the BES. This will also make the activation process go MUCH faster. If on BIS, make sure you have your BIS user and pass if you have one.
    Step 2 - Install the latest BlackBerry Desktop Manager as an Internet only account (non-BES corporate, even if you are on a BES) onto your computer if you don't already have it.
    Step 3 - Search for CrackMem and DL and install this app on your computer if you don't already have it.
    Step 4 - Remove all previous OS install files you might have installed on your computer. Then download the latest official BlackBerry OS file for your device and install it onto the computer.
    Step 5 - Connect the BBY while it is up and running normally, and open CrackMem. Make sure the phone model and OS you installed above is on the list on the left.
    Step 6- In CrackMem there is an option called Wipe Device. Click this and follow the prompts to Brick your phone.
    Step 7 - CrackMem should load the BlackBerry Application Loader which will run you through reinstalling your OS after it finishes bricking the phone. Now you have a factory fresh OS load.
    Step 8 - Activate the phone on the BES or push the service books on BIS, depending on which one you use. You may need to sync your PIM data back from whatever program you use (Outlook, etc).

    That should fix ANY problems, although it is like using sledge hammer to hang a picture; gets the job done, but obliterates everything in the process.

    Just remember, free advice is worth exactly what you pay for it, so if something goes wrong, don't blame the person who gave you the free advice.
    06-22-09 04:27 AM
  3. yoe-yoe's Avatar
    I got that error after I updated my Viigo and tried to open it. It took me a while but figured out I had to change the permissions for it. Don't know if that helps.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-22-09 06:56 AM
  4. sgwan's Avatar
    If you're still running .167, just update to a newer OS. When I was on .167 I got it constantly, since changing to .266 I have never seen it again. I didn't uninstall any apps nor brick my phone. If you don't want to update you'll need to pull the battery and try restarting again. You might have to do this several times but eventually everything will come back. To me it's easier to upgrade the OS.
    06-22-09 07:11 AM
  5. bt224's Avatar
    Most of the time a simple battery pull will clear these errors.
    06-22-09 07:49 AM
  6. Steve_S_T's Avatar
    I had this problem and battery pull did not help as it was caused by one of my third party apps - BBSMart Alarms Pro. The only reason that I found this out was when I upgraded it and, after the re-boot, the error message didn't return. Depending on how many apps you have, it might be worth just simply re-installing them one at a time, a bit of a pain but worth trying before any of the really drastic solutions or even the more involved OS re-install/ upgrade.
    06-22-09 09:56 AM
  7. webhead's Avatar
    I had the same problem with the null exception pop up. I called ATT then talked to the RIM guys and went through a lengthy diagnostic process. I ended up getting my Bold replaced.

    Yes, that was a pain in the axe!
    06-22-09 01:01 PM
  8. Gelobster's Avatar
    I got that error after I updated my Viigo and tried to open it. It took me a while but figured out I had to change the permissions for it. Don't know if that helps.

    Posted from my CrackBerry at wapforums.crackberry.com
    LIFESAVER! I had been fussing around with my OS thinking that something was f-ed up or incompatible. I set everything to allow and it fixed it. Do we know which specific permission causes the error?

    Viigo Error
    java.lang.NullPointerException
    06-30-09 10:09 PM
  9. alonzo12's Avatar
    hi,
    im usually getting this problem when im downloading a pic that someone send it to me via whatsapp.
    so how can i solve is there anyone that can help me?
    thank you in advance.
    04-28-13 12:02 PM
  10. alonzo12's Avatar
    ya 27ab somebody replyyy
    05-03-13 08:26 AM
  11. alonzo12's Avatar
    wlke ya shramit whyyyyyy whyyyyyyyyyy is this happening to me whyyyyyyyyyyyyyy
    05-03-13 10:59 AM
LINK TO POST COPIED TO CLIPBOARD