1. halter91's Avatar
    This is the 2nd time I've had issues with this. This started on Sat. Every time I type, its skips and misses things I've typed. I have to go back, and retype just about everything. Last type I wiped the device and restored it. Wondering if anyone else is having this issue?
    05-06-12 04:33 PM
  2. Fubaz's Avatar
    not to be obvious, but are you sure you are pressing the keys correctly?
    what device are you on? your profile says 8350

    is it the original keypad?
    any moisture damage?

    maybe a battery pull?
    05-06-12 06:33 PM
  3. MsBrittz1016's Avatar
    Im having issues typing on my 9900 the S G L K & M keys won't always work on the first press I have to type more slower and hit those keys more then once its very frustrating I didn't drop the device this problem happened out of the blue and has gotten wore over the past week. No warrenty on this device because I won it and my upgrade isn't up until nov. I really don't want to go back to my 9700 & im too scared to try and replace the key pad myself :-S
    05-06-12 08:24 PM
  4. berry_addict's Avatar
    This is the 2nd time I've had issues with this. This started on Sat. Every time I type, its skips and misses things I've typed. I have to go back, and retype just about everything. Last type I wiped the device and restored it. Wondering if anyone else is having this issue?
    I have been expieriencing the same problem since I updated to 7.1 with Rogers. Don't know if it's normal with upgrading to 7.1
    05-06-12 08:31 PM
  5. halter91's Avatar
    Sorry, 9930 Bold. Guess i should upgrade my profile. Anyways, I'm sure, it just started a while ago, did a restore and same thing. Just like MsBrittz, i have to type slow, press harder. very weird.
    05-06-12 08:54 PM
  6. MsBrittz1016's Avatar
    I don't think its the OS though... I upgraded to 7.1.0.402 a while ago this issue Occured this past week its very frustrating
    05-06-12 09:21 PM
  7. mssca's Avatar
    There has been hardware issues with OS 7 bold 99xx. Even I had issues on my first few BB 99xx.

    There are many threads here on this topic and I would read and check if you have a hardware issue. You are still under warranty.

    Sent from BlackBerry Bold 9900
    05-06-12 09:44 PM
  8. mssca's Avatar
    I don't think its the OS though... I upgraded to 7.1.0.402 a while ago this issue Occured this past week its very frustrating
    Then it is most likely a hardware issue. I hope you find a way to either fix it or replace it.

    Sent from BlackBerry Bold 9900
    05-06-12 09:48 PM
  9. GlowingBlue's Avatar
    I don't know if you have something like we have in Toronto... Most people would just bring it to Pacific mall and there will be someone willing to fix it at a bargain price!

    maybe just a simple keyboard swap is all that it needs


    Sent from my BlackBerry 9900 using Tapatalk
    05-06-12 10:10 PM
  10. FBA's Avatar
    It is hardware. It's either the keyboard or the ribbon below the keyboard. It's a simple fix and simply opening and cleaning may even resolve the issue. Worst case, buy a new keyboard and ribbon to fix it (E-bay). There are complete disassembly instructions for the 99xx Bold all over the web, including YouTube videos. At this point, you have little to lose by trying to repair it. Failing that, take it to a repair center - as I said, easy fix.
    05-06-12 10:52 PM
  11. Peritaxis's Avatar
    This is the 2nd time I've had issues with this. This started on Sat. Every time I type, its skips and misses things I've typed. I have to go back, and retype just about everything. Last type I wiped the device and restored it. Wondering if anyone else is having this issue?
    I've had that problem for about a month. At first it was only the letter b skipping. Then k, c, well, more and more letters started to do this. n doubles itself often, along with y, and a few letters. Capitalization key sometimes skips, and neither does ALT.

    I wrote BlackBerry Help on Twitter, and they suggested to wipe the phone and reinstall the software. After a security wipe and loading the newest OS 7.1, it was even WORSE.

    I've talked to Rogers sales reps and I'll be sending it in tomorrow to Rogers and receiving a Loaner.
    05-06-12 11:18 PM
  12. Umar Mohyudin's Avatar
    I also am experiencing this problem with my Blackberry bold 9900
    05-15-13 11:26 AM
  13. Farrris's Avatar
    Similar to me, I think my keyboard was dead. Need to replace new one..
    05-15-13 11:56 AM
LINK TO POST COPIED TO CLIPBOARD