12-09-13 12:42 PM
26 12
tools
  1. Phipson's Avatar
    Hello, everybody!

    I posted a similar question a while ago in the Berrylicio.us-Thread but now I'm curious if anybody could help me.

    The story: I bought a 9900 on eBay some months ago and it was quite devastated. It has dust in the display and does not look quite new. So I happen to download a new OS and tried it some days. The GPS worked in the beginning but as I installed another OS it would not do so anymore. I found out that ONLY the .862 standard OS would do the trick and the GPS working. Any other standard or hybrid OS would run fine but the GPS would not. I considered it a hardware issue as the device seemed to have a bad past.

    But yesterday I got another Bold 9900 and tried the same. I installed the new .1047 OS and the same issue happened again! No GPS! I haven't tried the .862 OS, yet but I assume it will do the same as on my older Bold.

    OK, that's the background. Has anyone an idea of what the issue could be? Am I just having extensively bad luck on BlackBerry smartphones?

    I'd appreciate any help! Thanks in advance.
    Last edited by Phipson; 09-23-13 at 03:32 PM. Reason: Tiredness
    09-23-13 03:31 PM
  2. sbx9900's Avatar
    just wondering if you have done any battery pull yet after installing an OS. Usually, right after installing an OS, some issues appear that go away after a battery pull.
    09-23-13 07:33 PM
  3. Phipson's Avatar
    just wondering if you have done any battery pull yet after installing an OS. Usually, right after installing an OS, some issues appear that go away after a battery pull.
    Yes, sir, did a couple of 'em. Unfortunately, it did not work out. :/

    Sent from my BlackBerry 9900 using Tapatalk.
    09-24-13 12:10 AM
  4. goodayeh's Avatar
    What axactly happens when trying to use GPS ?
    Do you get error messages ?
    09-25-13 06:48 AM
  5. Phipson's Avatar
    What axactly happens when trying to use GPS ?
    Do you get error messages ?
    Thanks for your question. I forgot to mention that.

    No, nothing happens. If I try to refresh the position out of the options menu, just nothing happens and I get a message that the refreshing failed. When I try to use BB Maps just nothing happens, not even a close find of my position. Under the working OS I usually get at least a position that's near my actual one (through mobile use, I assume). But on any other OS the Maps won't do anything and stays on the world map. :/

    Sent from my BlackBerry 9900 using Tapatalk.
    09-25-13 02:27 PM
  6. goodayeh's Avatar
    This may be a stupid question - you refreshed your location while outside , right ?
    I have attempted it while inside and wasn't finding my position .
    As soon as I tried outside , it worked.
    09-25-13 04:49 PM
  7. Phipson's Avatar
    This may be a stupid question - you refreshed your location while outside , right ?
    I have attempted it while inside and wasn't finding my position .
    As soon as I tried outside , it worked.
    Actually, no, I did not do this outside. But that does not seem necessary. With the working OS, I could do that from the inside, near the window and I would get a number. Not very accurate, indeed, but it did something. And with any other OS, there's plain nothing. :/

    Sent from my BlackBerry 9900 using Tapatalk.
    09-26-13 12:48 AM
  8. robsteve's Avatar
    You may have something set differently in the software. I haven't used my 9900 in a while but there was an option to use assisted GPS for location services that is not set on the later OS. I am not sure if this option was for cellular assisted or for using the wifi network to figure out where you are. I think it was for using the wifi network to figure out where you are. I figured this out when I took a router home from my cottage and set it up at home. Every time I tried to find my position at home, it showed I was at my cottage, because of the router.
    09-26-13 07:35 AM
  9. Phipson's Avatar
    You may have something set differently in the software. I haven't used my 9900 in a while but there was an option to use assisted GPS for location services that is not set on the later OS. I am not sure if this option was for cellular assisted or for using the wifi network to figure out where you are. I think it was for using the wifi network to figure out where you are. I figured this out when I took a router home from my cottage and set it up at home. Every time I tried to find my position at home, it showed I was at my cottage, because of the router.
    As far as I checked those options out, I had always the same options activated. And it seemed that neither the wifi or cellular data helped whatsoever. (What a sentence...). What a pity!

    Sent from my BlackBerry 9900 using Tapatalk.
    09-26-13 08:58 AM
  10. robsteve's Avatar
    It wasn't a really obvious option, but may something in the privacy setting or send data to BlackBerry. Once I turned it off, it no longer used the wifi to try to position me.

    If you go outside and get a fix after a couple of minutes, the on device GPS is working. If it works outside it is just a problem with the software either a setting or a software incompatibility with your carrier's network.
    09-26-13 12:32 PM
  11. Phipson's Avatar
    It wasn't a really obvious option, but may something in the privacy setting or send data to BlackBerry. Once I turned it off, it no longer used the wifi to try to position me.

    If you go outside and get a fix after a couple of minutes, the on device GPS is working. If it works outside it is just a problem with the software either a setting or a software incompatibility with your carrier's network.
    Thanks for your hint. Do you know if I could this thing to work when it's a carrier's problem? Is there a driver out there to replace, by any chance?

    Sent from my BlackBerry 9900 using Tapatalk.
    09-26-13 02:19 PM
  12. robsteve's Avatar
    Just to be clear, the 9900 GPS will never work inside if you have network assist disabled in the software.

    If it is not working outside even after a reboot and a couple of minutes to find the position, try starting BlackBerry Traffic. I found that this program seemed to bring the GPS back to life if another program or setting had it turned off.

    Your best bet for software would be to try one of the hybids in the OS section.

    http://forums.crackberry.com/hybrid-os-f224/
    09-26-13 02:41 PM
  13. iamq's Avatar
    I've had this problem - even with assist on and outside 10 mins for a fix?!

    I did notice while poking about in the E-Screen one day there is no IP server specified for the AGPS option. At some point I'll test what happens when I put the Nokia AGPS server host details in.

    GPS works on my current software but its still very very slow to get a fix (like upto 10 min with valid almanac data). My old N95 will get a full fix (with valid almanac data) within a few sec's, Even when its been offline for a long time and has no valid almanac it only takes a min or 2. Granted its a different phone, chipset and so on - but BB GPS is really really poor IMHO.
    10-01-13 04:06 PM
  14. CrazyJo82's Avatar
    I'm curious to know what issue you had... I just got a 9900 and the map sucks compared to the 9700 I had.

    The map on the 9900 i have is not accurate... it's off by about 500m to 1km... and it does not follow as i move and it doesn't have the speedometer indicator... the map is version 6.2.0.22
    10-15-13 11:59 AM
  15. Phipson's Avatar
    I'm curious to know what issue you had... I just got a 9900 and the map sucks compared to the 9700 I had.

    The map on the 9900 i have is not accurate... it's off by about 500m to 1km... and it does not follow as i move and it doesn't have the speedometer indicator... the map is version 6.2.0.22
    Hi there!

    The issue I had wasn't really connected to BB Maps. It was the issue that the GPS didn't work (and therefore the Maps, I suppose). It just didn't do it and when it did, eventually, it was way off. Maybe you have the same problem.... What's your OS' version?

    Sent from my BlackBerry 9900 using Tapatalk.
    10-16-13 02:12 AM
  16. CrazyJo82's Avatar
    updated to 7.1.0.1047 and gps has miraculously started working properly and it actually shows the direction of where i'm going.

    i wonder if it's bb server or something. my 9700 had problem when it didn't load the map and then started working again...
    10-19-13 02:47 PM
  17. Phipson's Avatar
    updated to 7.1.0.1047 and gps has miraculously started working properly and it actually shows the direction of where i'm going.

    i wonder if it's bb server or something. my 9700 had problem when it didn't load the map and then started working again...
    Hm, very strange! I had this miracle one but it failed to stay. I do absolutely not know what might be the problem. Does your GPS still work?

    Sent from my BlackBerry 9900 using Tapatalk.
    10-22-13 03:52 PM
  18. CrazyJo82's Avatar
    i just recently updated to 7.10.1098 and haven't tested the map yet.
    11-25-13 09:57 AM
  19. Phipson's Avatar
    i just recently updated to 7.10.1098 and haven't tested the map yet.
    Please let me know when you experience any difficulties. I thought about switching to that OS but disregarded it because no OS brought any new luck for me.

    Sent from my BlackBerry 9900 using Tapatalk.
    11-26-13 08:39 AM
  20. Legal Eagle's Avatar
    Please let me know when you experience any difficulties. I thought about switching to that OS but disregarded it because no OS brought any new luck for me.

    Sent from my BlackBerry 9900 using Tapatalk.
    Don't usually use GPS but just gave it a try for you.

    .1098 and BL Hybrid RC20.

    Was indoors when I tried and it took a while to scan but did so successfully.
    11-26-13 09:06 AM
  21. Phipson's Avatar
    Don't usually use GPS but just gave it a try for you.

    .1098 and BL Hybrid RC20.

    Was indoors when I tried and it took a while to scan but did so successfully.
    Many thanks, Legal. Nice from you! Hm, maybe I'll give it a shot with the .1098.

    Sent from my BlackBerry 9900 using Tapatalk.
    11-30-13 11:09 AM
  22. iamq's Avatar
    And I've just tested the current O2 UK build and it appeared to work somewhat better than before. It gave me a fix inside in a timely manor.

    When I say timely I mean the 'Refresh GPS' option didn't actually time out and require a 2nd or 3rd try. When I am out next I'll see if its as quick picking up a new location having been offline for a while.

    No issues with BBMaps or Google maps (Although all my stared places where lost again)
    11-30-13 11:10 AM
  23. Phipson's Avatar
    And I've just tested the current O2 UK build and it appeared to work somewhat better than before. It gave me a fix inside in a timely manor.

    When I say timely I mean the 'Refresh GPS' option didn't actually time out and require a 2nd or 3rd try. When I am out next I'll see if its as quick picking up a new location having been offline for a while.

    No issues with BBMaps or Google maps (Although all my stared places where lost again)
    Thank you for your input! Well, I just put my hopes aside that my 9900 will ever work fine with me. :/ But maybe I'll try the actual OS and/or the RC20 Berrylici.us version. If I do, I keep you posted.

    Sent from my BlackBerry 9900 using Tapatalk.
    12-01-13 06:07 PM
  24. iamq's Avatar
    And just a quick update to say I had the phone out and about yesterday and again GPS gave me a lock in a timely manor (Its still not as fast or as good as my old Nokia N95-2 though) from being switched on a few miles away from where it last had its fix. Based on my general usage of GPS on this phone it appears to be one of the 'better' software builds.
    12-06-13 07:57 AM
  25. CrazyJo82's Avatar
    it's weird... i'm not sure what's going on... the map works but the gps is wonky. it's off by almost 1km from my actual location and it doesn't track my movement when i'm moving... it updates my location every few seconds but it no longer has the speedometer.
    12-07-13 10:01 PM
26 12

Similar Threads

  1. WhatsApp problem, try older version?
    By Pettson in forum BlackBerry Bold Series
    Replies: 6
    Last Post: 01-23-18, 12:13 PM
  2. Instagram Side Load Not Working
    By Shawn Bellon in forum PlayBook Apps & Games
    Replies: 5
    Last Post: 09-26-13, 04:58 PM
  3. Blackberry Limited not found on Google Play Store anymore?
    By Bsbudd in forum General BlackBerry News, Discussion & Rumors
    Replies: 52
    Last Post: 09-23-13, 09:06 PM
  4. Text Message Problem
    By ZACKCOMMAKERSKA in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 09-23-13, 05:00 PM
  5. Browser problems (back button keeps going)
    By edberry12 in forum BlackBerry Q10
    Replies: 3
    Last Post: 09-23-13, 03:39 PM
LINK TO POST COPIED TO CLIPBOARD