1. andyp's Avatar
    I've had an issue with my trackball for a while now. Basically it doesn't push in. I can still click it & it works fine, but I don't get that "clicking" feeling & it doesn't really compress when I press it in, so it's almost like I don't even know if I actually pressed it or not until I actually see whatever I pressed it for working. I mean it still works fine, but it's pretty annoying.

    I finally had enough & ordered a new trackball from cnn.cn, installed it, and it's the exact same! Does anybody know what I'm talking about or have any suggestions?

    Thanks.
    06-14-09 05:55 PM
  2. Username00089's Avatar
    I'd just get a warranty replacement instead of breaking my head trying to fix
    the issue myself. No reason you should have to go through this.
    06-14-09 06:20 PM
  3. andyp's Avatar
    I'd just get a warranty replacement instead of breaking my head trying to fix
    the issue myself. No reason you should have to go through this.
    Would they know that I took it apart to try to do it myself (not sure if there's a security seal I would have broken or whatever)? Because if so I'm pretty sure that would void the warranty.
    06-14-09 06:25 PM
  4. venomgirl's Avatar
    Would they know that I took it apart to try to do it myself (not sure if there's a security seal I would have broken or whatever)? Because if so I'm pretty sure that would void the warranty.
    I'd have to agree with the warranty replacment, basically cleaning it w/saline won't help & before it gets worse & you get blamed for it you're better off simply getting it taken care of a.s.a.p.
    06-14-09 06:31 PM
  5. Username00089's Avatar
    Would they know that I took it apart to try to do it myself (not sure if there's a security seal I would have broken or whatever)? Because if so I'm pretty sure that would void the warranty.
    If the sticker on the hex screw isn't there anymore, then they'll know.
    06-14-09 06:37 PM
  6. SmokeyDaBear's Avatar
    I'm having the exact same problem. I can't tell if the click worked until the screen changes or if I see the browser's progress bar. I was thinking about swapping out the trackball but after reading this post I guess I'll be contacting my provider. I just don't feel comfortable with the idea of getting a refurb to replace my Bold that I've taken good care of.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-09 07:44 PM
  7. GibMcFragger's Avatar
    It's the little dome "clicker" under the track ball that provides the feedback when you press down on the ball. They fail....mine did. Unfortunately, they are part of the main board and you have to warranty your phone. I don't think you can buy the part anywhere to replace it yourself.
    06-14-09 11:30 PM
  8. lilro's Avatar
    I'm having the same problem with my 8900. I got a replacement coming in the mail now. I'm surprised it's this common with the Bold. I hope it doesn't happen on my replacement.
    06-15-09 12:56 AM
  9. SmokeyDaBear's Avatar
    oh well, called Rogers yesterday afternoon and got my replacement this morning! Now that's service!
    06-18-09 01:15 PM
LINK TO POST COPIED TO CLIPBOARD