1. omg516's Avatar
    Has anyone tried this? I'm picking one up today but I just read several threads about unlocked Bolds not working on Tmo because the service books aren't out yet. I know this is the case with Rogers branded Bolds but is this the case for At&t branded Bolds also?
    10-27-08 02:31 PM
  2. cinnamin's Avatar
    there is a thread about this already did you do a search?
    10-27-08 02:38 PM
  3. omg516's Avatar
    I read threads about Rogers branded Bolds on Tmobile but not the as yet unreleased At&t branded Bold on Tmo.
    10-27-08 03:14 PM
  4. cinnamin's Avatar
    oh ok i am looking for the same kind of information myself i would like to see what works and what doesn't so far with the rogers unlocked bolds mms and the blackberry browser wasn't working. but there's a workaround i can't wait to see if it will work for the at&t branded bold. which i will have soon.
    10-27-08 03:46 PM
  5. omg516's Avatar
    I'm picking one up today. If I have to use Opera Mini thats fine, as long as I can get the email and all of the 3rd party apps like jivetalk and viigo to work.
    10-27-08 03:58 PM
  6. pltaylor's Avatar
    Doesn't matter if it's At&t or Rogers. Here is the work around. http://forums.crackberry.com/f83/how...+bold+t-mobile PM me if you run into problems. Actually PM me if it goes smooth too as I'm trying to make it as simple as I can and would appreciate the input.
    10-27-08 04:07 PM
  7. naszero's Avatar
    I think the more important question is, where are you getting the AT&T branded Bold from?
    10-27-08 08:12 PM
LINK TO POST COPIED TO CLIPBOARD