1. MisterShark's Avatar
    I have a few pictures that when I'm flipping (finger-swiping) through only display as the picture file icon rather than opening and displaying the picture itself.
    If I zoom in then the picture opens, but as soon as I zoom back out it displays as the picture file icon again.

    A few details that could be important but which fail to point me towards causality none the less:
    - The files in question have the 'hidden' property
    - The files in question reside in a file folder which has the 'hidden' property
    - Using the 'Explore' file browsing utility and after selecting 'Show Hidden' almost all pictures display without any problems when clicked, and finger-swiping from picture to picture opens the images fine...with the exception of the problematic picture files I'm writing this for.

    While experimenting with the problematic files I tried a couple of different things just to see if anything would change:
    - Tried cutting/pasting one of the problem pics to the usual 'Pictures' folder, removing the hidden file attribute: the picture displays as a thumb the way it should and opens fine.
    - After moving that pic back to the hidden folder I created and restored it's 'hidden' attribute: it went right back to the abnormal behavior (wherein I had to open then zoom the pic to see it's actual content).
    - Tried re-naming the picture: it made no difference


    So I'm wondering if this is happening to anyone else and if this is a known issue.
    03-23-12 10:39 AM
  2. darth1sbw's Avatar
    I had this problem when I switched from my 9900 back to my 9800 for a trip overseas. Try copying all the files to a computer from the SD card; reformatt the SD card (from BB options menu); then copy the files back over to the BB once formatting is complete.

    Before copying files back to the BB, look for hidden files named of the sort: "bbthumbs400x400" or something like that. Sometimes when you switch devices the resolutions aren't the same. In my opinion, deleting those 'bbthums' files helps.
    05-10-12 06:11 PM
  3. MisterShark's Avatar
    I had this problem when I switched from my 9900 back to my 9800 for a trip overseas. Try copying all the files to a computer from the SD card; reformatt the SD card (from BB options menu); then copy the files back over to the BB once formatting is complete.

    Before copying files back to the BB, look for hidden files named of the sort: "bbthumbs400x400" or something like that. Sometimes when you switch devices the resolutions aren't the same. In my opinion, deleting those 'bbthums' files helps.
    Since initially reporting this problem the issue has been resolved. Thanks for your suggestion though.
    As I recall: I think I deleted the BBThumbs.dat, removed the MicroSDHC card, removed battery, re-inserted & MicroSDHC card, and replaced the battery.
    At that point, when first opening the pictures gallery I believe the OS recreated the BBThumbs.dat and the thumbs displayed the way they should.
    05-11-12 10:59 AM
  4. mqchards's Avatar
    When I ran into this issue recently I deleted a BBThumbs.dat file from the root of the SD card and two files (thumbs116x116.dat and thumbs480x360.dat) from Blackberry\system\media when mounted as a USB drive. After making sure every small thumbnail displayed and flipping through every picture, there was no longer a BBThumbs.dat file and the size of the thumbs480x360.dat dropped from about 546 MB to 16 MB. The thumbs116x116.dat remained about the same size (about 120 MB). No card removal, no battery pull.
    06-07-13 12:48 AM
LINK TO POST COPIED TO CLIPBOARD