1. jon12001's Avatar
    So i have a bold its a unlocked version and im trying ot use it with rogers and everytime i turn it on and turn on the 3g mode it crashes and sort of restarts to a white screen with really small print that says radio core catfailed (i think)
    if i keep it on 2g it lasts a little longer before it crashes.

    Anyone actually know what my problem is here other then i should have kept my iphone 3g ?

    Thanks
    10-24-08 01:29 AM
  2. bodisaffa's Avatar
    what OS are you running?? your symtoms sound like that of early OS releases of which a simple OS upgrade will fix.

    What's your OS??


    To find go OPTIONS - ABOUT
    10-24-08 01:33 AM
  3. greg24's Avatar
    Yea if you don't have the latest OS, you should get it. Hear it helps out a lot

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-08 01:42 AM
  4. Bla1ze's Avatar
    Your OS is bunked...you need to upgrade to the latest and even if you have the latest it's still bunked anyways..

    Upgrade

    and.....

    BlackBerry 101: How to Install or Upgrade to a New RIM BlackBerry Operating System (OS) | CrackBerry.com
    10-24-08 01:45 AM
  5. aeldes1's Avatar
    Did you buy it from a legitimate source?
    10-24-08 02:39 AM
  6. jceezy's Avatar
    yeah, did you buy it from a legitimate source? it says you're with Rogers... why did you have to buy an unlocked version?
    if you go to rogers.com/boldupgrade, yo can update to their official OS, which is .162
    10-24-08 08:58 AM
  7. jon12001's Avatar
    This is actually a movistar blackberry bold that is unlocked I bought it from a good friend of mine that has been using it with rogers for over a month and a half. But he was just using it as a pay as you go phone and he only ever had it in 2G Mode. Well after putting in my sim and booting it up it was fine then when i put on 3G the little arrows in the top right corner starteed moving showing it was connecting then all of a sudden it shuts of restarts to a white screen that says (Radio Core Catfailed!) Only way i can get it to go back to the homescreen is to hook it up to the computer and reinstall a new OS. I loaded the rogers on it now and its fine it works in 2G i can make calls and everything.

    But i know as soon as i switch it 3G that white screen of death is going to be there ! Now i dont know if i should be installing the movistar software if that makes a difference? then would it have to be unlocked again ? i dont know let me know what you guys think. But right now i have the latest rogers one on it !
    10-24-08 09:38 AM
  8. jon12001's Avatar
    Another thing i should add my sim is still registered to my iphone because thats what phone rogers thinks im still using according to their system i would imagine. I havent called them yet to try and get the blackberry setup because i dont want to have it a waste of time if the blackberry is screwed.

    I dont know if thats affecting the 3G ?
    10-24-08 09:42 AM
  9. kaiso's Avatar
    If you have the latest Rogers on it, you should be able to use 3G without issue also I would think. Try it and see.
    10-24-08 09:44 AM
  10. jceezy's Avatar
    Another thing i should add my sim is still registered to my iphone because thats what phone rogers thinks im still using according to their system i would imagine. I havent called them yet to try and get the blackberry setup because i dont want to have it a waste of time if the blackberry is screwed.

    I dont know if thats affecting the 3G ?
    i would make the call and asked them to switch to the BB plan. This would affect your webbrowsing capabilities, pushed emails, etc.
    When I first got my bold, the rogers rep "accidentally" placed me into the iPhone 3g plan, after I had clearly mentioned that I have the Bold. I never received the "white screen of death" though
    10-24-08 10:55 AM
  11. jon12001's Avatar
    well just tried updating my sim card which someone said might be a problem and still everything was fine till 3G kicked in now its sitting at the white screen again saying radio core catfailed. Only way i can get out of this screen is to reinstall the OS again for the 8th time. Hey if anyone wants a mint 1.5 month old bold make me an offer and it yours !!

    But it only runs in 2G or edge uness you can fix it !
    10-24-08 11:36 AM
  12. kutikayla's Avatar
    Hey I know from AT&T the iphone sim card shouldn't work in other phones. When I upgraded they told me I had to use another one because when I put my iphone sim card in it wouldn't work. Just a thought

    Supposedly iPhone sim cards are just for iPhones thats what AT&T told me and it's clear that's what I experienced at least
    Last edited by kutikayla; 10-24-08 at 11:57 AM. Reason: added info
    10-24-08 11:56 AM
  13. odrich's Avatar
    Using my iphone sim in my bb as I write this. Unlocked on ATT no issues since day 1.
    10-24-08 01:06 PM
  14. EvolutionCSR's Avatar
    iphone's do not use a special sim card. . As for the OP's issue I have never myself seen that error message in years of using BB, maybe hardware issue? I would get warranty replacement.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-08 01:11 PM
  15. kutikayla's Avatar
    That's weird .When I first got my pearl I popped my 2nd gen iPhone sim in it and it said SOS on the service bars, it wouldn't work so I had to use the new one. But when I put my pearl sim card in the bold it was aok.
    10-24-08 01:14 PM
  16. jon12001's Avatar
    i guess the phone is screwed i dont know what to do to fix it everything seems to work fine until i select the option for 2g and 3g mode then it crashes and i get that error.


    so if someone wants to try and fix it send me an offer and its yours to play with ! might be a simple fix ?
    10-24-08 01:23 PM
  17. LuvmyBberry's Avatar
    FWIW I had the same experience as Kayla (not with the Bold, a curve) I had the iphone and when I couldn't stand it anymore switched to the curve, it wasn't the actual sim card that gave me problems but something they had to switch when I went from the iphone to the BB. They just kept calling me and asking me if it was working right yet and saying it was "because you had been on the iphone plan" and "your blackberry won't work right until we get you off that plan" (which took 2 days! ugghh) Also, there was another person in the store when I had gone to the actual AT&T store the first time who was having the same problem with a 8820 he had just bought coming off the iphone as well.
    Maybe it was just an excuse, but Curve works fine now without any problems.

    P.S. Congrats on your new Bold Kayla!! I have to wait until the 4th :-( LOL
    Last edited by LuvmyBberry; 10-24-08 at 02:02 PM.
    10-24-08 01:42 PM
  18. gnr-met's Avatar
    FWIW I had the same experience as Kayla (not with the Bold, a curve) I had the iphone and when I couldn't stand it anymore switched to the curve, it wasn't the actual sim card that gave me problems but something they had to switch when I went from the iphone to the BB. They just kept calling me and asking me if it was working right yet and saying it was "because you had been on the iphone plan" and "your blackberry won't work right until we get you off that plan" (which took 2 days! ugghh) Also, there was another person in the store when I had gone to the actual AT&T store the first time who was having the same problem with a 8820 he had just bought coming off the iphone as well.
    Maybe it was just an excuse, but Curve works fine now without any problems.

    P.S. Congrats on your new Bold Kayla!! I have to wait until the 4th :-( LOL

    What was it that you didn't like about your iphone that made you go back to the bb? How's are browsing capabilities now?
    10-24-08 02:05 PM
  19. Branta's Avatar
    well just tried updating my sim card which someone said might be a problem and still everything was fine till 3G kicked in now its sitting at the white screen again saying radio core catfailed. Only way i can get out of this screen is to reinstall the OS again for the 8th time. Hey if anyone wants a mint 1.5 month old bold make me an offer and it yours !!

    But it only runs in 2G or edge uness you can fix it !
    I think you still have to tell us which software version you're using. If it is earlier than v4.6.0.162 you certainly need to upgrade. IMO you need to reload the OS anyway because what you are reporting could be due to corrupted software.

    The latest version approved for public release is .167 which became available this week, so I suggest you go for that and see if it clears the problem. Forget about buggy earlier releases.
    10-24-08 02:16 PM
  20. JosieGrossie's Avatar
    Hey I know from AT&T the iphone sim card shouldn't work in other phones. When I upgraded they told me I had to use another one because when I put my iphone sim card in it wouldn't work. Just a thought

    Supposedly iPhone sim cards are just for iPhones thats what AT&T told me and it's clear that's what I experienced at least
    Nope, I'm with Rogers and went from a Curve, to an iPhone, to a Bold ... all with the same SIM card.
    10-24-08 05:19 PM
  21. jon12001's Avatar
    alright thanks everyone for the help i just sold the phone and am back on a curve for now i just got a sweet deal from rogers. even though i upgraded to a 16 gb iphone in aug. for 299.99 there sending me a bold as well for the same price and i keep my iphone ! so 16gb iphone and a blackberry bold for 600 bucks ! cant beat that deal.
    10-24-08 05:42 PM
LINK TO POST COPIED TO CLIPBOARD