1. jayt04's Avatar
    Hey all,

    I have a real quick question.. When you are on a call on your berry, if you look at the screen on the right it has "my number"..mine says "unknown" and I cannot figure out where I input my number so it shows the correct number??

    Does anyone have an idea on how this can be done?

    Thank you in advance!

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 07:56 PM
  2. apbthe3's Avatar
    The only place I know of is in Options / Advanced Options / SIM Card. Click the menu button and "Edit SIM Phone Number" comes up. Mine has my number in it but if yours has nothing, maybe that's the spot.

    That being said, I don't have the guts to change it on mine to see if it works, so let me know
    04-29-10 08:09 PM
  3. blueyestm's Avatar
    click the green phone button, then bb button to go to options --> general options --> Show "My Number" yes/no
    04-29-10 08:21 PM
  4. jayt04's Avatar
    click the green phone button, then bb button to go to options --> general options --> Show "My Number" yes/no
    Hi blueyestm,

    That worked thanks for that! I entered my number then it re-registered me on the network and now it shows up. And phone still works fine so don't be afraid to try it :-)

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 09:46 PM
  5. pilothaz's Avatar
    Good job blueyestm.
    04-30-10 12:50 PM
LINK TO POST COPIED TO CLIPBOARD