1. misaac's Avatar
    Just looking for opinions here. Not sure if my 9650 has issues or is ok.

    I got it a week ago. After getting it activated, I noticed that the wifi and bbm didn't work. Called Verizon and spent about 90 minutes on the phone with them. Had to do a master reset on the phone. It got the two issues resolved.

    This last Saturday, I noticed that I could not send picture mail. So another 90 minutes on the phone and it's good to go. Had to go through several different things, including adding an "a-key", whatever that is. Ended up getting transferred to a higher tier tech support person that said it was a configuration issue in their system.

    Yesterday my wifi was cutting on and off and was very slow. Called Verizon again. Agent had me put no security on my home wireless router and the phone connected and worked. I put the security feature back into the router and the phone continued to work, although the phone is still very slow when connected to wifi. I download the Bolt browser and I think that it runs much better than the blackberry browser, but I think it should be faster than what it is.

    So, with all of these issues and Verizon stating they would replace it, do you think I should? Is the wifi just slow on BB's and it is something I just have to accept, or should it's speed match or be close to the speed of my laptop on wifi?

    I am very happy with the phone despite these issues, but if it has issues that may keep popping up, I'd like to get it replaced before my 30 days is up.

    One last thing. When I ping my phone's IP address from my laptop, that avg speed is about 400ms... seems to me it should be way better than that.
    Last edited by misaac; 06-15-10 at 02:13 PM. Reason: forgot to mention something
    06-15-10 02:10 PM
  2. papped's Avatar
    There's no way for us to tell what the problem is.. It could be your router not liking the phone. The other issues could have been service issues.

    You could swap the device and see if it all magically fixes. If not then it's some sort of service or software or your local network problem.
    06-15-10 02:12 PM
  3. misaac's Avatar
    Thanks for the reply.

    I think I may give it a few more days, just to see if any other issues pop up. Plus I want to test the wifi more on some other routers and see how it behaves.
    06-15-10 02:56 PM
  4. juttin3's Avatar
    I'm trying to exchange mine and sprint is not making it very easy for me. Telling me I have to go to a store for them to troubleshoot. I bought this online and I'm within 30 days.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-15-10 03:17 PM
LINK TO POST COPIED TO CLIPBOARD