1. anon(3870164)'s Avatar
    Let me explain what happened. This time my problem cannot be solved by just host routing table > register now or battery pulls.

    I am using Umobile (I am in Malaysia) monthly plan for 6 months already... Having hiccups once in awhile but was okay until 2 weeks ago, it was sort of disconnected so I thought it's just some normal downtime. Then I used another telco's sim card temporarily for 2 weeks and then switched back to umobile. It's the same, totally can't connect to BIS service.

    Then I called customer service, my BIS is back BUT only a few useless service books (WAP, WIFI etc, no BB-related service books) are pushed into my device. There should have 20~30 service books. No matter how many times I did battery pull it's the same.

    Then I went to the service centre, they troubleshooted for 1 hour, and told me that my simcard BIS worked with other phones but NOT my bb, so it's my phone prob. BUT ANOTHER TELCO's sim card WORKS JUST WELL! So I went Brightstar service centre and that staff told me they need to reflash my phone to check if it's my phone's prob...

    They asked me to allow them to flash my phone. So I refused (I have tonnes of apps to back up) and I went home and reload my OS. The outcome? SAME! Only a few service books are pushed...

    Until now I have no definite solution, I cannot surf or do anything because there are no service books. Umobile said they can't help because other phone works with my SIM. Brightstar can't help either except sending to warranty, but I'm pretty sure it works with my other simcard, so shouldn't be hardware problem.

    Now, is there any reason behind this? Hope some pros can help. Thank you in advance.

    *Sorry for my poor english and such a long essay
    08-07-11 02:20 AM
  2. laurah2215's Avatar
    Device-Advanced System Settings-Host Routing Table-Press BB Button and s elect Register Now. That should re-register your device with the network and hopefully send the service books. You also have the option of logging in to your carrier's BIS webpage and sending service books through that (if it's set up).
    08-07-11 12:55 PM
  3. laurah2215's Avatar
    I should have added that after you hit 'Register Now', wait a minute then do a battery pull. You should find that the service books are there when after the battery pull. That may be why it didn't work for you before if you just hit 'Register Now'. Need to be a battery pull after.
    08-07-11 12:57 PM
LINK TO POST COPIED TO CLIPBOARD