1. nothin2seehere's Avatar
    As good as the Bold has potential, it's not living up to my expectations. I'm going to my local Orange shop on my lunch break tomorrow to see if they can make the web browser work (90% of sites I want to look at have an XML formatting problem apparently) and if not, I'm getting a refund.

    Tell me: does crackberry.com work on your Bold?

    Edit 1: Whenever I post here with a problem it seems to fix itself. That is, web browsing ONLY seems to work effectively when I change to Hotspot Browser, and identify as Internet Explorer (or FF I presume). I sitll get the XML errors if I revert back to "Orange World" which makes this pretty useless for browsing away from WiFi areas.

    Is this problem going to be fixed with software revisions, or is "Orange World" some wacky walled garden where I'm deliberately being blocked?
    Last edited by nothin2seehere; 08-25-08 at 05:14 AM.
    08-25-08 04:57 AM
  2. Hazysky's Avatar
    Do you have an 'internet browser' to choose from as opposed to Orangeworld?

    For example I can choose from , internet bowser, o2 wap and o2 wap secure. The Internet Browser is the BB browser.
    Last edited by Hazysky; 08-25-08 at 05:47 AM.
    08-25-08 05:38 AM
  3. StikiGreenZ's Avatar
    I had similar problems with my Browser. I couldnt access Crackberry's WAp SITE OR m.youtube.com. It turned out when I used the Switch Device Wizard to migrate from the Curve, it moved over some settings to mess up the browser.

    Used desktop manager to purge all of the Browser items and it works like a charm now.
    08-25-08 07:29 AM
  4. nothin2seehere's Avatar
    Do you have an 'internet browser' to choose from as opposed to Orangeworld?

    For example I can choose from , internet bowser, o2 wap and o2 wap secure. The Internet Browser is the BB browser.
    I haven't seen this, no. My Home Screen has "Browser" and nothing else apart from the usual array of messaging etc.
    08-25-08 07:46 AM
  5. Montala's Avatar
    Another Orange 'customisation' perhaps?
    08-25-08 07:53 AM
  6. Hazysky's Avatar
    Try going to options > advanced options > Browser and have a look at the options for the default browser.
    08-25-08 07:54 AM
  7. SurrealCivic's Avatar
    my browser works just fine.. make sure you have Internet Browser selected, and view it in Page Mode. You should be able to see the entire website.
    08-25-08 08:10 AM
  8. nothin2seehere's Avatar
    Try going to options > advanced options > Browser and have a look at the options for the default browser.
    Options for Default Browser are Orange World and Hotspot Browser, but as I said, using Hotspot Browser means I can only browse the web when I'm connected to WiFi, meaning it's useless on the train etc.
    08-25-08 08:13 AM
  9. nothin2seehere's Avatar
    Another Orange 'customisation' perhaps?
    Maybe Perhaps I should cancel the contract and wait for it on O2? I was planning on just getting a replacement device..
    08-25-08 08:14 AM
  10. Hazysky's Avatar
    None of the other Orange users have reported this problem have they?

    Orange may well have 'crippled' the BB browser.

    It may be worth looking at your browser settings too, from your browser hit menu key and select options > browser configuration. check all options Make sure the emulation mode is set to Blackberry and see if the 'show images' option can be changed. The options on this device may well be different from mine as I do not have a Bold.... yet!

    It is possible that your device is faulty.
    08-25-08 08:18 AM
  11. Allyson Kazmucha's Avatar
    I would try to use a different browser like Opera Mini or Skyfire (do they have this for BB yet)...I had issues viewing some sits on the BB browser on my old Curve but never had an issue with opera mini.
    08-25-08 10:18 AM
  12. nigeltrevor's Avatar
    You should be able to use Internet Browser and all sites work perfectly on mine - not had a single problem, and certainly no XML errors....

    Must be a config issue I would think, as haven't had a browser problem on mine.

    There'll be no difference in the browser between O2 and Orange.
    08-25-08 10:33 AM
  13. nothin2seehere's Avatar
    Good news My Internet Browser has finally appeared, I think, as a result of a few SIM updates from Orange which came through a couple of hours ago. I'm so happy now, but I'm still going back to the shop tomorrow to get the 'Berry replaced for a brand new one.

    Thanks for everyone's help - this place is the best
    08-25-08 04:20 PM
  14. Hazysky's Avatar
    That's great and I think you are right to replace it.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-25-08 04:25 PM
  15. nigeltrevor's Avatar
    Good news My Internet Browser has finally appeared, I think, as a result of a few SIM updates from Orange which came through a couple of hours ago. I'm so happy now, but I'm still going back to the shop tomorrow to get the 'Berry replaced for a brand new one.

    Thanks for everyone's help - this place is the best
    Good to hear! Glad it's fixed!
    08-25-08 04:38 PM
  16. shuurajou's Avatar
    The issue you had is an issue with the RIM relay. Whenever Orange does SIM updates they resend provisioning requests to the RIM relay (such as what service books you should have). Wouldn't be anything wrong with your device. 'Orange World' web browser is a WAP browser, and as such will only read WML coded sites (WAP sites). Internet Browser is for everything .
    08-25-08 05:45 PM
  17. nothin2seehere's Avatar
    Thanks Shuurajou. Makes me feel better than it wasn't really Orange's fault then
    08-26-08 04:11 AM
  18. shuurajou's Avatar
    Well, as long as they sent the right provisioning request to RIM to begin with, yes .

    Posted from my CrackBerry at wapforums.crackberry.com
    08-26-08 04:24 AM
LINK TO POST COPIED TO CLIPBOARD