1. mars10#CB's Avatar
    Hi

    Does anybody know how to remove/delete the Input Language icon that appears in the top right hand corner of the blackberry? For e.g. "EN" appears on my blackberry every time I type an email or sms.

    Thanks for your time.


    Marissa
    11-16-08 10:56 PM
  2. teamtl's Avatar
    I had this problem too. What I did was use Desktop Manager and from there:
    Backup/Restore
    Advanced
    Open a previously backed up file that did not have the EN
    From that backed up file, click only on the Input Language Method
    In between the two boxes there will be two boxes with directional arrows, click on the bottom arrow (">>")
    A pop up box may occur and if it does click OK
    It will start scanning and should only take a few seconds.
    After this the annoying EN should be gone
    This has worked for me, although I do find that the EN will come back even when I haven't reset it or anything. So it may not be a permenant fix but it is something.
    11-17-08 11:14 AM
  3. djyeo's Avatar
    I am also looking for a permanent fix for this problem.
    11-17-08 12:40 PM
  4. ntm's Avatar
    I have this annoying problem too. I do not have any backups since I have my BES and it backs up wirelessly. I just got the Bold and this started happening.
    11-17-08 12:54 PM
  5. anon(2088)'s Avatar
    In DM > Add / Remove applications > advanced, is the input language support checkbox checked? If so, uncheck it...
    11-17-08 01:06 PM
  6. mars10#CB's Avatar
    Thanks all for your feedback.

    There is no 'input language support' checkbox in DM > Add / Remove applications (I am using DM v4.6).

    And similar to ntm, my bb bold is using BES wireless and therefore I don't have any backups.

    Is there any other solutions?
    11-17-08 09:00 PM
  7. jlopi's Avatar
    Hello,
    I have exactly the same problem on my Bold.
    And I confirm, as mars10 was saying : " There is no 'input language support' checkbox in DM > Add / Remove applications (I am using DM v4.6). "

    Have someone a solution ?

    Thank you very much!
    11-19-08 11:33 AM
  8. stella_bella's Avatar
    I had this problem, it annoyed the cr*p outta me! the only solution was when I upgraded my OS and it went away....I don't know how else to remove it, sorry
    11-19-08 11:39 AM
  9. jlopi's Avatar
    Thank you.
    I believe I will have to put up with this icon... because I don't need to restore my OS.
    11-19-08 12:44 PM
  10. rdawodu's Avatar
    Does anyone know how to fix this problem?
    12-04-08 10:56 PM
  11. danielx's Avatar
    I have this problem too! Occured when I switched input language

    Posted from my CrackBerry at wapforums.crackberry.com
    01-09-09 10:39 AM
  12. kingrx's Avatar
    This has happened to me and is annoying the crap out of me. I'm gonna try teamtl's method tomorrow.
    02-23-09 12:27 PM
  13. bungandy's Avatar
    yeah! me too!.. does anybody find solution??

    05-28-09 11:55 AM
  14. bbhp's Avatar
    As for OS 5.0 this can easily be changed: options -> language -> language ID (automatic/show -> hide)
    BootlegZani and boyriot like this.
    06-02-09 03:27 PM
  15. jonchos's Avatar
    As for OS 5.0 this can easily be changed: options -> language -> language ID (automatic/show -> hide)
    I was about to wipe my Tour due to this icon driving me nuts.
    I am glad I kept on reading, searching crackberry.com because I found your useful information.
    The icon is now gone.
    Now I can safely change languages and not have the icon driving me nuts.
    THANK YOU!
    07-19-09 09:13 PM
  16. Stevenojobs's Avatar
    There is still no solution for OS 4.xx ?
    09-17-09 07:43 AM
  17. NIKSTORM's Avatar
    Bump......same problem on my storm I hate it.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-09 09:40 AM
  18. NIKSTORM's Avatar
    I Used Dm To Erase Anything And Everything Language Based And Still No Help....i Hate This Thing!!!! Worst Part It Just Showed Up
    09-18-09 11:05 AM
  19. ranonranonarat's Avatar
    I figured out a solution that won't wipe your entire device, or have to go to a previous restore and lose current data.

    You do need to have a backup of your blackberry on your pc before the Language display was shown. Connect to PC and go to Advanced options in the "backup/Restore" of your Desktop Manager. Open the backup file and find "input Method Switcher option" from the backup file and transfer that to your device. (it will restore just that option).

    This worked for me.
    11-15-09 10:02 AM
  20. crazyson's Avatar
    As for OS 5.0 this can easily be changed: options -> language -> language ID (automatic/show -> hide)
    Thank you very much!!!
    I was soooo annoyed with that icon too~~~
    12-03-09 10:44 AM
  21. BootlegZani's Avatar
    Thanks for this. I guess people on an OS before 5.0 don't really have a fix.
    08-24-11 12:30 PM
LINK TO POST COPIED TO CLIPBOARD